Vraag Lightdm probleem na het installeren van xmonad, Ubuntu 14.04


Gisteren besloot ik Xmonad te installeren en uit te proberen op mijn laptop met een vrij nieuwe installatie van 14.04. Na het uitvoeren van een Xmonad-sessie besloot ik de Gnome-xmonad-optie (of iets dergelijks) te proberen. Alles wat ik zag was de achtergrond en geen van de toetscombinaties voor xmonad werkte, dus ik herstartte de aan / uit-knop.

Daarna startte de computer niet op met de Lightdm-login, alleen een grijs scherm. Ik kan ctrl + alt + F1 gebruiken om een ​​shell te openen. sudo service lightdm restart werkte niet en start alleen maar verteld dat Lightdm al actief was.

ik lees deze, maar het is niet echt van toepassing op mijn problemen. Ik heb geprobeerd toe te voegen sleep 2 volgens deze, maar het mocht niet baten. Ik weet niet zeker waar ik nu naar op zoek ben en besloot deze vraag te plaatsen voordat ik iets anders deed.

Ik ben overdag beschikbaar om logboeken te plaatsen en details te beantwoorden.

Bewerk 1: Output van sudo lshw -c display:

  *-display
       description: VGA compatible controller
       product: Haswell-ULT Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:66 memory:b5000000-b53fffff memory:c0000000-cfffffff ioport:6000(size=64)
  *-display
       description: 3D controller
       product: GK208M [GeForce GT 730M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:09:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=nouveau latency=0
       resources: irq:65 memory:b3000000-b3ffffff memory:a0000000-afffffff memory:b0000000-b1ffffff ioport:3000(size=128)

Bewerk 2: hardlopen sudo Xorg -configure resulteert in:

Fatal server error:
(EE) Server is already running for display 0
        if this server is no longer running, remove /tmp/.X0-lock
        and start again.

2
2018-06-23 08:44


oorsprong


Ervan uitgaande dat je al een nieuwe installatie hebt gedaan, werkte dit voor mij: askubuntu.com/a/409866/42720  Ik heb xorg.conf in verschillende mappen opgepakt en de back-ups overschreven, en toen tegen vergelijkbare problemen aangelopen als jij. Het is eenvoudiger om Xmonad de configuratie van de Lightdm-monitor te laten accepteren om xorg.conf te gebruiken. Als je inlogscherm dat configuratiebestand gebruikt, zal XMonad het vangen, maar niet anders, gewoon in mijn ervaring. - Peter Becich


antwoorden:


  1. Schakel over naar tty1, log in
  2. Stop lightdm:

    sudo stop lightdm
    
  3. Purge lightdm en installeer het opnieuw:

    sudo apt-get remove --purge lightdm
    sudo apt-get install lightdm
    
  4. Start lightdm

    sudo start lightdm
    

Laag grafisch, probeer Xorg opnieuw te configureren

  1. Schakel over naar tty1, log in
  2. Stop lightdm:

    sudo stop lightdm
    
  3. Maak een nieuw Xorg-configuratiebestand aan:

    sudo Xorg -configure
    sudo mv /root/xorg.conf.new /etc/X11/xorg.conf
    
  4. reboot

    sudo reboot
    

0
2018-06-23 09:25



Na het proberen probeert het op te starten naar de low-graphics-modus en blijft daarna hangen in 'Resolver state herstellen ...'. Nog meer lezen suggereert driverproblemen (of mogelijk hardware). Om het even welke ideeën? - user2837144
De uitvoer toegevoegd aan de originele post. - user2837144
Er is geen xorg.conf-bestand, het dichtst is xorg.conf.failsafe - user2837144
Ik heb het geprobeerd, mijn bericht bijgewerkt. Hoe controleer ik of de server nog steeds actief is, of moet ik doorgaan en het bestand toch verwijderen? - user2837144
Oké, ik heb het xorg.conf gemaakt en opnieuw opgestart, maar niets lijkt te zijn veranderd. - user2837144