Vraag "Ctrl + space" heeft ongetwijfeld een bepaalde invoermethode aangeroepen en werkt niet in Emacs of Eclipse automatisch aanvullen


In Emacs run in terminal, ctrl+ruimte is een standaard sneltoets om regio te selecteren. Maar onder Ubuntu 12.04 zal het een bepaalde invoermethode voor niet-Engelse taal oproepen. Ik vroeg me af of ik het alleen voor Emacs kan reserveren?

Onder System Settings -> Keyboard -> Shortcuts, Ik kon niet vinden waarnaar ctrl+ruimte is gebonden. Vreemd.

Andere programma's, met name automatisch aanvullen in Eclipse, lijken ook een probleemafhandeling te hebben ctrl+ruimte.


81
2018-01-15 23:55


oorsprong




antwoorden:


Het klinkt alsof je Ibus draait, dat gebruikt Ctrl + Ruimte standaard om de invoer-editor in / uit te schakelen.

U kunt de toegewezen sneltoets wijzigen in Ibus-voorkeuren.

enter image description here

Als Ibus in de menubalk wordt weergegeven, kunt u met de rechtermuisknop klikken om te selecteren Voorkeur van het menu. Als Ibus niet in de menubalk wordt weergegeven, kunt u het dialoogvenster Voorkeuren vanuit de Dash starten door het uit te voeren Toetsenbordinvoermethoden of vanaf de terminal met ibus-setup.

Update voor 14.04

ibus-setup is niet langer beschikbaar voor 14.04. Functies van de eerste ibus-setup zijn in plaats daarvan geïntegreerd in Systeeminstellingen >> Tekstinvoer.

Ingangsschakeling is nu standaard ingesteld op Super + Ruimte, maar Ibus kan nog steeds de focus stelen van de Controle + Ruimte keybinding en veroorzaken andere systeemproblemen, met name de auto-complet in Eclipse.

Integratie van de invoer van Ibus-invoer in de nieuwe instellingen voor tekstinvoer is nog steeds een werk in uitvoering en dit veroorzaakt het probleem omdat de oudere instelling nog steeds achter de schermen aanwezig is.

Als je een upgrade hebt uitgevoerd vanaf 12.04, ibus-settings moet nog steeds beschikbaar zijn.

In 14.04 kun je de instellingen direct bewerken dconf-editor.

Als het niet is geïnstalleerd:

sudo apt install dconf-editor

Blader vervolgens naar Desktop >> ibus >> algemeen >> sneltoets. De trigger en triggers instelling toont nog steeds 'controle + spatie'. Bewerk deze instellingen en zorg ervoor dat er geen lege haken achterblijven [] in triggers.


119
2018-01-16 00:59



Dit lost ook autocomplete niet op in Eclipse nadat ik een upgrade naar xubuntu 14.04 heb uitgevoerd - Brian Laframboise
Mijn ibus-setup op 14.04 is iets anders en heeft die optie niet. - BoppreH
@BoppreH 14.04 heeft ibus-installatie een beetje gewijzigd. Ik zal er naar kijken. Bedankt. - chaskes
dconf-editor verholpen mijn probleem, heel erg bedankt @chaskes. - BoppreH
@BoppreH Blij dat het gelukt is. Up-to-date (als je dit nog niet hebt gedaan). ;) - chaskes


Schakel de IBUS-trigger uit met behulp van de commandoregel:

gsettings set org.freedesktop.ibus.general.hotkey triggers @as []

Of als dit niet werkt, probeer dan of de eerste een fout oplevert:

gsettings set org.freedesktop.ibus.general.hotkey triggers []

10
2018-06-24 07:46



Het tweede commando werkte voor mij op een zakelijke aangepaste versie van Ubuntu 14.04 (goobuntu), die mijn emacs probleemkopie / yank of copy / paste repareerde. - rrenaud
Het tweede commando repareerde dit voor mij en het is nu in mijn installatiescript voor het instellen van nieuw geïnstalleerde ubuntu-desktops. Bedankt, askubuntu! - Mnebuerquo


ibus veroorzaakt me alleen maar hoofdpijn. Telkens wanneer ik de instellingen probeer te veranderen, komt de Ctrl + spatiebalk terug als ik opnieuw opstart. Dit is mijn oplossing:

sudo apt-get purge ibus
sudo killall ibus

Nu werkt alles totdat Ubuntu hun volgende stomme ding beslist. Misschien zal de letter 'o' worden gekoppeld aan het uitschakelen van de computer?


4
2018-02-11 12:47



Ik heb dit zojuist geprobeerd (Ubuntu 14.04.3 LTS). Het hielp niet. - Keith Thompson
CORRECTIE: Dit of het wijzigen van de IBus-voorkeuren of uitvoeren dconf-editor, deed werk. Ik was aan het testen door Ctrl-V Ctrl-Space in bash te typen; om de een of andere reden accepteerde bash het niet. Maar Ctrl-Space genereert een nul karakter. - Keith Thompson


Na de upgrade naar ubuntu 14.04 had ik hetzelfde probleem. Wat ik deed.
In Ibus-voorkeuren: System > Preferences > Keyboard Input Methods.
Er is een optie: Next input method het was ingesteld op ctrl + spatie, ik verwijderde dat en begon toen weer terug te werken.


2
2017-07-24 09:04





Ubuntu Studio 14.04 (XFCE) hier. Ik had geen probleem met Autocomplete (Ctrl + Space), maar met Copy Line (Ctrl + Alt + Down).

Dit werkte voor mij:

  • Open Windows Manager: xfwm4-settings
  • Ga naar het tabblad Toetsenbord
  • Blader omlaag naar een conflicterende actie
  • Druk op de knop Wissen of wijzig de actie in een andere snelkoppeling

1
2018-04-04 11:34



Bedankt! Dit kan ook op de opdrachtregel worden gedaan xfconf-query -c xfce4-keyboard-shortcuts -r -p " /xfwm4/custom/<Primary><Alt>Up" ; xfconf-query -c xfce4-keyboard-shortcuts -r -p " /xfwm4/custom/<Primary><Alt>Down" ; xfconf-query -c xfce4-keyboard-shortcuts -r -p " /xfwm4/custom/<Primary><Alt>Left" ; xfconf-query -c xfce4-keyboard-shortcuts -r -p " /xfwm4/custom/<Primary><Alt>Right" . - Stéphane Gourichon


Ik heb Ubuntu 14.04 GNOME met LXDE. Blijkbaar heeft deze desktop ibus-setup. Dus voor mij was het veranderen van de ibus-instelling de juiste oplossing. Misschien was het alleen Unity die de ibus-setup-app had afgeschaft.


0
2017-12-28 04:28



Ja, het is iets Unity. - Gunnar Hjalmarsson


De dconf-editor verandering was niet voldoende voor mij. Ik heb de Mozc (Japanse) invoerbron geïnstalleerd.

Op Ubuntu 16.04 moest ik ook:

  1. Ga naar Systeeminstellingen -> Tekstinvoer
  2. Klik op Mozc om te markeren
  3. Klik hieronder op het pictogram met de sleutel / schroevendraaier
  4. Het tabblad Algemene configuratie
  5. De eerste instelling daar, 'Trigger Input Method', was CTRL_SPACE. Ik klikte erop en raakte vervolgens Ontsnappen om de keybinding uit te schakelen.

0
2017-09-08 17:18