Vraag Hoe kan ik van toetsenbordcombinatie wisselen?


Ik zou graag Hebreeuws willen typen in Ubuntu. Ik heb geprobeerd het Hebreeuwse taalpakket te downloaden en vervolgens in te stellen alt-verschuiving als mijn lay-out-sneltoets in de opties sectie van "Toetsenbordindeling".

Echter, wanneer ik daadwerkelijk druk alt-verschuiving, niks gebeurt. Hoe kan ik mijn toetsenbordindeling veranderen in Hebreeuws?


84
2017-10-17 13:34


oorsprong


Bij het selecteren van toetsencombinaties om de taal te veranderen, werken sommige combinaties niet (beide werkten niet voor mij). Ik gebruik Shift + Ctrl zonder probleem.
In Ubutu 18.04 Zie askubuntu.com/questions/1030418/... - user642711


antwoorden:


Ubuntu 13.04 en ouder

Het lijkt erop dat je een belangrijke stap bent vergeten.

  1. Hebreeuwse taalondersteuning downloaden. U kunt dit doen vanuit de Talen installeren / verwijderen gedeelte van "Taalondersteuning".
  2. Systeeminstellingen -> Toetsenbordindeling -> "+" -> "Hebreeuws" -> Toevoegen
  3. Systeeminstellingen -> Toetsenbordindeling -> Opties -> Toetsen om layout te wijzigen -> markeer [alt] + [shift] (deze stap is optioneel, alleen als u die aangepaste sneltoets wilt)

Een pictogram als dit zou in de rechterbovenhoek moeten verschijnen na stap twee:

The keyboard indicator


Ubuntu 13.10 en nieuwer

Vanaf Ubuntu 13.10 wordt het nu genoemd Tekstinvoerinstellingen in plaats van Toetsenbordindeling

Het kan worden bereikt via een van deze methoden

  1. Systeeminstellingen doorlopen -> Tekstinvoer
  2. De app-indicator gebruiken zoals weergegeven in de onderstaande schermafbeelding.

App Indicator icon


95
2017-10-17 13:49



Ik heb hetzelfde als hierboven en kan de toetsenbordindeling nog steeds niet wijzigen. . . - deadalnix
Ik heb dit gedaan, om een ​​of andere reden heb ik alleen een close knop die niets opslaat. : - \ - Ramzi Kahil


Schakelen tussen toetsenbordindelingen op Ubuntu 12.04

  1. Ga naar Systeem instellingen...

  2. Onder Toetsenbordindeling - Klik op Opties ...

    enter image description here

  3. Onder Sleutel (s) om de lay-out te veranderen - kies de combinatie van toetsen die u wilt gebruiken.

    enter image description here


22
2018-06-02 09:33



Wanneer ik de toetscombinatie instel, en druk erop, doet het niets. Ik kan de lay-out echter wijzigen met mijn muis in de applet, die perfect werkt. - Ondřej Čertík


Ik ben een nieuweling voor Ubuntu, ik heb het zojuist gisteren geïnstalleerd en ik ben er dol op, maar ik ben hetzelfde probleem tegengekomen toen ik probeerde om sneltoetsen te gebruiken om over te schakelen van Latijns naar Arabisch, maar gelukkig vond ik de oplossing, hier is gewoon wat te doen:

Systeeminstellingen ... → Toetsenbordindeling → (klik op "+" om nieuwe taallay-outs toe te voegen) → Opties ... → (klik op) "Toets (s) om de lay-out te wijzigen" → (aanvinken) "Links Alt + Left Shift "→ Sluiten


4
2017-10-02 22:06





In Ubuntu 12.04 LTS,

Ga naar de Toetsenbordindeling opties venster dat ik zou kunnen selecteren Sleutel (s) om de lay-out te veranderen en Mark de binding van mijn keuze. ik gebruik Verschuiving + Caps Lock naar toggle de lay-out vanaf het toetsenbord zelf, zonder dat de muiscursor hoeft te worden gebruikt om de gewenste lay-out in de paneelindicator te selecteren. Dezelfde toetscombinatie leek te werken om een ​​serf door te geven of om te kiezen tussen meerdere lay-outs. (Maar in Ubuntu 13.10 was het niet zo eenvoudig.) snap5


In Ubuntu 13.10,

Ga naar de Toetsenbord instellingenvenster, onder shortcuts tabblad, ik selecteer Typen. De standaard voor Schakel over naar de volgende bron is Super+RUIMTE wat niet leek te werken voor mij en dus door erop te klikken en ik een toegewezen Nieuwe accelerator ..., om naar de volgende te gaan Layout (ik gebruikte Super+L).

(Vervolgens heb ik iets soortgelijks toegewezen voor Overschakelen naar vorige bron dezelfde lay-out van dezelfde voorkeur gebruikenen begon ze vervolgens te testen. Overschakelen van de gewenste lay-out naar de alternatieve werkte, maar het omgekeerde deed dat niet. Raadpleeg de volgende stap voor de oplossing.) saucy1

De fix: Na het toewijzen Super+L voor "Schakel over naar de volgende bron" mijn gebruiken gewenste lay-out (A), Ik veranderde mijn toetsenbordindeling naar de alternatieve lay-out (B) en vervolgens de combinatie toegewezen aan "Overschakelen naar vorige bron" (waarvoor ik heb gebruikt Verschuiving+Super+L). Daarna heb ik ze getest en ze werken prima. (Misschien uitschakelen "Overschakelen naar vorige bron" zou ook werken.)

De nieuwe accelerators voor de belangrijkste combo's die ik heb gebruikt zien er als volgt uit: saucy2

Ik zou dan kunnen overschakelen naar lay-out (A) met Super+L en terug naar lay-out (B) met behulp van Verschuiving+Super+L.


4
2018-03-29 05:54





Het lijkt erop dat je bent vergeten om de Hebreeuwse toetsenbordindeling toe te voegen. Het maakt niet uit hoeveel mogelijke talen je hebt, je moet alle talen toevoegen waarmee je wilt SCHRIJVEN in je toetsenbordinstellingen.

Zoiets als: 3.- Instellingen -> Toetsenbordindeling -> + -> Hebreeuws -> Toevoegen


3
2017-10-17 14:45





Controleer nogmaals of deze combinatie al is ingesteld in compiz-config. Voer het uit door op te drukken alt + F2, typ dan ccsmen druk vervolgens op invoeren. Soms wordt de snelkoppeling al door een ander programma gebruikt, dus u kunt het niet gebruiken.

Controleer ook of het werkt met een andere combinatie, bijvoorbeeld Caps Lock + Verschuiving.


3
2017-10-17 13:45





Als u taalondersteuning hebt geïnstalleerd nadat het toetsenbord is geïnstalleerd, ondervindt u mogelijk geen actie voor geselecteerde combinaties (zoals @OndrejCertik hierboven vermeld).

U moet de standaardinstellingen van de toetsenbordindeling in dat geval opnieuw instellen System Settings -> Keyboard Layouts -> Reset To Defaults en instellen Key(s) to change layout opnieuw onder Options... er.


2
2018-01-17 21:59