Vraag Hoe OpenGL op Ubuntu 14.04 LTS met Intel grafische kaart te updaten


Ik probeer Supertuxkart uit te voeren> = 0.9.2. Er staat dat mijn videostuurprogramma te oud is. Het wil OpenGL versie 3 of hoger. Dus ik probeer OpenGL te updaten.

Ik heb andere berichten over dit probleem gezien (bijv. Hoe OpenGL te updaten met Intel grafische kaart Ubuntu 14.04 ), maar geen enkele werkt. Dus ik vraag het hier.

Het laatste wat ik deed was:

sudo apt-get install --install-recommends xserver-xorg-lts-xenial libqt5gui5 libgles1-mesa-lts-xenial libgles2-mesa-lts-xenial libgl1-mesa-glx-lts-xenial libgl1-mesa-glx-lts-xenial:i386 libglapi-mesa-lts-xenial:i386 libegl1-mesa-lts-xenial libwayland-egl1-mesa-lts-xenial libgbm1-lts-xenial libgl1-mesa-dri-lts-xenial 

Deze bijgewerkte mesa. Ik heb nu

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) 945GM x86/MMX/SSE2
OpenGL version string: 1.4 Mesa 11.2.0

Supertuxkart zegt echter nog steeds dat ik OpenGL 2 heb:

[info   ] IrrDriver: OpenGL version: 2.1
[info   ] IrrDriver: OpenGL vendor: Intel Open Source Technology Center
[info   ] IrrDriver: OpenGL renderer: Mesa DRI Intel(R) 945GM x86/MMX/SSE2
[info   ] IrrDriver: OpenGL version string: 1.4 Mesa 11.2.0

Mijn grafische kaart is:

$ lspci
...
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
...

Waarom OpenGL niet is bijgewerkt?

Bij voorbaat bedankt.

Bijwerken  Bedankt Doug. Inderdaad, mijn grafische kaart ondersteunt OpenGL versie 3 of hoger niet. Ik heb het geverifieerd met behulp van OpenGL Extension Viewer. Dus dit is waarom niets werkte voor het updaten van OpenGL.


2
2017-08-20 11:13


oorsprong


Die gpu ondersteunt alleen 2.1, dus om 'bij te werken' krijg je nieuwere hardware. - doug


antwoorden: