Vraag Waarom duurt het zo lang voordat het wachtwoord van de SSH-code wordt weergegeven?


Wanneer ik het probeer ssh, het wachtwoord vraagt ​​te lang (bijna twee minuten) om te verschijnen.

Waarom gebeurt dit?


87
2018-01-22 20:55


oorsprong


De antwoord van Gilles zou moeten zijn de antwoord zoals uitgelegd in de reacties, echt waar. - gertvdijk


antwoorden:


Er kunnen verschillende dingen fout gaan. Toevoegen -vvv maak ssh een gedetailleerd spoor van wat het doet en zie waar het pauzeert.

Het probleem kan zich op de client of op de server bevinden.

Een veelvoorkomend probleem op de server is als u verbinding maakt vanaf een client waarvoor time-outs voor reverse DNS-zoekopdrachten optreden. (Een "omgekeerde DNS-lookup" betekent dat u van het IP-adres van de clientcomputer terugkeert naar een hostnaam. Het is niet echt handig voor de beveiliging, maar slechts een klein beetje nuttig om breakin-pogingen uit logboekinvoeren te diagnosticeren, maar de standaardconfiguratie doet het hoe dan ook.) Als u reverse DNS-lookups wilt uitschakelen, voegt u toe UseDNS no naar /etc/ssh/sshd_config (je moet root zijn op de server, onthoud dat je de SSH-service daarna opnieuw moet opstarten).

Een ander ding dat kan fout gaan is GSSAPI authenticatietiming uit. Als je niet weet wat dat is, vertrouw je er waarschijnlijk niet op; je kunt het uitschakelen door de lijn toe te voegen GSSAPIAuthentication no naar /etc/ssh/ssh_config of ~/.ssh/config (dat is aan de kant van de klant).


135
2018-01-22 21:15



Voor mij was dit het probleem met de GSSAPIAverificatie. Dank je. - RajaRaviVarma
GSSAPI was mijn probleem, bedankt. - jcora
Reverse DNS-lookup was mijn probleem - trinth
Reverse DNS was ook de boosdoener voor mij, en UseDNS no repareerde het als een charme. Ik gebruik een intern netwerk zonder DNS-server om reverse lookups voor interne IP's af te handelen. - Jordan Mack
@AlexanderMalakhov Als je hier op vertrouwd om je aan te melden, sluit je jezelf af als je het uitschakelt. Anders dan dat, nee. En als u GSSAPI gebruikt, weet u dat u een GSSAPI-gebaseerde service op uw netwerk had moeten configureren. - Gilles


Laat tijd het inlogproces en kijk hoe lang het duurt:

[root@gislab00207 ~]# time ssh root@ISSLABNTL01
root@isslabntl01's password:
Last login: Fri Oct  4 07:55:03 2013 from 3.60.40.232

[root@ISSLABNTL01 ~]# exit
logout
Connection to ISSLABNTL01 closed.

real    0m45.192s
user    0m0.003s
sys     0m0.005s

You have new mail in /var/spool/mail/root
[root@gislab00207 ~]#

Zie hierboven het duurde ongeveer 45 seconden om in te loggen -------- ZEER LANGZAAM

Zodra u zich als root aanmeldt, wijzigt u het bestand sshd_config en wijzigt u het gebruik van UseDNS zoals hieronder. Hier gebruik ik sed in plaats van het bewerken van het bestand.

[root@ISSLABNTL01 ~]# grep -i dns /etc/ssh/sshd_config
#UseDNS yes

[root@ISSLABNTL01 ~]# sed -i 's/#UseDNS yes/UseDNS no/g' /etc/ssh/sshd_config
[root@ISSLABNTL01 ~]# grep -i dns /etc/ssh/sshd_config
UseDNS no

[root@ISSLABNTL01 ~]# service sshd restart
Stopping sshd:                                             [  OK  ]
Starting sshd:                                             [  OK  ]
[root@ISSLABNTL01 ~]# exit

Laten we het aanmeldingsproces een tijdje doorlopen en nu zien hoe lang het zal duren.

[root@gislab00207 ~]# time ssh root@ISSLABNTL01
root@isslabntl01's password:
Last login: Fri Oct  4 07:55:03 2013 from 3.60.40.232

[root@ISSLABNTL01 ~]# exit
logout

Connection to ISSLABNTL01 closed.

real    0m6.192s
user    0m0.003s
sys     0m0.005s

You have new mail in /var/spool/mail/root
[root@gislab00207 ~]#

Ik heb nu 6 seconden nodig, de tijd om het wachtwoord te typen.


12
2017-10-04 12:39



fantastisch .. een punt re tijd .. de useDNS heeft het niet voor mij gerepareerd .. ik had wachtwoord authenticatie en de vertraging was voor dat wachtwoord dat prompt invoerde om te verschijnen .. ik wachtte tot dat toen verscheen deed ctrl-c dus de 'tijd 'omvatte niet het invoeren van het wachtwoord. - barlop
ik kan bevestigen UseDNS no in /etc/ssh/sshd_config heeft mijn probleem opgelost
UseDNS no Opgelost - Pandurang Patil
@PandurangPatil Slechte configuratieoptie: usedns - zhilevan
@zhilevan Je moet ook vermelden waarom het een slechte configuratie is. Dat zal helpen begrijpen waarom het slechte config is - Pandurang Patil


Het is iets dat fout gaat door de installatie van Ubuntu.

Om het probleem op te lossen, moet je deze regel wijzigen /etc/nsswitch.conf:

hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4

En verander het voor deze:

hosts:          files dns

4
2018-01-22 20:55



Ubuntu's configuratie is niet verkeerd. In sommige gevallen (thuisnetwerken zonder centrale DNS-servers) is dit het juiste. In andere (netwerken waar mDNS time-out vereist), is het slecht. - Gilles
de [NOTFOUND = return] zou er niet moeten zijn. - Neuquino
@Neuquino It moeten wees erbij. Het is daar voor een reden je begrijpt het blijkbaar niet. Rommelen met je nsswitch.conf zoals dit is vragen om problemen en niet om een ​​algemene oplossing te bieden voor het vertragen van SSH. - gertvdijk
Dit lijkt me de enige oplossing die werkt - linello


In mijn geval kan het probleem worden opgelost door opnieuw te starten systemd-logind:

systemctl restart systemd-logind

Dit wordt genoemd op Serverfault.

Ik moet dit echter regelmatig doen, en ik weet niet wat de oorzaak van het probleem is.


4
2018-04-22 17:01





De foutopsporingsoutput voor ssh in mijn geval is net 30 seconden gestopt terwijl deze 'verbond'. De oplossing bleek gerelateerd te zijn aan de DNS-instellingen op mijn lokale systeem. Een vorige netwerkconfiguratie had een valse DNS-server achtergelaten in de /etc/resolv.conf het dossier. Het probleem werd opgelost door het te vervangen door een huidige DNS-server.


1
2017-07-25 16:29





Voor mij was het veranderen van het systeem dns naar 127.0.0.1, daarvoor was het een niet-bestaande host.

nano /etc/resolv.conf

En schrijf het volgende

domain localdomain
search localdomain
(Removed this line) ===> nameserver 10.0.0.1
(Added this line) ===> nameserver 127.0.0.1

0
2017-12-07 05:51



Voor mij leek dit bestand /etc/resolv.conf (geen e) - Shadow


Ik weet niet zoveel over de omgeving van de poster als ik zou willen, maar voor anderen met een soortgelijk probleem kan het een probleem zijn met sssd, die we gebruiken om ldap mojo in te binden.

Dit gebeurt met mij:

$ time ssh server.example.com

real  2m0.018s
user  0m0.006s
sys   0m0.004s

Ik moet toegang krijgen tot de server (in mijn geval via de console) en dan een:

service restart sssd

Daarna werken de dingen gewoon. Ik heb geen tijd gehad om de oorzaak te debuggen, maar deze bandaid werkt voor mij.


0
2017-09-15 18:36





Ik zou het kunnen oplossen langzaam wachtwoord prompt via ssh - Uitgifte door te checken Zet DNS Relay aanin DHCP-instellingen op mijn dlinkrouter. Nadien werkten verbindingen met SSH binnen een seconde.

Network Settings -> Router Settings -> Enable DNS Relay [x]

De standaardconfiguratie stuurt elk DNS-verzoek door naar de provider. Het was traag hoewel ik verbinding maakte met ssh pi@10.0.0.103. Een hint naar de oplossing was een vermelding in /etc/resolv.conf "search upc.at" die wordt aangeboden via dhcp.

De dlink-handleiding vermeldt:

When DNS Relay is enabled, DHCP clients of the router will be assigned 
the router's LAN IP address as their DNS server. All DNS requests that 
the router receives will be forwarded to your ISPs DNS servers. 
When DNS relay is disabled, all DHCP clients of the router will 
be assigned the ISP's DNS server.

Na een DHCP-release op client en server, was verbinding via SSH weer snel. HTH.


0
2018-06-19 19:11