Vraag Ubuntu 14.04 vastgelopen bij afsluiten


Wanneer ik mijn computer probeer uit te schakelen, blijft deze hangen bij het afsluitscherm en dit zijn de enige regels die ik kan zien:

wait-for-state stop/waiting
Stoping GNUstep distributed object mapper: gdomap.
* Stopping rsync daemon rsync [ OK ]
* Stopping Speech Dispatcher speech-dispatcher [ OK ]

En dat is alles.

Ik gebruik gnome 3.10 (had 3.12 maar werd gedowngraded vanwege een aantal problemen) als het daar iets mee te maken heeft.

Het opnieuw opstarten van de computer werkt; het hangt niet.


14
2017-08-07 09:51


oorsprong




antwoorden:


In mijn geval werkten deze eenvoudige stappen voor mij prima:

  1. druk op Ctrl+alt+T om naar een terminal te gaan en typ:

    sudo gedit /etc/default/grub
    

    Dit opent het GRUB-configuratiebestand. Verander de regel:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    

    naar:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force apm=power_off"
    

    Sla het vervolgens op en sluit het.

  2. Typ in dezelfde terminal:

    sudo gedit /etc/modules
    

    Dit opent de modules config, voeg gewoon het volgende toe:

    apm power_off=1
    

    en sla het bestand op.

  3. Typ het volgende in de terminal:

    sudo update-grub
    

Bron


13
2018-01-13 10:59



@Fabby, je hebt gelijk, dank je. Ik heb de stappen toegevoegd =) - Uroš Podkrižnik
Veel beter! En een bewerking en een upvote! Kun je alsjeblieft mijn recensie bekijken bewerkingen en bekijk ook de hulp bij het bewerken om de leesbaarheid van uw antwoorden in de toekomst te verbeteren ... ;-) - Fabby
ik geloof acpi=force behoort binnen de citaten, zoals ik veel plaatsen elders heb gezien (zie een voorbeeld). Het antwoord hieronder heeft ook de apm=power_off deel binnen de aanhalingstekens. - Nateowami


Ubuntu sluit niet goed af of loopt vast bij afsluiten?

Probleem geconfronteerd tijdens het installeren van Ubunutu 14.04 in Dell XPS 15Z-laptop

Open het bestand /etc/default/grub met teksteditor van uw keuze en met privilleges van beheerders. Zou kunnen worden gedaan met gksu gedit /etc/default/grub voor GUI-teksteditor of sudo nano /etc/default/grub voor toegang tot de opdrachtregel.

Zoek de volgende regel:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Vervang het door het volgende:

GRUB_CMDLINE_LINUX_DEFAULT="acpi=noirq acpi=force apm=power_off quiet splash"

Sla het bestand op en sluit het. Terug in de terminal voer uit:

 sudo update-grub

Als u nu afsluit, zou het moeten werken.


7
2017-08-07 09:58



Hangt vast bij afsluiten. Ik heb dit geprobeerd, maar hetzelfde probleem blijft bestaan. - user313246
Voor Razer Blade 14 helpt uw ​​oplossing. Bedankt. ik liet vallen acpi=noirq omdat het in mijn geval geen verschil maakt. - topr


Ik heb zojuist verwijderd quiet splash van deze regel in /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

en rende sudo update-grub

en het is nooit meer opgehangen bij afsluiten


3
2017-12-17 02:48



Ik heb het verwijderd en nu zit mijn laptop niet vast bij afsluiten / opnieuw opstarten. Bedankt. - Mustafa Chelik


Ik gebruik Lubuntu 16.04.1. Ik heb verschillende methoden geprobeerd, waaronder: bewerken /etc/default/grub, rennen sudo swapoff -a voor sluiting, enz ... Maar geen van die werkte voor mij.

Uitdoen USB 3.0 legacy mode in de BIOS werkte voor mij.


2
2017-07-29 02:14





Ik probeerde veranderingen te rooien zonder succes. Ik moest gebruiken sudo shutdown -h 0 (dus met -h) om het te laten werken.

Als ik het vergeet -h, het systeem hangt potentieel ver van me af, dus ik heb er een alias voor gemaakt (normaal gesproken geen goed idee om commando's alias te bouwen, maar ik vind dit belangrijk).

alias sudo='sudo '  # note the space, that's what makes sudo recognize aliasses
alias shutdown='shutdown -h'

1
2017-08-02 15:41





Ik had hetzelfde probleem met de shutdown op Ubuntu (15.10 en 16.10). Met Debug ingeschakeld in GRUB kon ik zien dat de laptop crashte direct na 'Reached target Shutdown'

GRUB_CMDLINE_LINUX_DEFAULT="debug"

Ik heb ook verschillende GRUB-opties geprobeerd en zelfs om een ​​service te maken die de USB uitschakelt.

Als je USB 3.0 hebt, zou je kunnen proberen ze uit te schakelen van het BIOS (ik kon dat niet doen op mijn ASUS X540SA vanwege een paar instellingen in het BIOS)

Voor mij was de oplossing om de kernel te upgraden. Ik gebruikte 4.5.3 op Ubuntu 15.10 (alles dat groter is dan dit zal het besturingssysteem doen crashen na inloggen) En 4.7 RC3 werkt op Ubuntu 16.04.

Voorheen had ik Linux Mint 17 geïnstalleerd en er waren geen problemen met rebooten / afsluiten.


1
2018-06-20 08:11



Holy shit! Heel erg bedankt! Ik probeer dit nu dagenlang op te lossen. uitschakelen Pre-OS USB 3.0 Configuration van mijn BIOS-instellingen repareerde het. - Sheharyar


Ik had hetzelfde overkomen op mijn ASUS-laptop en probeerde elke methode om het onder de zon te weerstaan. Degene die het verste kreeg, was het bijwerken van de kernel naar 4.2.3, dus als je dat een keer wilt proberen Klik hier en volg de instructies.

Als dat niet lukt, kun je altijd terugvallen op SysRq, wat ik ook deed. Als u van plan bent om SysRq te gebruiken, moet u echt de REISUB-stappen volgen, maar echt, als u het vaak moet doen zoals ik deed, dan maakt alles behalve B (of O in ons geval) er niet echt toe.

Houd de toets ingedrukt Alt+Prt Sc/SysRq+Shift toetsen en typ in REISUO, wacht ongeveer 5-10 seconden tussen elk ervan en uw computer zal worden afgesloten.

Uitleg:

 R - Forces capturing of the keyboard
 E - Terminates all processes
 I - Kills all processes
 S - Syncs all mounted drives
 U - Remounts all drives in read-only mode

Dan ofwel:

 B - Reboots the system
 O - Shuts down the system

Het is vanwege het lange wachten dat nodig is tussen elke invoer die ik op de overbodige heb geknipt; plus, de meeste zijn alleen nodig als je de controle over het systeem verliest. Dus als je probeert om handmatig af te sluiten en het bevriest, zoals het wil, volg dan REISUO ... anders gebruik je gewoon O.

(Vergeet niet dat dit niet meteen zal gebeuren, dus blijf er niet op drukken om het sneller te laten werken, wees geduldig).

Als een aanvullende opmerking: sommige computers kunnen verschillende toetscombinaties gebruiken, zoals Alt+Fn+Prt Sc/SysRq. Er zijn meer details hier op de Wikipedia-pagina met alternatieve patronen kunt u proberen of het origineel niet werkt.

Ik hoop dat dit allemaal helpt.


0
2017-12-12 03:42





Ik had precies hetzelfde probleem en niets stelde dat het werkte. Ik heb eindelijk door dat het systeem is ingesteld om te starten met LEGACY en niet met UEFI Secure. Toen ik het eenmaal had gewijzigd in UEFI werkte het perfect!


0
2018-01-16 22:11





Ik had precies hetzelfde probleem en het kostte me drie dagen om het op te lossen.

Ik gebruik een Lenovo B50-10. De installatie van Ubuntu 14.04 veroorzaakte geen problemen totdat ik de computer opnieuw wilde opstarten om de installatie te voltooien. Het scherm werd zwart en de computer deed niets. Al snel kwam ik erachter dat het ook niet zou stoppen. De harde schijf is uitgeschakeld maar het display bevroor en toont het ubuntu-logo met de puntjes.

Dus probeerde ik de opstartopties aan te passen door de

GRUB_CMDLINE_LINUX_DEFAULT = "stille plons"

lijn en het toepassen van de oplossingen die worden genoemd in de bovenstaande antwoorden.

Toen kwam ik erachter dat ik Ubuntu in de legacy-modus heb geïnstalleerd en dit kan een reden zijn. Dus veranderde ik de BIOS-modus in UEFI en installeerde het in de UEFI-modus. Verrassend genoeg zou ik nu kunnen voorkomen dat Ubuntu vasthoudt aan afsluiten / opnieuw opstarten door te bewerken

GRUB_CMDLINE_LINUX_DEFAULT = "acpi = noirq quiet splash"

Helaas zorgde deze wijziging ervoor dat ik geen wifi-verbinding meer had. Dus het was echt geen oplossing en ik overwoog het BIOS en de kernel bij te werken. Maar zonder een Windows-productcode en een bloederige Linux-beginner zoals ik ben, wist ik niet hoe.

Maar uiteindelijk loste ik het probleem op door deze oplossing toe te passen:

Ga naar bios en verander "OS Optimized Defaults" en zet dit op "Enabled". Druk vervolgens op "Standaardinstellingen laden".

Dit was de oplossing die voor mij werkte. Dus ik hoefde de firmware of de kernel niet bij te werken.


0
2018-02-25 13:20





Ik heb nog steeds hetzelfde probleem, ondanks het volgen van de adviezen,

Hier is de uitvoer van

sudo gedit / etc / default / grub

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force apm=power_off"
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash reboot=bios"
GRUB_CMDLINE_LINUX=""

En uitvoer van

sudo gedit / etc / modules

lp
rtc
apm power_off=1

Bedankt,


-1
2018-05-12 09:12