Vraag Trusty-pakketten installeren in Saucy


De versie van yate in Saucy geeft me problemen mee pulseaudio en ik wilde een nieuwere versie installeren, dus installeerde ik alle vereiste debielen die betrouwbaar waren om te maken yate-qt4 werk. Ik heb tot nu toe nog geen problemen ondervonden en alles lijkt goed te werken, maar geeft dit me later problemen met het upgraden?


2
2018-02-03 20:46


oorsprong




antwoorden:


Aangezien Trusty Saucy onmiddellijk volgt, zou u geen problemen moeten hebben bij het upgraden als je upgrade naar betrouwbaar (eerste). Zelfs als u wilt upgraden naar de u-serie, sla de upgrade dan niet over naar Trusty, om uw systeem weer volledig "in sync" te krijgen.

Maar ja, het uitvoeren van "gemengde distributies" is wat mensen altijd doen.

In Debian wordt het uitvoeren van een mixed stable / oldstable of stabiel / testen of stabiel / testen / onstabiel of stabiel / onstabiel systeem ondersteund, maar niet oldstable mengen met testen bijvoorbeeld (één distributie overslaan).

In Ubuntu wordt het mixen van distributies normaal ondersteund, ofwel versie X en X + 1, of versie X = LTS en X + 4 = LTS + 1, omdat je direct van de ene LTS naar de volgende kunt upgraden. (Aan de andere kant, omdat er 4 volledige Ubuntu-releases zijn tussen LTS-releases, zal het mixen van dergelijke pakketten minder waarschijnlijk zijn als gevolg van bijgewerkte afhankelijkheden (bijvoorbeeld bibliotheken) en wijzigingen van het hele systeem).

Het is veel veiliger om pakketten van een oudere versie op een nieuwer systeem te installeren dan om pakketten van een nieuwere versie op een ouder systeem te installeren. Over het algemeen gebruikt men daarvoor backports (ofwel officiële of PPA).


1
2018-03-01 23:50