Vraag LightDM of GDM kunnen niet werken op LTS 16.04 na VirtualBox-update


Ik heb een gemaakt bug report voor dit probleem, maar ik heb geen ideeën om de oorzaak te achterhalen. Bij het opnieuw opstarten maakt lightdm 5 pogingen om te starten voordat het faalt op het consolescherm en op elk moment dat sudo systemctl restart lightdm wordt ook aangeroepen. Zie de bovenstaande link voor alle bijgevoegde logbestanden. De laatste geslaagde herstart was op 13 maart, het probleem deed zich vervolgens voor op 31 maart toen het opnieuw werd opgestart.

Ik heb geprobeerd opschonen en opnieuw installeren mijn grafische stuurprogramma's van Intel. Ik heb een oudere kernel geprobeerd (4.4.0-112-generiek). Ik heb ook geprobeerd om lightdm en xorg op te ruimen en opnieuw te installeren, het mocht niet baten. Ik heb ook geprobeerd de initrd-bestanden te vernieuwen:

update-initramfs -c -k all
update-grub

Ik kan op de desktop opstarten met lxdm, maar veel applicaties zullen niet starten. Firefox faalt bijvoorbeeld altijd met een segfault, Roxterm wordt niet geopend, Verzending wordt niet geopend en afgezien van de Firefox-segfault worden deze fouten niet weergegeven in syslog of kern.log. Toepassingen die worden geopend in de bureaubladomgeving (LXDE) zijn Seamonkey, Lxterminal en PCmanFM.


2
2018-04-02 07:11


oorsprong


Lijkt erop dat je kernelversie is 4.4.0-116.140-generic. Heb je een oudere en een nieuwere geprobeerd? Ik heb niet echt een favoriete oude maar mijn huidige favoriete nieuwe is 4.14.27. Zien: askubuntu.com/questions/119080/... - WinEunuuchs2Unix
Ja, de vorige kernel was 4.4.0-112 die ook dezelfde fout oplevert. 4.4.0-116.140-generiek is de laatste die beschikbaar is in mijn installatiebronnen, ik heb nog niets nieuws geprobeerd (nog steeds de link die u hebt genoemd gelezen). - shellcat_zero
btw, de 4.14 kernel is de "HWE" kernel die wordt teruggestuurd en ondersteund op Xenial, hier kun je meer over lezen: wiki.ubuntu.com/Kernel/LTSEnablementStack - dpb


antwoorden:


Blijkbaar heb ik op mijn hostsysteem Virtualbox-gastprogramma's geïnstalleerd die u normaal alleen bij de gast zou moeten uitvoeren. Dit probleem deed zich alleen voor toen het pakket werd bijgewerkt. Na vallen en opstaan ​​is het beledigende pakket virtualbox-guest-x11: amd64 (5.1.34-dfsg-0ubuntu1.16.04.2), geen van de andere virtualbox-guest-pakketten veroorzaakt dit probleem.


1
2018-04-03 08:14