Vraag Hoe installeer ik Adobe Acrobat in Ubuntu 16.04?


Ik ken de draad Hoe installeer ik Adobe Acrobat Reader deb-pakket gedownload van de Adobe-website? Er is echter geen Linux meer op de installatiesite hier. Mislukte pogingen

  • Ik doe het voorstel van DriraWassim waaraan niets wordt toegevoegd apt-get en toont het geïnstalleerde .deb-pakket niet in het pad / zoeken

    sudo apt-get install libxml2:i386 
    sudo apt-get update
    sudo apt-get upgrade 
    apt-cache search adobereader-enu
    

    Ik download het nieuwste .deb-pakket hier en voer het uit. Ik kan de toepassing nergens in het systeem vinden. Het staat niet op het pad en niet in de zoektocht van Ubuntu. Hoe kun je het starten?

Systeem: Ubuntu 16.04, 64 bit
Hardware: Macbook Air 2013-mid
Linux kernel: 4.6


93
2018-05-05 10:50


oorsprong




antwoorden:


Ik volgde de onderstaande tips op Kubuntu 16.04 64 bit:

sudo add-apt-repository "deb http://archive.canonical.com/ precise partner"
sudo apt-get update
sudo apt install adobereader-enu

Na correct geïnstalleerde Adobe Reader, vergeet niet om de Canonical Partners-repository voor Precise te verwijderen:

sudo add-apt-repository -r "deb http://archive.canonical.com/ precise partner"
sudo apt update

109
2017-07-31 20:17



Het installeert eigenlijk acroread-bin:i386 liever dan adobereader-enu - pd12
Waarom installeert dit zoveel pakketten? Het lijkt erop dat deze procedure het grootste deel van mijn systeem opnieuw installeert. Ik zag dingen als systemd - bli
@bli Ja, dit is waarschijnlijk de verkeerde benadering, je kunt de Deb van krijgen hier in plaats van een oude repository toe te voegen waardoor je systeem sneller zal breken. - Ads20000
@ses Er is niets dat Ubuntu daaraan kan doen, Adobe werkt Adobe Reader voor Linux niet bij. Je kunt echter, indien gewenst, Adobe Reader 11 of DC installeren met Wine (probeer PlayOnLinux (voor Reader DC) te gebruiken, dit maakt het proces redelijk vanzelfsprekend). - Ads20000
ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/... moet in het geaccepteerde antwoord staan ​​en het is de nieuwste versie die beschikbaar is vanaf Adobe. - Jeff Xiao


Voor Adobe Reader 9.5.5 (native uitgevoerd zonder Wine)

Voeg de Ubuntu 12.04 Partner-repository niet toe, het is niet de bedoeling dat u repositories van eerdere Ubuntu-versies toevoegt! Haal de Deb eruit hier (bron - het is ook gelinkt in de vraag), nee het zal niet automatisch worden bijgewerkt, maar omdat het niet langer wordt ondersteund (en Ubuntu kan er in Ubuntu 12.04 sowieso geen beveiligingslekken voor patchen, omdat het privé is) doet er niet toe. Er is minder kans dat je je systeem kapot maakt als je het zo krijgt.

Als u Adobe Reader niet kunt vinden / uitvoeren, moet u het uitvoeren sudo apt -f install om afhankelijkheden op te lossen. Als het nog steeds niet werkt, probeer het dan sudo apt install libxml2:i386.

Dit is natuurlijk een erg verouderde versie van Adobe Reader, maar dit is niet de schuld van Ubuntu, Adobe heeft de Linux-client van Adobe Reader niet bijgewerkt. U kunt echter een nieuwere versie krijgen met behulp van het onderstaande proces (dit installeert een Windows-versie van Adobe Reader op Ubuntu).

Voor Adobe Reader DC 1501020056 (werkt met Wine 1.9)

  1. Installeer PlayOnLinux
  2. Laad PlayOnLinux
  3. Klik op 'Installeren' (in de werkbalk)
  4. Typ 'Adobe Acrobat Reader DC' in de zoekbalk
  5. Klik op 'Adobe Acrobat Reader DC'
  6. Klik op 'Installeren' (rechtsonder)
  7. Volg de installatieschermen
  8. Na installatie klikt u op 'Adobe Acrobat Reader DC'
  9. Klik op 'Uitvoeren' (in de werkbalk)

U moet PlayOnLinux openen om Adobe Reader DC elke keer te starten (merk op dat u dit naast Adobe Reader 9.5.5 kunt laten installeren). U kunt het bureaubladbestand naar de Launcher slepen om daar een knop te krijgen, u kunt ook een pictogram ervoor in het Ubuntu Dash toevoegen met behulp van Alacarte ('Hoofdmenu'). Ik zou daar later instructies aan kunnen toevoegen. Helaas is zelfs deze versie niet helemaal up-to-date (er zijn waarschijnlijk ook niet-gepatchte beveiligingskwetsbaarheden in die versie en ook Wine is hier verouderd, hoewel dat er niet zoveel toe doet). Als u de nieuwste versie van Reader, DC of niet-DC wilt installeren, moet u dit handmatig doen met PlayOnLinux. Ik kan hier misschien instructies voor schrijven of een POL-script schrijven om dit later te doen.


37
2017-11-20 22:49



Bij gebruik van de deb acroread draait niet, ik moest installeren libxml2:i386 - Gerhard Burger
Oh sorry, sudo apt -f install kan dat automatisch hebben gedaan? Moet ik dat toevoegen aan het antwoord (welk commando?)? - Ads20000
Ik installeerde met het Ubuntu Software Center, dus ik denk dat het een ontbrekende afhankelijkheid is. Bedankt voor je gids, werkt geweldig! - Gerhard Burger
FTP-clientgebruikers: gebruik om verbinding te maken "anonymous" als aanmeldingsnaam en gebruik uw e-mailadres als wachtwoord. Bijvoorbeeld inloggen: anoniem wachtwoord: ftpuser@adobe.com ftp.adobe.com/signon.txt - Luka
Een andere manier om het pakket te krijgen is om het te downloaden van Launchpad. - Ruslan


Ja dat is er, maar de ondersteuning is weggevallen. Controleren dit uit en volg de instructies om te installeren:

  1. Open de terminal door op Ctrl + Alt + T op het toetsenbord te drukken. Plak bij het openen de onderstaande opdracht en druk op enter om de repository toe te voegen:

    sudo add-apt-repository "deb http://archive.canonical.com/ precise partner"
    

    Voer uw gebruikerswachtwoord in wanneer dit wordt gevraagd. Merk op dat er geen visuele feedback is wanneer u een wachtwoord typt.

  2. Nadat u de repository hebt toegevoegd, werkt u pakketlijsten bij en installeert u het acroread-pakket door de opdrachten één voor één uit te voeren:

    sudo apt-get update
    sudo apt-get install acroread
    

    Na de installatie moet u het vanuit Unity Dash of het menu Toepassingen openen.

  3. Na correct geïnstalleerde Adobe Reader, vergeet niet om de Canonical Partners-repository voor Precise te verwijderen:

    sudo add-apt-repository -r "deb http://archive.canonical.com/ precise partner"
    sudo apt-get update
    
  4. Adobe Reader instellen als standaard PDF-lezer:

Voer de onderstaande opdracht in terminal uit om het configuratiebestand te bewerken:

    sudo gedit /etc/gnome/defaults.list

Wanneer het bestand wordt geopend, doet u het volgende:

Zoek uit en verander de lijn

application/pdf=evince.desktop

in:

application/pdf=acroread.desktop

Voeg de onderstaande regel toe aan het einde:

application/fdf=acroread.desktop
application/xdp=acroread.desktop
application/xfdf=acroread.desktop
application/pdx=acroread.desktop

Sla tenslotte het bestand op en start nautilus opnieuw (voer opdracht nautilus -q in terminal uit) om wijzigingen toe te passen.


14
2018-05-05 10:57



Waarom is de ondersteuning gedaald? - Léo Léopold Hertz 준영
Geen idee. Sinds 13.10. - Mookey
Ik snap dat sommige pakketten niet kunnen worden geïnstalleerd als dit wordt geprobeerd (voor 16.04): "acroread: Afhankelijk: nspluginwrapper maar het kan niet worden geïnstalleerd". Proberen om nspluginwrapper te installeren geeft aan dat het geen installatiekandidaat heeft. - Steve Kroon
Update: door te lopen sudo apt install adobereader-enu , Ik kon met succes installeren. - Steve Kroon
de versie van acrobaat is daar te oud. het ondersteunt wel bewerkingskalenderachtige ingangen. - ses


Je zou gewoon de .deb moeten kunnen downloaden vanaf hier: ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb

en installeer het door dat bestand te openen. Probeer te installeren via de terminal om eventuele fouten te bekijken als deze niet werkt via de GUI van de softwarebeheerder: https://unix.stackexchange.com/a/159103/173836

Ik open meestal bestanden met Acrobat door gebruik te maken van de terminal en de acroread filename.pdf opdracht. Het duurde een tijdje om de eerste keer dat ik het runde te openen.

Toen ik het meest recent het op Ubuntu 16.04 installeerde, kreeg ik een paar fouten:

libxml2.so.2: cannot open shared object file: No such file or directory

en

Gtk-Message: Failed to load module "canberra-gtk-module"

Ik heb deze opgelost

sudo apt-get install libxml2:i386 libstdc++6:i386 (van hier)

en

sudo apt-get install libcanberra-gtk-module:i386 (van hier)

Blijkbaar kan er nog een andere fout aan verbonden zijn adobereader-enu:i386; rennen:

sudo apt-get install libgtk2.0-0
sudo apt-get -f install

Installeer vervolgens het .deb-bestand opnieuw en u zou moeten worden gesorteerd.


11
2018-05-27 04:04



Heb je geprobeerd het te installeren? Als dit zo simpel was, zouden mensen dit allemaal niet hebben meegemaakt - Anwar
Dit werkt in feite. Ik zal het antwoord aanpassen met enkele extra stappen voor het geval iemand de fouten krijgt die ik heb. - skepticscript
De versie van libgtk2.0-0 is niet hoog genoeg om dit specifieke deb-bestand te installeren. Adobe vereist libgtk versie 2.4 en op Ubuntu 17.04 is er alleen versie 2.24 van libgtk - jr0cket
De vraag was voor Ubuntu 16.04. Het werkt op die versie. - skepticscript
Geïnstalleerd na het volgen van de procedure, maar het mislukte stil bij het opstarten. - user276851


Afhankelijkheden installeren voor Adobe Reader

sudo apt-get install gtk2-engines-murrine:i386 libcanberra-gtk-module:i386 libatk-adaptor:i386 libgail-common:i386

Installeer Adobe Reader met de volgende opdrachten

sudo add-apt-repository "deb http://archive.canonical.com/ precise partner" 
sudo apt-get update 
sudo apt-get install adobereader-enu

Na het installeren moet je de precieze repository verwijderen met behulp van de volgende commando's

sudo add-apt-repository -r "deb http://archive.canonical.com/ precise partner" 
sudo apt-get update

Voor configuratie heb ik een Breif-artikel geschreven Installatie van Adobe Reader in Ubuntu 16.04 / 16.06


8
2018-04-10 16:50



Ja, het werkt (getest op 16.04.3). Dank je! - user276851


U kunt nog steeds de nieuwste versie "Adobe Acrobat Reader DC" gebruiken samen met wijn, hoewel Adobe enkele jaren geleden de PDF-reader-software voor Linux stopzette. Het werkt perfect voor mij.

Eerste installatie wine en winetricks

sudo apt install wine-stable winetricks

Bereid wijn voor om de DC-installatie van Acrobat Reader te ontvangen:

winetricks mspatcha

Download de nieuwste versie van Adobe Reader voor Windows 10 via de officiële website http://get.adobe.com/uk/reader/otherversions/

Een bestand met extensie exe wordt gedownload. (AcroRdrDC1801120040_en_US.exe) Installeer nu dat exe-bestand in wijn:

wine AcroRdrDC1801120040_en_US.exe

(Gebruik dezelfde naam als die van het gedownloade exe-bestand)

Klik Install knop.

Wacht tot de installatie is voltooid en klik op Finish.

Zoek nu naar Acrobat Reader in het applicatiemenu en open het.

kiezen Always open with Protected Mode Disabled. (Adobe Reader DC wordt standaard in de beveiligde modus uitgevoerd om een ​​extra beveiligingslaag te bieden)

Accepteer de licentie.

Nu kunt u uw bestanden openen met Acrobat Reader DC, zelfs op Ubuntu.


3
2018-05-19 07:42



Werkte ook in Manjaro, hoewel het winetricks mspatcha eindigde met een fout. Opmerking: het uitvoerbare bestand dat met wijn wordt uitgevoerd, is AcroRd32.exe - zezollo


Ik vond dat:

sudo apt install adoberead-enu

... geeft een foutmelding dat het pakket niet gevonden kon worden adoberead-enu. Maar toen ik deed:

sudo apt install adoberead-bin:i386

... het werkte, en het resultaat lijkt een werkende Adobe Reader te zijn.

Ik gebruik Ubuntu 16.04.


2
2017-09-27 03:50