Vraag Hoe verander ik mijn standaardbrowser?


Is er een optie om mijn standaardbrowser voor al mijn toepassingen te wijzigen?


94
2017-11-14 21:41


oorsprong




antwoorden:


Kijk eens naar je system-settings -> Details:

(Merk op dat in oudere versies van Ubuntu Details wordt genoemd System Info)

enter image description here


103
2017-11-14 21:48



Als dat het goede teken in je antwoord is, klaar. - Ederico
Wauw, dat is een mooie dom plaats om het te zeggen! Bijna net zo slecht als het moeten gaan naar "instellingen" om uw computer uit te zetten in Windows 8. - Mike
in ubuntu 14.04 [kaneelthema] navigeer naar System Settings > Preferred applications - diEcho
Om dit op Ubuntu 14.04 vanuit de CLI te starten, probeer het unity-control-center  askubuntu.com/questions/116655/... - Winny
Hoe laat ik daar een toepassing verschijnen? - Anaphory


Dit is een ubuntu manier om dit te doen

sudo update-alternatives --config x-www-browser
sudo update-alternatives --config gnome-www-browser

45
2017-10-29 11:43



Dit is een systeembrede verandering en moet worden gedaan in aanvulling op het antwoord van fossfreedom. - Flimm
Ik heb hier alle antwoorden geprobeerd; alleen de tweede van deze twee regels veranderde de browser waarin browser-externe koppelingen (bijvoorbeeld van Pidgin) werden geopend. - Stew
Dit is de meest geschikte manier om dit te doen, werkend voor i3WM en andere bureaubladomgevingen waar terminals regels zijn. Bedankt voor het delen. - Geppettvs D'Constanzo
Dit werkte niet voor mij op ubuntu 16.04 (probeerde de browser gebruikt door thunderbird te veranderen om links te openen). De geaccepteerde oplossing werkte. - Étienne


Als uw voorkeursbrowser niet in dat menu staat of u doet dit liever vanaf de opdrachtregel, kunt u met deze opdracht hetzelfde doen als in het antwoord van fossfreedom:

xdg-settings set default-web-browser name-of-browser.desktop

bijv .:

xdg-settings set default-web-browser firefox.desktop

of

xdg-settings set default-web-browser chromium-browser.desktop

of

xdg-settings set default-web-browser google-chrome.desktop

30
2018-03-28 20:44



Om SEO-redenen: dit werkt met i3wm wanneer Chrome naar binnen sluipt x-www-browser en update-alternatives is buiten bereik omdat het vereist sudo. Je moet hebben my-application.desktop beschikbaar, bijvoorbeeld in ~/.local/share/applications/my-app.desktop. Maar je komt niet het hele pad over xdg-settings, alleen de bestandsnaam. - black_puppydog


Alle voorkeuren over standaardtoepassingen die uw gebruiker heeft gevonden in het bestand "mimeapps.list". Ik gebruik Gnome 3 en Debian, dus dat is het voor mij ~/.config/mimeapps.list.

Ik weet niet waar dit bestand zich bevindt, probeer opdracht:

locate mimeapps.list

Als u een standaardbrowser wilt uitschakelen, moet u ten minste de waarden in de categorie wijzigen [Standaardapplicaties]

  • x-regeling-handler / http
  • text / html
  • application / xhtml_xml
  • image / WebP
  • x-regeling-handler / https
  • x-regeling-handler / ftp
  • x-regeling-handler / https
  • x-regeling-handler / ftp

en in categorie [Toegevoegd verenigingen]

  • text / html
  • text / xml
  • application / xhtml_xml
  • image / WebP
  • x-regeling-handler / https
  • x-regeling-handler / ftp

Voor Opera het bestand ~/.config/mimeapps.list must bevat:

[Default Applications]
x-scheme-handler/http=opera-browser.desktop
text/html=opera-browser.desktop
text/xml=opera-browser.desktop
application/xhtml_xml=opera-browser.desktop
image/webp=opera-browser.desktop
x-scheme-handler/https=opera-browser.desktop
x-scheme-handler/ftp=opera-browser.desktop

[Added Associations]
text/html=opera-browser.desktop;
text/xml=opera-browser.desktop;
application/xhtml_xml=opera-browser.desktop;
image/webp=opera-browser.desktop;
x-scheme-handler/https=opera-browser.desktop;
x-scheme-handler/ftp=opera-browser.desktop;

Probeer het (moet open zijn in Opera, als het is geïnstalleerd)

xdg-open somehtmlfile.html

Voor Chrome het bestand ~ / .config / mimeapps.list moet bevatten:

[Default Applications]
x-scheme-handler/http=google-chrome.desktop
text/html=google-chrome.desktop
text/xml=google-chrome.desktop
application/xhtml_xml=google-chrome.desktop
image/webp=google-chrome.desktop
x-scheme-handler/https=google-chrome.desktop
x-scheme-handler/ftp=google-chrome.desktop

[Added Associations]
text/html=google-chrome.desktop;
text/xml=google-chrome.desktop;
application/xhtml_xml=google-chrome.desktop;
image/webp=google-chrome.desktop;
x-scheme-handler/https=google-chrome.desktop;
x-scheme-handler/ftp=google-chrome.desktop;

Probeer het (moet open zijn in Chrome, als het is geïnstalleerd)

xdg-open somehtmlfile.html

En zo verder (Firefox, of iets anders).

U hoeft alleen wens-mimetypes te overschrijven. Maar ik raad aan om er GUI voor te gebruiken. Het zal het aantal fouten verminderen.

Het is feitelijk voor mij systeem en zal worden gewijzigd van systeem naar systeem, van bureaubladomgeving naar bureaubladomgeving, enzovoort.

Testomgeving

$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 8.6 (jessie)
Release:    8.6
Codename:   jessie
$ uname -a
Linux localhost 3.16.0-4-amd64 #1 SMP Debian 3.16.36-1+deb8u2 (2016-10-19) x86_64 GNU/Linux
$s gnome-session --version
gnome-session 3.14.0

2
2017-12-26 13:57





Afgezien van enkele van de bovenstaande opmerkingen, zou ik willen voorstellen het beste antwoord te volgen hier. Het gaat om het veranderen van de mimeapps / url schema's van uw huidige gebruiker.

Ik moest die oplossing gebruiken om linux te maken Skype zich normaal gedragen. De meeste andere toepassingen zouden gebruiken x-www-browser of gnome-www-browser maar ik denk dat ze wel een punt hebben om de URL-schema's; soms is het logischer.


1
2017-09-30 05:50



Dit geeft geen antwoord op de vraag. Als je een auteur wilt bekritiseren of om opheldering wilt vragen, laat dan een reactie achter onder zijn of haar bericht - je kunt altijd reageren op je eigen berichten en als je eenmaal voldoende hebt reputatie je zal in staat zijn reageer op een bericht. - Jan
Ik dacht dat dit nog steeds de vraag voor beantwoordde Skype waarvoor voor zover ik weet, de veranderingen in de top antwoord heeft geen invloed op hoe skype de standaardtoepassing kiest in alle voorwaarden. Het antwoord is hier om gebruikers te helpen in het geval de eerste dat niet doet. Als dit kan worden gedaan door te reageren met opmerkingen bij het eerste antwoord, dan zal ik precies dat doen. :) Bedankt voor de heads-up! - Adrian Castravete
Snap je, Adrian - zit gewoon in dezelfde boot. Maar dat loste het niet voor mij op. Wat het oploste, was dit antwoord. Maar dat zou te wijten kunnen zijn aan het feit dat ik LXDE als bureaublad gebruik. - Izzy


U kunt uw standaardbrowser ook wijzigen in de relevante browserinstellingen, bijvoorbeeld

Firefox:
Preferences, tick 'Always check if Firefox is your default browser'

Chromium:
Settings, click 'Make chrome default browser'


1
2017-10-29 12:10



Dit werkt niet voor mij op 15.04 - user11153


Systeem -> Controlecentrum -> Voorkeursapplicaties
voor ubuntu met MATE DESKTOP


0
2018-04-22 13:59