Vraag Rhythmbox 2.98 crasht de hele tijd


De standaardversie van rhythmbox is 2.98 en crasht altijd na een lange pauzeperiode. Hoe kan ik deze versie upgraden naar een nieuwere versie?


2
2018-06-26 08:10


oorsprong




antwoorden:


Voordat je ingewikkelde dingen gaat doen, probeer je gewoon "Watch my library" en crossfade in preferences uit te schakelen. Dit zijn de meest complexe taken die Rhythmbox kan doen.


2
2018-06-26 11:05





Ik raad aan de nieuwste versie (2.99.1) te downloaden van http://ftp.acc.umu.se/pub/GNOME/sources/rhythmbox/2.99/rhythmbox-2.99.1.tar.xz dit moet worden geïnstalleerd met de volgende opdrachten:

Ga eerst naar de plaats waar u het bestand hebt gedownload:

cd Downloads

Vervolgens moet je het bestand uitpakken met

sudo apt-get install unp
unp rhythmbox-2.99.1.tar.xz

Hiermee wordt unp geïnstalleerd, die zal worden gebruikt voor het uitpakken van bestanden uit het archief met behoud van de mappenhiërarchische structuur. Vervolgens het bestand uitpakken.

Dan moeten we het installeren.

Eerst voeren we de nieuw aangemaakte map in

cd rhythmbox-2.99.1

Nu om het bestand te configureren dat we invoeren:

./configure

Volgende We maken het bestand:

make

Eindelijk installeren we het

make install

U moet dan mogelijk opnieuw opstarten, maar dat zou het moeten zijn.

Bewerk

De langdradige manier zou zijn:

Voer het volgende uit in Terminal

sudo apt-get update
sudo apt-get upgrade

om het systeem bij te werken. Dan:

sudo apt-get install <dependency>

Probeer het dan opnieuw. Hiermee worden eerst de ontbrekende pakketten geïnstalleerd.


0
2018-06-26 08:38



Bij het maken van de ./configure geeft deze fout: controleren op gobject-introspectie ... configureren: fout: gobject-introspection-1.0 is niet geïnstalleerd. Ik voer dit uit: apt-get installeer gobject-introspection, maar blijft dezelfde fout geven. Kun je me helpen? Dank je - Kaf
het gebruik van de dpkg -l verschijnt: gobject-introspection 1.36.0-1 i386 - Kaf
voer het volgende commando uit in Terminal sudo apt-get install -f zonder pakketnaam, zou dit dit moeten genezen omdat het alle vereiste pakketten zal installeren - SimplySimon
het deed het niet. De fout blijft. - Kaf
OK, ik heb iets meer toegevoegd aan het antwoord, vervang <package> met gobject-introspection-1.0 - SimplySimon


Een waarschuwing: deze methode heeft mijn Rhythmbox-installatie verpest. Ik kan 2,99 niet uitvoeren en heb onoplosbare afhankelijkheidsproblemen bij het installeren van 2.98.


Hoewel Barafu Albino het antwoord heeft gegeven dat je probleem oploste, wil ik toch graag het antwoord geven op de vraag hoe je Rhythmbox kunt bijwerken naar een nieuwere als iemand daarin geïnteresseerd is.

Je kunt Rhythmbox updaten naar 2.99.1 via een PPA. Open Terminal en typ het volgende in:

sudo add-apt-repository ppa:dobey/rhythmbox-dailies
sudo apt-get update
sudo apt-get install rhythmbox

De PPA geeft aan dat het de dagelijkse builds van Rhythmbox is, maar dat lijkt niet het geval te zijn. Rhythmbox 3.0 is onlangs uitgebracht. Ik weet niet of deze PPA automatisch naar die versie zal worden bijgewerkt.

Bron: LinuxG.net


0
2017-09-24 16:54



Ik heb dit zojuist geprobeerd en terwijl de update werkt en Rhythmbox installeert, werkt het niet voor mij (13.04). Ik laat het antwoord hier achter voor het geval het voor iedereen nuttig is, maar ik ga terug naar 2.98. Ik heb daar eigenlijk moeite mee, want ik heb nu problemen met afhankelijkheid. Ga voorzichtig verder! - duxk.gh