Vraag Hoe krijg ik Ubuntu om de nieuwe geïnstalleerde Pandoc-versie te herkennen?


Ik wil een nieuw installeren pandoc versie. Ik volgde de beschreven procedure hier.

mark@server:~$ sudo cabal install pandoc pandoc-citeproc

Dit is gelukt. Maar bij het controleren van de geïnstalleerde versie die ik krijg

mark@server:~$ pandoc -v
pandoc 1.12.2.1

Dit is niet de nieuwste, hoewel ik bij het opnieuw uitvoeren van de bovenstaande installatieopdracht nog een versiegegevens krijg:

All the requested packages are already installed:
pandoc-1.13.2
pandoc-citeproc-0.6
Use --reinstall if you want to reinstall anyway.

Hoe krijg ik Ubuntu om de nieuwste installatieversie uit te voeren? Dit kan een simpele Ubuntu-vraag zijn (nou ik ben nieuw voor Linux), maar ik begrijp niet hoe ik Ubuntu de nieuwe pandoc-versie kan laten zien.


2
2018-03-07 10:41


oorsprong


Cabal heeft geen invloed op het archief van ubuntu-pakketten. U moet het gegenereerde binaire bestand naar het gewenste pad verplaatsen voor uitvoering en handmatig het systeempakket verwijderen. - cosmoscalibur


antwoorden:


Cabal heeft geen invloed op het archief van ubuntu-pakketten. U moet het gegenereerde binaire bestand naar het gewenste pad verplaatsen voor uitvoering en handmatig het systeempakket verwijderen.


2
2018-01-03 04:47



kun je daar wat meer over vertellen, zodat nieuwelingen het zullen begrijpen (zoals locaties, paden, etc.)? - Mark Heckmann