Vraag Hoe een LibreOffice-woordenboek te installeren (Spellingcontrole, Thesaurus ...)


Wat zijn de stappen om de spellingcontrole en andere taalondersteuning voor LibreOffice te installeren. Bijvoorbeeld Spaans, Frans, Italiaans, enz.


99
2017-10-25 21:40


oorsprong




antwoorden:


Dit wordt blijkbaar op systeemniveau beheerd. Ga naar de Taalondersteuning menu in de Systeem instellingen menu en voeg de talen toe die u wilt ondersteunen. Daarna herstart u LibreOffice en ziet u dat de spellingcontrole u bijvoorbeeld de mogelijkheid biedt om de nieuw geïnstalleerde talen te gebruiken.


80
2017-10-25 21:48



Oké, ik was op de oude manier van kijken naar de taalondersteuningspakketten. Dit scheelt me ​​veel hilariteit. Bedankt. - Luis Alvarado♦
Heeft gewerkt voor mij, maar is het mogelijk vanaf de opdrachtregel? Andere voorgestelde opdrachtregeloplossingen faalden voor mij. - Ciro Santilli 新疆改造中心 六四事件 法轮功
@cirosantilli, heb je de andere "opdrachtregel" antwoorden hieronder geprobeerd ?, bijvoorbeeld: sudo apt-get install myspell-es of aspell-es of hunspell-es - alfC
werkt niet zo voor de meeste talen in Ubuntu 14.04 met LO 4.2 - cipricus
Reactie van Andre Blecha: een waarschuwing: het systeem zal taalafhankelijke bestanden downloaden, zoals hulp en documentatie voor AL uw geïnstalleerde applicaties. Dit kan disc-ruimte en tijdrovend zijn. - Fabby


Het bevel: sudo apt-get install aspell-<language pack> zal het lukken

Het Spaanse woordenboek is bijvoorbeeld:

sudo apt-get install aspell-es


29
2018-01-13 13:28



Dat is specifiek voor de spellingcontrole, toch? Dat geeft je eigenlijk niet de thesaurus of andere functies in de taal, nietwaar? - Eliah Kagan
je hebt gelijk Elia is gewoon de spellingscontrole - German Attanasio
Onlangs had ik een soortgelijk probleem met Evolution e-mail, in dat geval was de oplossing om iets soortgelijks te doen, maar met hunspell in plaats daarvan, sudo apt-get install hunspell-es - alfC
Om alle beschikbare woordenboeken te zien sudo apt-cache zoek aspell - Philippe Gachoud
installeren aspell woordenboeken werkten niet voor mij (Kubuntu 16.04, LibreOffice 5.1.4.2), maar installeren myspell deed het werk. - datka


Als u geen systeempakketten kunt installeren, kunt u handmatig een spellingcontrole-woordenboekuitbreiding installeren. U moet LibreOffice opnieuw starten.

Amerikaans Engels woordenboek hier beschikbaar: extensions.libreoffice.org.

Instructies voor het installeren van extensies:

  1. Download een extensie en bewaar deze overal op uw computer.
  2. Selecteer in LibreOffice Extra → Extensiebeheer in de menubalk.
    Tools > Extension Manager...
  3. Klik in het dialoogvenster Extensiebeheer (Afbeelding 2) op Toevoegen. Using the Extension Manager
  4. Er wordt een bestandsbrowser geopend. In het dialoogvenster Extensie toevoegen (Add Extension) kunt u de bestanden van de extensie in uw systeemmappen vinden. De bestanden van de extensie hebben een OXT-bestandsextensie. Add Extension(s) dialog
  5. Zoek en selecteer de extensie die u wilt installeren en klik op Openen.
  6. Als deze extensie al is geïnstalleerd, wordt u gevraagd om op OK te drukken om te bevestigen of de huidige versie door de nieuwe moet worden overschreven of op Annuleren om de installatie te stoppen. Replacing an extension
  7. Hierna wordt u gevraagd of de extensie alleen voor uw gebruiker of voor alle gebruikers moet worden geïnstalleerd.
    • Als u de optie Alleen voor mij kiest, wordt de extensie alleen voor uw gebruiker geïnstalleerd (de extensie wordt opgeslagen in uw gebruikersprofiel en andere gebruikers hebben er geen toegang toe).
    • Als u Voor alle gebruikers kiest, moet u over systeembeheerdersrechten beschikken. In dit geval wordt de extensie geïnstalleerd in de LibreOffice-systeemmap en is deze beschikbaar voor alle gebruikers.
    • Kies over het algemeen alleen voor mij, waarvoor geen beheerdersrechten voor het besturingssysteem nodig zijn.
      Installation options: Only for me or For all users
  8. Hierna wordt u mogelijk gevraagd om een ​​licentieovereenkomst te accepteren. Use Scroll Down button to verify the license
  9. Gebruik de knop Omlaag om de licentieovereenkomst te lezen. Aan het einde van de licentietekst is de knop Accepteren ingeschakeld.
  10. Klik op Accepteren om door te gaan met de installatie.
  11. Wanneer de installatie is voltooid, wordt de extensie weergegeven in het dialoogvenster Extension Manager. Extension Manager dialog (again), now contained the installed extension

Instructies gestolen uit libreoffice.org


24
2018-05-10 21:14



werkte als een charme. het enige dat ik moest doen was de oxt-extensie aan het bestand toe te voegen omdat de extensiebeheerder het extensiebestand niet zag. sorry voor het slechte Engels. - Engels Peralta
Libreoffice zou dit proces echt eenvoudiger moeten maken. - Ciro Santilli 新疆改造中心 六四事件 法轮功


Om de Spaanse spellingcontrole op Libre-Office te installeren, hebt u het volgende pakket nodig:

sudo apt-get install myspell-es

14
2018-05-30 16:17



1. Voor mij aspell-nl was niet werken, maar myspell-nl  was werkend - Jasper de Vries
Voor Duits is de pakketnaam, in tegenstelling tot verwacht uit het bovenstaande voorbeeld myspell-de-de. - orschiro


Voor Ubuntu 12.04 en Duits (Oostenrijk) loste het installeren van het hunspell-pakket mijn probleem op:

sudo apt-get install hunspell-de-at

Vergeet niet om LibreOffice Writer opnieuw te starten na het installeren van het pakket!


10
2018-03-15 08:07





Er is ook een zeer populaire extensie die maximaal 20 talen ondersteunt en die niet alleen typefouten, maar ook grammaticale fouten en "valse vrienden" kan detecteren. De extensie wordt gebeld LanguageTool.


2
2017-07-15 12:41



Beste antwoord naar mijn mening. LO specifieke, vele talen inbegrepen (zoals oorspronkelijk gevraagd), bijgewerkte extensie, niet systeem-breed, vereist geen root, geen "apt-get install" raadspel. - berbt
U moet het "libreoffice-java-common" -pakket installeren om dit te laten werken (anders mislukt het met een UNO / java / NoClassDefFound-fout) - Grey Panther


U moet systeemwijzigingen aanbrengen in de juiste volgorde om het in LibreOffice weer te geven, Ga naar systeeminstellingen, Selecteer uw taalvoorkeuren om het taalpakket niet alleen voor LibreOffice, maar voor uw systeem te krijgen.


1
2017-11-27 05:23



Nee, dat doe je niet nodig hebben naar. Zie andere antwoorden. - berbt


sudo apt-get --install-suggests install libreoffice-l10n-fr

Hiermee installeer je: hunspell hunspell-fr-comprehensive hyphen-fr libreoffice-help-fr libreoffice-l10n-fr mythes-fr

Het moest installeren libreoffice-grammarcheck-fr maar om een ​​of andere reden is het pakket niet beschikbaar op mijn installatie van linuxmint


1
2017-12-16 13:41