Vraag Hoe stel ik dubbele monitors in XFCE in?


Ik heb een laptop met een intel-chip en ik wil graag dubbele monitors instellen in Xfce.

Hoe doe ik dit?


99
2017-09-23 12:38


oorsprong


Interessant om te wijzen op het feit dat oplossingen voor deze problemen hier mogelijk maken om geen eigen stuurprogramma's te gebruiken (op een handige manier)! - smonff


antwoorden:


Open eerst de monitorconfiguratie - deze bevindt zich in Start > Settings > Settings Manger, open dan de Display item.

Zorg ervoor dat beide schermen aan staan. enter image description here

Open vervolgens een terminal en voer dit uit:

xrandr

De uitvoer ziet er ongeveer zo uit:

Screen 0: minimum 320 x 200, current 2464 x 900, maximum 4096 x 4096
LVDS1 connected 1024x600+1440+0 (normal left inverted right x axis y axis) 220mm x 129mm
   1024x600       60.0*+   65.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 connected 1440x900+0+0 (normal left inverted right x axis y axis) 408mm x 255mm
   1440x900       59.9*+   75.0  
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1280x800       74.9     59.8  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1

Voer dan het volgende uit, veranderend VGA1 en LVDS1 om het juiste scherm te matchen:

xrandr --output VGA1 --left-of LVDS1

Merk op dat je verandering kunt verplaatsen --left-of naar --right-of.

Nu zou het moeten werken, maar je hebt nog steeds een probleem.

Het verdwijnt na het uitloggen. U moet het dus toevoegen aan uw aanmeldingsitems.

Ga naar Start > Settings > Settings Manger, open vervolgens "Session and Startup", voeg de bovenstaande opdracht toe aan uw aanmeldingsitems en u bent klaar om te beginnen!

enter image description here


125
2017-09-23 12:40



Ik heb dit account gemaakt, zodat ik je echt behulpzame vraag en antwoord kan bijwerken. Ik gebruik Debian-testen en kreeg die lelijke puinhoop genaamd gnome3 die ik heb vervangen door xfce4 - en nu ben ik helemaal gelukkig :-) - slashmais
@slashmais Bedankt, ik waardeer het! Ik ben blij dat ik je heb kunnen helpen. :) - jrg♦
@jrg Ik heb xrandr - output CRT1 - LVFT - van LVDS gedaan maar ik krijg xrandr: het scherm kan niet groter zijn dan 1600x1600 (gewenste grootte 2766x1050) wanneer het een resolutie van 1400x1050 is. Wat moet ik doen? - jaorizabal
Drie jaar later! Heel erg bedankt, dit hielp veel meer dan je weet! - opiop65
Dit is een goed antwoord, maar je moet het herhalen voor elke gebruiker op een systeem met meerdere gebruikers. Zie voor een eenmalige systeembrede oplossing wiki.archlinux.org/index.php/... - Aaron J Lang


Er is een andere oplossing voor dit probleem.

Volgens Dit artikel, xfce 4.11 en 4.12 hebben multi-monitoropstelling uit de doos geïmplementeerd. Ik vermoed dat deze vraag daarom verouderd zal zijn voor ubuntu 13.04.

Ondertussen, voor ubuntu 12.04 en 12.10, kan men de xfce 4.12 ppa gebruiken:

sudo add-apt-repository ppa:xubuntu-dev/xfce-4.12
sudo apt-get update
sudo apt-get upgrade
xfce4-display-settings -m

21
2018-02-10 19:20



Werkt perfect op Ubuntu 13.10! - Nordlöw
Hiermee kunt u opgeven dat 'VGA1 gelijk heeft aan HDMI1' maar u geen verticale offset krijgt als de monitoren een ander formaat hebben. Arandr zal dit behandelen. - aquaherd
Fijn om te leren dat het gaat om XFCE ... - smonff


Nu kunt u gebruiken Arandr.

Hiermee kun je dat doen visuele editor en sla vervolgens de instellingen op als shellscript met xrandr commando script.

Dan kun je het toevoegen aan autostart.


17
2017-10-11 20:56





Ik had hetzelfde probleem en loste het op met een grafische applicatie. De naam is grandr en bevindt zich in de universe-repository (Ubuntu 11.04). Je kunt je dubbele instelling naar believen wijzigen. Ik hoop dat het helpt.


15
2017-09-28 10:47



Grandr is niet langer beschikbaar vanaf 12.04 - maar dat is niet het geval - 23 93 26 35 19 57 3 89
Als arandr is een nieuwe oplossing, zie het antwoord hierboven - smonff


Als u een "monitor switching" -knop op uw toetsenbord hebt

  1. Sluit de externe monitor aan.
  2. Klik op uw monitor-schakelknop en kies in het dialoogvenster "Beeldschermen" welk beeldscherm u wilt gebruiken, of dat u het ene wilt uitbreiden of het andere wilt spiegelen: "Displays" dialog

Als u geen "monitor switching" -knop op uw toetsenbord hebt

  1. Zoek in het Whisker-menu naar de instellingenmanager en klik op Beeldscherm (of zoek naar Weergave in het Whisker-menu).
  2. Vink "Nieuwe weergaven configureren bij verbinding" aan en sluit het dialoogvenster: Display Settings
  3. Sluit de externe monitor aan
  4. Het dialoogvenster "Beeldschermen" zou automatisch moeten verschijnen, nu kunt u kiezen welke monitor u wilt gebruiken, of wilt u dat de ene de andere vergroot of de andere spiegelt: "Displays" dialog

Meer informatie: http://docs.xfce.org/xfce/xfce4-settings/display


2
2018-02-14 08:08





Ja, Xrandr en / of de versie 4.12 gui voor de weergave-instellingen laten u toe om posities van monitoren te wisselen, en het is mogelijk om het paneel met het applicatiemenu op de rechtermonitor te hebben. Op de linkermonitor verschijnen echter nog steeds bureaubladpictogrammen.

Het zou goed zijn als Xfce iets als de FolderView-instelling in KDE implementeert, waarbij u de primaire monitor aan de rechterkant (met zijn paneel- en bureaubladpictogrammen) kunt hebben.


0
2018-02-13 16:25





Hartelijk bedankt. Ik heb nu een uitgebreide installatie met twee monitoren (MSI CR700, Nvidia GeForce 8200M G), met Xubuntu 12.04. Na vele dagen van rouw met verschillende versies van Ubuntu, installeerde ik Xubuntu 12.04 en kreeg dual mirrored monitors. Om een ​​uitgebreide desktop over beide monitoren te krijgen, vond ik het advies hier (http://www.webupd8.org/2012/11/how-to-use-multiple-monitors-in-xubuntu.html) erg behulpzaam. Maar arandr is buggy; het werkte een keer, toen kreeg ik een grijs scherm dat het bureaublad en de launcher aan de onderkant van het scherm verbergde. Het advies van 78 hierboven, namelijk: xrandr gevolgd door: xrandr - uitgang VGA1 - links-van LVDS1 (pas VGA1 en LVDS1 aan afhankelijk van de uitvoer van xrandr) heeft het probleem verholpen. Erg bedankt.


0
2018-03-07 08:53





----------------------- OPLOSSING VOOR xrandr: scherm kan niet groter zijn dan -------------

Stap .1 Controleer of u het bestand xorg.conf in / etc / X11 ..... ja: ga naar stap 3 anders stap 2

Stap .2 Maak een xorg.conf-bestand met behulp van de volgende stap

                 Step 2.a    switch to console mode: Alt+Ctrl+F1
                 Step 2.b    kill x server: sudo service lightdm stop
                 Step 2.c    generate new xorg.conf file: sudo X -configure -- this
                             will create xorg.conf.new file in your current dir
                 Step 2.d    rename and move: sudo mv xorg.conf.new /etc/X11/xorg.conf
                 Step 2.e    return to GUI: sudo start lightdm

Stap .3 Open /etc/X11/xorg.conf en voeg "Virtual 3200 1080" toe in subsectie "Weergave"

                 Step 3.a    vi /etc/X11/xorg.conf
                 Step 3.b    Add "Virtual 3200 1080" to ALL SubSection "Display" 
                             FOR ALL SCREEN if you have more than one "Display"
                             Subsection and more than 1 screen (replace 3200 1080 
                             with your desired screen resolution)
                             FOR EXAMPLE:
                                    Section "Screen"
                                    Identifier "Screen1"
                                    Device     "Card1"
                                    Monitor    "Monitor1"
                                         SubSection "Display"
                                               Viewport   0 0
                                               Depth     1
                                               Virtual 3200 1080
                                         EndSubSection
                                     EndSection
                                    Section "Screen"
                                    Identifier "Screen2"
                                    Device     "Card1"
                                    Monitor    "Monitor1"
                                         SubSection "Display"
                                               Viewport   0 0
                                               Depth     1
                                               Virtual 3200 1080
                                         EndSubSection
                                     EndSection

Stap 4. Start uw computer / laptop opnieuw op

Stap 5. Maak een script (vi /etc/X11/dual_monitor.sh) en voeg het volgende toe                    xrandr --output DVI-0 - modus 1280x1024                    xrandr --output DVI-1 - mode 1920x1080                    xrandr --output DVI-0 --auto - right-of DVI-1 --pos 1920x0             verander de bestandsrechten                    chmod 755 /etc/X11/dual_monitor.sh             (opmerking: mijn scherm1 is DVI-1 en scherm2 is DVI-0 en vervang de resolutie als             per behoefte)

Stap 6. Voer het script uit en kijk of het werkt. (/etc/X11/dual_monirot.sh)

Stap 7. Als het script werkt, neemt u het script op in Auto Start             Menu >> Instellingen >> Sessie en opstarten >> Toepassing Autostart >> Toevoegen                    Naam: Dual Monitor Xfce                    Beschrijving: Dual Monitor Xfce                    Commando: /etc/X11/dual_monitor.sh

Stap 8. Start opnieuw en geniet ervan

Stap 9. Voer stap 7 opnieuw uit voor alle gebruikers die als gebruiker zijn aangemeld

(Laat het me weten als het werkte shasankh@hotmail.com)


0
2017-12-24 17:08





Stap 5. Maak een script (vi /etc/X11/dual_monitor.sh) en voeg het volgende toe

         xrandr --output DVI-0 --mode 1280x1024 
         xrandr --output DVI-1 --mode 1920x1080 
         xrandr --output DVI-0 --auto --right-of DVI-1 --pos 1920x0 

   change the file permission chmod 755 /etc/X11/dual_monitor.sh 
   (note: my screen1 is DVI-1 and screen2 is DVI-0, and replace resolution as per need)

Stap 6. Voer het script uit en kijk of het werkt. (/etc/X11/dual_monirot.sh)

Stap 7. Als het script werkt, neemt u het script op in Auto Start

        Menu >> Settings >> Session and Startup >> Application Autostart >> Add 
                Name: Dual Monitor Xfce 
                Description: Dual Monitor Xfce 
                Command: /etc/X11/dual_monitor.sh

Stap 8. Start opnieuw en geniet ervan

Stap 9. Voer stap 7 opnieuw uit voor alle gebruikers die als gebruiker zijn aangemeld


0
2017-12-24 17:12