Vraag Kan geen USB-penstation monteren


Het is een USB-stick van 4 GB. Geformatteerde NTFS. USB2. Werkt prima op vensters op dezelfde computer (en anderen). Het heeft de inhoud van een Windows XP-installatieschijf.

... ik kan het gewoon niet aankoppelen. Wanneer ik verbinding maak, gebeurt er niets, maar ik geloof dat Ubuntu het kan zien.

Hier zijn enkele commando-uitgangen


laatste paar regels van dmesg

[  164.703187] ieee80211 phy0: rt2800usb_txdone: Warning - Got TX status for an empty queue 2, dropping
[  554.953670] usb 1-4: USB disconnect, device number 2
[  565.092026] usb 1-4: new high-speed USB device number 6 using ehci-pci
[  565.227144] usb 1-4: New USB device found, idVendor=0951, idProduct=1641
[  565.227150] usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  565.227154] usb 1-4: Product: DataTraveler C10
[  565.227157] usb 1-4: Manufacturer: Kingston
[  565.227160] usb 1-4: SerialNumber: 0019B9087CD7A9C1164B005C
[  565.227564] usb-storage 1-4:1.0: USB Mass Storage device detected
[  565.228288] scsi4 : usb-storage 1-4:1.0
[  566.228802] scsi 4:0:0:0: Direct-Access     Kingston DataTraveler C10 8.20 PQ: 0 ANSI: 2
[  566.229160] sd 4:0:0:0: Attached scsi generic sg2 type 0
[  566.229950] sd 4:0:0:0: [sdb] 7825408 512-byte logical blocks: (4.00 GB/3.73 GiB)
[  566.231158] sd 4:0:0:0: [sdb] Write Protect is off
[  566.231164] sd 4:0:0:0: [sdb] Mode Sense: 23 00 00 00
[  566.231904] sd 4:0:0:0: [sdb] No Caching mode page found
[  566.231910] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[  566.237756] sd 4:0:0:0: [sdb] No Caching mode page found
[  566.237762] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[  567.282038]  sdb: unknown partition table
[  567.287030] sd 4:0:0:0: [sdb] No Caching mode page found
[  567.287036] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[  567.287040] sd 4:0:0:0: [sdb] Attached SCSI removable disk

het deel dat betrokken is bij het apparaat van sudo fdisk -l

Disk /dev/sdb: 4006 MB, 4006608896 bytes
255 heads, 63 sectors/track, 487 cylinders, total 7825408 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0066cd1f

This doesn't look like a partition table
Probably you selected the wrong device.

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   ?          63     7825407     3912672+   7  HPFS/NTFS/exFAT

sudo blkid toont het apparaat niet


Probeerde het te koppelen met die commando's:

sudo mount /dev/sdb1 /media/somefolder/someotherfolder maar het geeft

mount: special device /dev/sdb1 does not exist

en;

sudo mount -t ntfs /dev/sdb1 /media/somefolder/someotherfolder

ntfs-3g: Failed to access volume '/dev/sdb1': No such file or directory

ntfs-3g 2013.1.13AR.1 external FUSE 29 - Third Generation NTFS Driver
    Configuration type 7, XATTRS are on, POSIX ACLS are on

Copyright (C) 2005-2007 Yura Pakhuchiy
Copyright (C) 2006-2009 Szabolcs Szakacsits
Copyright (C) 2007-2012 Jean-Pierre Andre
Copyright (C) 2009 Erik Larsson

Usage:    ntfs-3g [-o option[,...]] <device|image_file> <mount_point>

Options:  ro (read-only mount), windows_names, uid=, gid=,
          umask=, fmask=, dmask=, streams_interface=.
          Please see the details in the manual (type: man ntfs-3g).

Example: ntfs-3g /dev/sda1 /mnt/windows

News, support and information:  http://tuxera.com

sudo ntfs-3g /dev/sdb1 /media/somefolder/someotherfolder geeft precies dezelfde uitvoer als hierboven.


pmount /dev/sdb1 kingston geeft;

Error: device /dev/sdb1 does not exist

Help alstublieft

Bewerk! "Schijven" ziet het apparaat !! (de Kingston-een) ... maar wat nu? disks output

Bewerk: output van sudo mount -t ntfs -o loop=/dev/loop3 /dev/sdb /mnt

NTFS signature is missing.
Failed to mount '/dev/loop3': Invalid argument
The device '/dev/loop3' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

2
2018-05-23 20:48


oorsprong




antwoorden:


Heb je de Disks-applicatie geprobeerd? (Druk op Super / Win-toets, typ Disks) Het toont alle apparaten die Ubuntu kan zien. Vanaf daar kun je zien welke apparaten zijn aangekoppeld, partities bewerken, opmaken.


2
2018-05-23 21:51



!!!! verrassend genoeg ziet het de flashdrive !!! dacht daar niet aan! ... maar ik weet niet wat ik hierna moet doen. - Mina Michael
... wie gaf de man een min één !? -_- - Mina Michael
... hoewel je dit niet als een antwoord had moeten posten, had je het als commentaar moeten toevoegen. (regels zijn de regels). - Mina Michael


Probeer het / dev / sdb (NO PARTITION nummer) te monteren met de loop-optie. d.w.z. behandel het als een bestand dat je monteert met de loopback, en natuurlijk het ntfs bestandssysteem type. Omdat fdisk geen partitietabel lijkt te zien, heeft het misschien geen!

sudo mount -t ntfs  -oloop=/dev/loop /dev/sdb /mnt

Controleer de bevestigingsopties (man mount). Er is een offset, wat kan helpen omdat de startsector 63 is. Je zou de datablokken in een bestand met dd kunnen lezen (gebruik de offset opnieuw) en mount het bestand met lus, of als je bereid bent om de data (wat toch belangrijk zou kunnen zijn op een Windows-installatieschijf;), zou je kunnen proberen een nieuwe partitietabel te maken, met behulp van de bestaande 63 start- en 7825407-uiteinden.


1
2018-05-23 21:27



Ik voel me positief over je antwoord; het is iets dat ik niet eerder heb geprobeerd ... maar nog steeds niet werkt. Ik heb dit exacte commando geprobeerd en het wordt uitgevoerd /dev/loop: No such file or directory. ... ik keek snel naar deze dus ik probeerde het sudo mount -t ntfs -o loop=/dev/loop3 /dev/sdb /mnt (merk op loop3). Ik zet de output in de hoofdvraag op. (het ziet er echt slecht uit in een opmerking) ... IK VROEG EENS NODIG OVER DEZE "NTFS-handtekening" hier maar geen antwoorden :( help? - Mina Michael


Misschien moet je je rit eerder repareren. In ieder geval heb je geluk nodig.

  1. Controleer of is niet aangekoppeld: df
  2. Probeer het te monteren, misschien iets als sudo mount -t auto /dev/sdb /mnt/. Misschien werken met -oloop=/dev/loop en ntfs of ntfs-3g op -t

TestDisk

  • apt-get install testdisk
  • Rennen testdisk
  • Kies om een ​​logboek te maken of niet.
  • Kies apparaat:

    enter image description here

  • Partitietabeltype, waarschijnlijk Intel.
  • Advance> NTFS-partitie (indien beschikbaar)> [Boot]> MFT repareren

ntfsfix

Veelvoorkomende fouten herstellen en Windows dwingen NTFS te controleren

sudo ntfsfix /dev/sdb


1
2018-04-01 03:50





Heb je geprobeerd om te monteren in alleen-lezen modus?

mount -o ro /dev/sdb1 /media/somefolder/someotherfolder

0
2018-05-23 21:13



niet goed. mount: special device /dev/sdb1 does not exist. bedankt. - Mina Michael
Ik geloof dat het / dev / sdb zou moeten zijn in plaats van / dev / sdb1 omdat "disks" geen partitie voor / dev / sdb1 laat zien. - mchid


Het lijkt erop dat er waarschijnlijk geen / dev / sdb1 is en dat er waarschijnlijk maar één partitie / dev / sdb is. Dit is niet ongewoon.

Open een terminal en voer de volgende opdrachten uit:

sudo mount /dev/sdb /mnt

Als er geen fouten zijn, kunt u het apparaat bekijken in nautilus:

nautilus /mnt

Voor lees schrijf toestemming:

sudo chown -R $USER:$USER /mnt

0
2018-06-05 08:45



Voor alle duidelijkheid, linux sd staat voor scsi-device, letter erachter correleert de founding-orde. Nummer nadat dit partitienummer is, dus als je een partitie op je apparaat hebt, is het in linux / dev / sdb (n), niet / dev / sdb. sdb is een tweede gevonden blokapparaat, sdb1 is de eerste partitie op dat apparaat. - Pasi Suominen