Vraag Ubuntu kan niet in VirtualBox worden geïnstalleerd vanwege "deze kernel vereist een x86-64 CPU, maar detecteert alleen een i686 CPU, niet in staat om op te starten" -fout


Ik probeerde Ubuntu 12.04 te installeren in VirtualBox 4.2.12r84980. ik snap het

this kernel requires an x86-64 CPU, but only detects an i686 CPU, unable to boot

Maar ik gebruik een 64 bit Windows 8, en probeer dezelfde .iso voor het proberen van Ubuntu. Wat is dan het probleem?


107
2018-06-16 17:07


oorsprong


Probeer de 32-bits Ubuntu ISO te installeren - edwin
Het maakt niet uit dat je hostsysteem 64bit is. Het hele doel van een virtuele machine is dat het een afzonderlijke en autonome machine is, zij het een virtuele machine. Bewerk de configuratie van de virtuele machine en verander het CPU-type in 64bit. - hmayag
Verwant: Kernel vereist een x86-64 CPU, maar alleen een i686 CPU. Hoe kan ik Lubuntu / Ubuntu installeren? - Eliah Kagan


antwoorden:


Om een ​​64-bits besturingssysteem in Virtual Box te kunnen uitvoeren, moeten we ervoor zorgen dat de architectuur van de virtuele machine ook is ingesteld op 64-bits.

  • Kies Ubuntu 64-bit in Algemeen -> Basis instellingen voor het maken van uw VM

    enter image description here

  • Bovendien, voor hardlopen 64-bit gasten het wordt aanbevolen om de APIC invoer / uitvoer in te schakelen in de Systeem -> Moederbord instellingen voor uw virtuele machine:

  • In de Systeem -> Versnelling We willen mogelijk de hardwarevirtualisatiefuncties VT-x / AMD-V van je CPU inschakelen.

  • Op het hostsysteem moeten we mogelijk inschakelen hardwarevirtualisatie in het BIOS.

  • In sommige systemen moet een host-BIOS-optie om niet-vertrouwde uitvoering te voorkomen worden uitgeschakeld (bron).


136
2018-06-16 20:47



het werkte: dank u - aluph
het werkte als charme .. Heel erg bedankt. - Anil Chahal
Voor mij is zelfs 'Ubuntu (64-bit)' geen lijst in de vervolgkeuzelijst. Alle OS-lijst in dropdown tonen '(32-bit)'. - ARUN
@ARUN had je virtualisatie ingeschakeld in BIOS? - Takkat
@ARUN Ik had hetzelfde probleem. Tijdens het maken ervan was het geen optie, maar nadat het is gemaakt, kun je teruggaan naar Instellingen> Algemeen en het staat in die lijst. - Sinaesthetic


Open de instellingen van de virtuele machine. Ga naar de vervolgkeuzelijst Versie (Algemeen> Basis> Versie).

Als u "Ubuntu (64 bit)" niet ziet als een optie in de vervolgkeuzelijst, betekent dit dat virtualisatie niet is ingeschakeld op de host.

Start de host opnieuw op, ga naar BIOS en schakel virtualisatie in. Sluit het BIOS en zorg ervoor dat u wijzigingen opslaat.

Nu zou u alle 64 bit-opties in de vervolgkeuzelijst Versie moeten zien.

Virtual machine general settings


19
2018-01-26 20:55





Voor degenen onder u die net als ik zijn en geen optie op uw virtuele vak hebben om de. Te selecteren versie: Ubuntu (64 bit):

Doe dit: download de 32-bits Ubuntu iso. VOORAL als u bij het downloaden van Ubuntu op uw virtuele doos ervoor kiest om minder dan 2 GB geheugen toe te wijzen.


5
2018-01-14 16:15





vboxmanage createvm --name "ubuntu" --ostype Ubuntu_64 --register

of als je al hebt gemaakt,

vboxmanage modifyvm --ostype Ubuntu_64

Om alle ostype op te sommen: http://zeblog.co/?p=390


0
2018-05-29 17:57