Vraag Probleem bij het installeren van de essentiële build op 14.04.1 LTS [duplicate]


Deze vraag heeft hier al een antwoord:

Ik probeer VM Player op Ubuntu 14.04.1 LTS te installeren.

Ik heb threads gezien voor eerdere versies van Ubuntu die zeggen om te installeren build-essential en linux headers eerst. Het lijkt erop dat linux headers al de nieuwste versie is. Echter build-essential zal niet voor mij installeren.

sudo apt-get install build-essential

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package build-essential

Is er iets dat ik hier mis? Bij voorbaat dank voor uw hulp.


2
2017-09-07 00:13


oorsprong


Kun je dat? Bewerk uw vraag en plak in de inhoud van /etc/apt/sources.list? - saiarcot895


antwoorden:


build-essential is beschikbaar op Hoofdrepository voor 14.04. Dus eerst de repository inschakelen.

De hoofd component bevat applicaties die gratis software zijn, vrij kunnen worden herdistribueerd en volledig worden ondersteund door het Ubuntu-team. & De universum component is een momentopname van de vrije, open-source en Linux-wereld.

U kunt de hoofd- en universe-repository inschakelen door de volgende opdracht te volgen:

sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu $(lsb_release -sc) main universe"

Installeer vervolgens het pakket door het volgende commando in terminal te volgen:

sudo apt-get update
sudo apt-get install build-essential.

10
2017-09-07 07:07



Als alternatief via GUI van Software & Updates: i.stack.imgur.com/6fyae.png - Pandya


Probeer deze opdrachten een voor een uit te voeren in terminal:

sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get --fix-missing install
sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install build-essential
sudo apt-get clean
sudo apt-get autoremove

1
2017-09-07 00:24



Dat gaat geen ontbrekende afhankelijkheden oplossen. - Panther
@ bodhi.zazen Een "Kan pakket niet vinden ..." is geen missing dependencies probleem. Het kan voorkomen als onderdeel van de afhankelijkheidsresolutie, maar dat is niet wat hier gebeurt, door de foutmeldingen van de OP. - Eliah Kagan
@ bodhi.zazen The sudo apt-get update zeer goed, zou op zichzelf een probleem kunnen oplossen dat zich onder dergelijke omstandigheden voordoet. De vraag vermeldt met name niet dat hij is gerund. Als bijkomend voordeel hebben bezoekers die deze opmerkingen zien, nu ook de juiste uitleg. - Eliah Kagan
@ bodhi.zazen Het antwoord van Pandya wordt geaccepteerd en lijkt het probleem te hebben opgelost. Ik denk dat mijn commentaar daar de dingen goed genoeg verduidelijkt. Ik dacht in plaats daarvan aan bewerken, maar besloot dat dit misschien als een radicale verandering zou worden beschouwd. Als Pandya ervoor kiest om te bewerken, is er nog minder behoefte aan nog een antwoord. Hoe dan ook, ik denk dat we gelijk hebben gehad om dit te sluiten als een duplicaat van een meer algemene vraag. Als dit wordt heropend, kan ik overwegen een antwoord te plaatsen. (Ik had er eigenlijk niet veel tijd aan besteed ... behalve deze opmerking, die ik niet als posting heb aangemerkt. Maar ik waardeer uw zorgen en ik dacht dat ik ze moest beantwoorden.) - Eliah Kagan