Vraag Hoe WebGL inschakelen in Chrome op Ubuntu?


chrome://gpu/

enter image description here

En http://webglreport.com/

enter image description here

 google-chrome --version
 Google Chrome 27.0.1453.93 

http://www.chromeexperiments.com/webgl

enter image description here

Hoe WebGL inschakelen in Chrome op Ubuntu?


109
2018-05-24 05:27


oorsprong




antwoorden:


Voor WebGL om te werken in Google Chrome (en Chromium), Dit zijn de stappen om WebGL in Google Chrome in te schakelen.

Stap 1: Open Google Chrome

Stap 2: typ chrome://flags in de adresbalk

Stap 3: Druk op Ctrl + f en typ " Rendering list "," Overschrijven van softwareversie lijst " zou moeten verschijnen, klik nu op Activeren en start de browser opnieuw.

Stap 4: Mis Chrome volledig: typ killall chrome in een console.

Stap 5: Ga naar chrome://settings en inschakelen Use hardware acceleration when available. Standaard is het uitgeschakeld sinds versie 43.

Stap 6: start Chrome

enter image description here

Nu controleren chrome://gpu/

enter image description here

http://webglreport.com/

enter image description here

Bron


148
2018-05-24 05:27



Nu heb ik YouTube in HTML5-spelers met mooie prestaties! - Vitaly Zdanevich
Waarom is dit standaard niet ingeschakeld ??? - Konstantin Schubert
@ Constantin Dat is een goede vraag, ik zal er wat onderzoek naar doen. - Qasim
Hint: zeker in Ubuntu (waarschijnlijk ook windows) moet je zeker zijn dat je de achtergronddraden (chrome) ook doodt voordat de wijzigingen van kracht worden. - Lance Caraccioli
@Kostanos nee ik weet het niet abot dat ... dat is de makkelijkste manier ... - Qasim


Als u nog steeds geen resultaten krijgt, controleert u of de hardwareversnelling is ingeschakeld in Chromium-instellingen, Google heeft de neiging deze instelling standaard uit te schakelen sinds versie 43. In dit geval was dat het probleem voor mij nadat ik de GPU-stuurprogramma's had bijgewerkt, waardoor de GPU blacklist, en zo en zo.


10
2017-07-11 10:57



Hier ook. Ik dacht dat ik een vreselijke bug zag maar realiseerde me niet chrome: // settings -> Toon geavanceerde instellingen ... -> Gebruik hardwareversnelling wanneer deze op de een of andere manier uitgeschakeld werd. Ik heb het omgedraaid, de browser opnieuw gestart en alles werkt. - Stephen Niedzielski
Werkte voor mij, bedankt - shturm
Het uitschakelen van hardwareversnelling werkte voor mij. - Thomas Orlita


met chrome versie 49.0.2623.108 op Ubuntu 14.04 (64-bit).

Wat we moeten activeren is #ignore-gpu-blacklist

Het is de eerste regel binnen chrome://flags/

Ik hoop dat het kan helpen,


2
2018-04-22 08:23





Misschien is uw videostuurprogramma te oud of niet juist geïnstalleerd.

Ik had hetzelfde probleem ook, maar deze oplossing loste mijn probleem op zonder overrides!

  1. PPA toevoegen voor Ubuntu 14.04 / 13.10 / 13.04 / 12.10

    Ubuntu 14.04 / 13.10 / 13.04 / 12.10 gebruikers, Voer de volgende opdracht uit in de terminal en typ het wachtwoord voor de gebruiker wanneer daarom wordt gevraagd. Anderen gebruiken de Ubuntu-X PPA.

    sudo apt-add-repository ppa: xorg-edgers / ppa
  2. PPA toevoegen voor Ubuntu 12.04 / 11.10 / 11.04 / 10.04

    sudo apt-add-repository ppa: ubuntu-x-swat / x-updates

    Na het toevoegen van de PPA werkt u uw systeemrepository bij.

  3. Updaten

    sudo apt-get update

    Installeer nu het NVIDIA GeForce grafische stuurprogramma 304.108 in uw systeem, terwijl u andere pakketten installeert met apt-get.

  4. Installeren

    sudo apt-get install nvidia-current nvidia-settings

    Bovenstaande opdracht zal de driver installeren.


Bron: http://www.howopensource.com/2012/10/install-nvidia-geforce-driver-in-ubuntu-12-10-12-04-using-ppa/


1
2017-10-22 13:04



Ik gebruik deze oplossing een week op mijn desktop, maar mijn Chrome eet soms alle CPU's (de "GPU-proces" -taak). - Ik heb Ubuntu Trusty met "GeForce 8400 GS Rev. 2" - Ik kan geen oplossing voor deze bijwerking vinden, alleen heb ik een oplossing: schakel "Versnelde 2D-canvas uitschakelen" optie in chrome: // flags / ... Grrr - andras.tim


Ik had het probleem dat WebGL als niet beschikbaar werd gerapporteerd na het overschakelen van de eigen Nvidia naar de nieuwe chauffeurs, een wijziging die niet lijkt te zijn opgepikt in de chromium GPU-configuratie van mijn profiel. De fix is ​​actief chromium-browser --single-process  een keer om de GPU-configuratie te resetten.


0
2017-07-06 21:17