Vraag Hoe te repareren "sudo: niet in staat om te openen ... Alleen-lezen bestandssysteem"?


De titel is misschien niet zo beschrijvend als ik zou willen, maar kon geen betere bedenken.

Het bestandssysteem van mijn server is alleen-lezen gegaan. En ik begrijp niet waarom het dit doet en hoe het op te lossen.

Ik kan SSH naar de server sturen en als ik bijvoorbeeld apache2 probeer te starten, krijg ik het volgende:

username@srv1:~$ sudo service apache2 start
[sudo] password for username:
sudo: unable to open /var/lib/sudo/username/1: Read-only file system
 * Starting web server apache2                                                                                                                                                                                                               (30)Read-only file system: apache2: could not open error log file /var/log/apache2/error.log.
Unable to open logs
Action 'start' failed.
The Apache error log may have more information.

Wanneer ik probeer de server opnieuw op te starten, krijg ik:

username@srv1:~$ sudo shutdown -r now
[sudo] password for username:
sudo: unable to open /var/lib/sudo/username/1: Read-only file system

Zodra ik het handmatig opnieuw opstart, start het gewoon op zonder enige waarschuwing of bericht dat er iets mis is.

Ik hoop dat iemand me de juiste richting kan wijzen om dit probleem op te lossen.


112
2017-10-07 15:41


oorsprong


Ik raad @John aan om het antwoord op het laatst geposte antwoord van Bibhas te wijzigen, omdat het echt werkt waar de andere antwoorden eigenlijk helemaal niet helpen. - Joshua Robison
Voor MicroSD: askubuntu.com/questions/213889/... - Ciro Santilli 新疆改造中心 六四事件 法轮功
Iedereen, deze vraag is voor een server, niet voor een pc. Als dit probleem zich voordoet op uw dual-boot-pc, controleer dan alstublieft The **quick start** option can be found in **power options** in the control panel of Windows. Ik heb hetzelfde probleem met een Ubuntu op AWS - vanduc1102


antwoorden:


Het bestandssysteem zal meestal alleen-lezen worden terwijl het systeem wordt uitgevoerd als er een probleem is met de consistentie van het bestandssysteem. Dit wordt gespecificeerd in fstab als errors=remount-ro en zal optreden wanneer een FS-toegang mislukt of een noodherinnering alleen-lezen wordt aangevraagd via alt+SysRq+U. Je kan lopen:

sudo fsck -Af -M

om een ​​controle van alle bestandssystemen te forceren. Zoals een van de andere antwoorden aangeeft, kijkend naar dmesg is ook erg nuttig.

Bewerken: Vergeet het -M op de opdrachtregel.


51
2017-10-07 15:58



Ik denk dat je dat niet moet doen dwingen een bestandssysteemcontrole op andere r / w gemounte bestandssystemen. Dat kan uw gegevens mogelijk beschadigen. Voeg de toe -M optie om gemounte bestandssystemen over te slaan. (-M Do not check mounted filesystems and return an exit code of 0 for mounted filesystems. van FSCK (8)) - gertvdijk
Dit helpt niet, ik krijg gewoon dezelfde foutmelding wanneer ik probeer dat commando uit te voeren. sudo: unable to open /var/lib/sudo/kuplack/1: Read-only file system  fsck from util-linux 2.20.1 - Mark Kramer
Maar ... -M slaat gemounte bestandssystemen over, inclusief / dev / sda1 (of wat ooit gemount station omvat / var / lib / sudo / ...). @MarkKramer: ik raad ten zeerste aan om altijd het root-wachtwoord in te stellen bij het installeren van linux, met sudo su; passwd. Dan kun je gebruiken su -c fsck -Af -M. - naught101
Ja voor mij moest ik -M verwijderen omdat / dev / sda1 was gemount, en om je leven gemakkelijker te maken, voeg -Afy toe (de y betekent antwoord ja op alle prompts) ... Ik speel snel en los met VM's dus ik ' m is meestal in orde met dit type oplossing, maar als dit geen geback-upte hardware is, kan dit een andere aanpak inhouden en dmesg lezen. - FreeSoftwareServers
@DarshanChaudhary The -M flag zorgt ervoor dat fsck gemounte bestandssystemen overslaat. Zie de fsck (8) manpage. - hexafraction


Hier is de opdracht die mijn probleem heeft opgelost:

mount -o remount /

beter dan a reboot of sudo fsck -Af 


40
2018-01-30 16:23



Niet beter als het besturingssysteem uw schijf alleen-lezen heeft gemaakt om mogelijke corruptie te voorkomen. - Drew Noakes
Niet alleen dat - alleen root kan het bestandssysteem opnieuw koppelen en sudo werkt niet als het bestandssysteem alleen-lezen is. - Nathan Osman
Helpt niet, ik krijg gewoon dezelfde boodschap: sudo: unable to open /var/lib/sudo/kuplack/1: Read-only file system  mount: cannot remount block device /dev/sda2 read-write, is write-protected - Mark Kramer
o ja deze werkte. - R T
Aaaaw Ja! Bedankt ton fella! - shramee


Het antwoord door hexafraction werkte niet voor mij. Elke keer als ik probeerde te executeren sudo fsck -Af -M het is net getoond

$ sudo fsck -Af -M
fsck from util-linux 2.20.1

en niets anders. Geen fout of zo. Voor mij was het opstarten van een live-schijf en het uitvoeren van dit werkte -

sudo fsck.ext4 -f /dev/sda1

Op voorwaarde dat de partitie in kwestie /dev/sda1 was een ext4 bestandssysteem.


32
2018-02-17 15:44



Bedankt voor dit antwoord. Dit is het enige dat echt heeft gewerkt - Joshua Robison
-M betekent niet gemounte bestandssystemen te doen. Je bestandssysteem / dev / sda1 was gemount (ik vermoed dat /). Dus het werd overgeslagen. - dalore
sudo fsck.ext4 -f /dev/sda1 werken. Nog steeds een herstart nodig. - efkan
Het werkte voor mij op ubuntu 16.04.3 Bedankt - Rosário Pereira Fernandes


Probeer te rennen dmesg | grep "EXT4-fs error" om te zien of er problemen zijn gerelateerd aan het bestandssysteem / journaling systeem zelf. Ik zou je aanraden om je systeem opnieuw te starten. Ook, sudo fsck -Af antwoord van ObsessiveSSOℲ doet geen pijn.


10
2018-06-24 18:17





Als je je rootbestandssysteem wilt dwingen om opnieuw te beginnen als rw, kun je het volgende doen.

mount -o remount,rw /

9
2018-06-01 05:07





Merk op dat dit soms veroorzaakt kan worden doordat de computer de systeemtijd vergeet - schijfcontrole mislukt omdat de datums in het journaal zich IN DE TOEKOMST bevinden!

Het instellen van de BIOS-tijd (en het controleren van de BIOS-batterij) loste dit probleem voor mij op, zonder enig schijfherstel te hoeven doen.


6
2018-02-23 02:15



Welkom bij Ask Ubuntu! ik raad aan Bewerkdit antwoord om het uit te breiden met specifieke details over hoe dit te doen. (Zie ook Hoe schrijf ik een goed antwoord? voor algemeen advies over wat voor soort antwoorden het meest waardevol zijn op Ask Ubuntu.) - David Foerster
Ik ben er vrij zeker van dat dit op dit moment met me gebeurt, aangezien mijn computer me vertelde dat het deze ochtend zijn tijd vergat. - nomen


Doorgaans zet linux je bestandssystemen alleen in lezen wanneer er fouten optreden, vooral fouten met de schijf of het bestandssysteem zelf, fouten zoals een verkeerde journaalboeking bijvoorbeeld.

Je kunt beter je controleren dmesg voor disk-gerelateerde fouten.

Google is hier vol van discussie over en je kunt degenen kiezen die dichter bij je configuratie staan, maar een blik op dmesg is meestal genoeg.


1
2017-10-07 15:58



Waar moet men naar kijken / grep voor in dmesg output? - isomorphismes
Helaas als je ervoor kiest om je thuismap te versleutelen, dmesg zal zeker vol zitten met nutteloze fouten van ecryptfs. - Nathan Osman


(Vorige antwoord verwijderd)

Bewerken: het grootste probleem was aan de vensterzijde. Na het updaten van mijn Windows 10, werd de 'quick start' optie automatisch ingeschakeld. Door deze optie opnieuw uit te schakelen en de machine opnieuw te starten, ging het probleem weg. Windows 10 gaf me dagenlang zware hoofdpijn :(

De optie 'snelstart' is te vinden in 'energieopties' in het configuratiescherm. Schakel dat uit !!! :)


1
2017-12-23 08:18





Als je dual je computer opstart met Ubuntu en Windows samen en dit probleem zich voordoet, komt dit omdat Windows het bestandssysteem wijzigt, in dat geval zou dit de slag kunnen slaan. Probeer snel opstarten uit te schakelen

Configuratiescherm> Hardware en geluiden> Stroomopties> (aan de linkerkant) Kies wat het sluiten van het deksel doet> Instellingen wijzigen die momenteel niet beschikbaar zijn> Verwijder 'Schakel snel opstarten in'

Nu opstarten in Ubuntu lost het probleem op. Ik hoop dat dit helpt!

https://youtu.be/KJ-0KPZhAFo


1
2018-04-25 08:03





eerst bij de Herstelmenu (alleen lezen) kiezen dpgk Repareer beschadigde pakketten aan het eind zal het Herstelmenu zijn Herstelmenu (lezen / schrijven) kiezen root Opdracht venster gebruiker en je zult het als root-gebruiker kunnen gebruiken!


0
2017-08-15 09:36





In mijn geval was het te danken aan het stabiliseren van RAID 1 na de eerste installatie. Ik heb / boot en / on s / w RAID1. Het systeem een ​​nacht verlaten en opnieuw opgestart, alles werkt prima. Richard


0
2017-12-08 11:51