Vraag Bionic Default Repositories hebben geen releasebestand - sudo apt-get update werkt niet [gesloten]


Ik krijg te maken met een probleem met apt: sudo apt-get update zal niet succesvol worden voltooid op mijn Ubuntu 18.04 Desktop.

Eerst zou ik willen specificeren dat het onderwerp Xenial-repository heeft geen releasebestand loste mijn problemen niet op, ook niet Ubuntu-repository heeft geen releasebestand of een ander.

Mijn distro is een nieuwe geïnstalleerde Ubuntu 18.04.1 Bionic.

Het probleem is, op een sudo apt-get update Ik krijg de volgende foutmeldingen:

E: The repository 'http://security.ubuntu.com/ubuntu bionic-security Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Ik krijg deze berichten op elke REPOSITORY van mijn sources.list, de standaardinstellingen voor Ubuntu 18.04.

Hier is de inhoud van mijn /etc/apt/sources.list bestand (ik heb het van Ubuntu Official Documentation gehaald). Ik heb de opmerkingenregels verwijderd om de leesbaarheid te verbeteren.

 # deb cdrom:[Ubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426)]/ bionic main restricted
deb http://us.archive.ubuntu.com/ubuntu/ bionic main restricted
deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
deb http://us.archive.ubuntu.com/ubuntu/ bionic universe
deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates universe
deb http://us.archive.ubuntu.com/ubuntu/ bionic multiverse
deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
deb http://security.ubuntu.com/ubuntu bionic-security main restricted
deb http://security.ubuntu.com/ubuntu bionic-security universe
deb http://security.ubuntu.com/ubuntu bionic-security multiverse

Ik heb begrepen door berichten over die foutmelding te lezen, dat deze vaak afkomstig is van een slechte configuratie van opslagplaatsen in dat bestand (bijvoorbeeld het vragen om de bionische versie van een pakket dat nog niet is gepubliceerd op bionische repos).

Het punt is: dit zijn de standaard repositories. En als ik ga ga naar de dist map in de gegeven URL, kan ik de distro's zien die zijn opgegeven in de configuratie: bionische, bionische-updates en bionische beveiliging.

Dus, kort samengevat:

  • Ik heb alleen de officiële standaardrepository's voor Ubuntu Bionic 18.04 geconfigureerd
  • elk van hen krijgt dezelfde foutmelding (heeft geen Release-bestand)
  • elke hint die ik heb gevonden gaat over een specifieke repository, of over een volledige systeemupgrade, wat niet mijn geval is

Als iemand een idee, een hint of zelfs beter heeft, is er een oplossing voor te maken sudo apt-get update werk, ik zou heel dankbaar zijn!

Bedankt


3
2017-08-07 15:37


oorsprong


In uw sources.list er is altijd een ruimte na http://. Als je dat in je eigenlijke bestand hebt, verwijder het dan en probeer het opnieuw te updaten. - Florian Diesch
@Florian OP had onderaan een notitie dat de spaties met opzet waren toegevoegd. Ik heb net de opmaak gerepareerd. - wjandrea
Gebruikt u een proxy of VPN? Zit u op een thuisnetwerk of een universitair / bedrijfsnetwerk? Ben je in de VS? - wjandrea
Als een kanttekening, Ubuntu-repositories zijn geen PPA's - de laatste zijn een apart type van niet-officiële repository - Zanna
@wjandrea: ik sta achter een zakelijke proxy. Ik heb de proxyconfiguratie als volgt toegevoegd aan /etc/apt/apt.conf: Acquire::http::Proxy "http://myUser:myPassword@companyProxy:proxyPortNumber". Deze configuratie lijkt mij OK, omdat ik een pakket "sudo apt-get install" kan "sudo" (bijv. `Sudo apt-get install peco` heeft peco correct geïnstalleerd). Het sudo apt-get update commando dat de fout verhoogt. Ik ben gevestigd in Europa. Ik probeerde fr.archive.ubuntu mirror, evenals uk.archive.ubuntu mirror, met dezelfde resultaten. En ik sta niet achter een VPN. - Zolano


antwoorden: