Vraag Globaal menu / appmenu toevoegen in xubuntu 11.10 64-bit (zoals mac / unity)?


Ik heb hier veel naar gezocht, maar ik kan gewoon geen algemeen menu krijgen om aan Xubuntu 11.10 64-bit te werken. De beste oplossing die ik heb gevonden is http://www.omgubuntu.co.uk/2011/10/how-to-enable-ubuntus-global-menu-in-xubuntu-11-10/ maar het werkt niet: wanneer ik de applet aan het xfce-paneel toevoeg, lijkt het onmiddellijk te crashen. Wanneer ik xfce4-paneel in de console uitvoer, zien de laatste 3 regels er behoorlijk relevant uit:

/ usr / lib / xfce4-indicator-plugin / xfce4 / panel-plugins / xfce4-appmenu-plugin: fout tijdens het laden van gedeelde bibliotheken: libxfce4panel-1.0.so.3: verkeerde ELF-klasse: ELFCLASS64

xfce4-panel-Message: Plugin-indicator-appmenu-29 is na een crash automatisch opnieuw opgestart.

/ usr / lib / xfce4-indicator-plugin / xfce4 / panel-plugins / xfce4-appmenu-plugin: fout tijdens het laden van gedeelde bibliotheken: libxfce4panel-1.0.so.3: verkeerde ELF-klasse: ELFCLASS64

Dit kan erop wijzen dat de plug-in niet werkt op mijn 64bit-besturingssysteem, maar ik kon geen 64-bits alternatief vinden ...

Ik zou het erg op prijs stellen als iemand me hiermee een beetje verder kon helpen. ELKE manier om een ​​globaal menu te krijgen werkt! Ik raakte er aan gewend op mijn hackintosh, en nu kan ik niet zonder leven. :)

PS: Hoewel ik [xubuntu] in de titel heb vermeld, voer ik eigenlijk de standaard ubuntu uit, waarop ik xubuntu-desktop heb geïnstalleerd. Ik gebruik de Unity niet echt meer, omdat het te buggy is zonder hardwareversnelling.

Alvast bedankt voor de hulp, elke suggestie wordt op prijs gesteld.


3
2017-10-20 20:04


oorsprong




antwoorden:


Omdat ik geen 64bit-machine heb, heb ik alleen 32bit-pakketten gepubliceerd, probeer het te compileren vanuit de broncode:

http://opendesktop.org/content/show.php?content=146102

Op deze pagina, ik heb de broncode verstrekt om te downloaden, moet u mogelijk het volgende uitvoeren:

sudo apt-get build-dep xfce4-indicator-plugin -y 

om alle ontwikkelkoppen voor de compilatie te krijgen


1
2017-10-22 03:03



Heel erg bedankt, het bouwen van de bron heeft geholpen !! Ik heb het appmenu nu aan het werken, het lijkt echter onstabiel te zijn, het crashte nadat ik gedit begon: (xfce4-appmenu-plugin: 10617): libxfce4panel-CRITICAL **: IA__xfce_panel_plugin_add_action_widget: assertion `GTK_IS_WIDGET (widget) 'failed (xfce4 -appmenu-plugin: 10617): Indicator-Appmenu-CRITICAL **: Kan de naam com.canonical.AppMenu.Registrar niet claimen - Mr. Pixel
Na een nieuwe herstart lijkt het appmenu te werken als een charme (ik krijg nog steeds de bovengenoemde fout, maar hoe dan ook). Heel erg bedankt voor je antwoord! - Mr. Pixel
@ Mr.Pixel, heb je geprobeerd uit te loggen en weer in te loggen? Het lijkt erop dat een of andere dbus-interface nog niet is geëxporteerd. Ik heb gedit geïnstalleerd via apt-get en het werkt probleemloos. - daisy