Vraag Hoe deactiveer ik de sneltoetsen F1 en F10 in de gnome-terminal?


Hoe kan ik de F1 (hulp) en F10 (meldingen menu) belangrijkste bindingen?

De eerste heb ik nodig voor schermhulpprogramma en de tweede om af te sluiten mc in console.

Er zijn geen dergelijke sneltoetsen in de Toetsenbord sneltoetsen systeem instellingen.


115
2018-04-27 13:55


oorsprong




antwoorden:


11.04

De F1-snelkoppeling uitschakelen

  1. In een gnome-terminal open up Bewerken ➜ Toetsenbordsnelkoppelingen.

  2. Blader omlaag naar de Help / Contents snelkoppeling, klik daar waar "F1" staat en klik Backspace:

    enter image description here

De F10-snelkoppeling uitschakelen

  1. Installeer de compizconfig-settings-managerInstall compizconfig-settings-manager pakket.

  2. Doe open CompizConfig Settings Manager.

    • Raken Super om de Dash te openen, typ "Compiz" en druk op invoeren.
  3. Typ 'unity' in de Filter invoer en selecteer de Ubuntu Unity Plugin.

  4. Klik op de knop rechts van Sleutel om het eerste paneelmenu te openen en haal het vinkje weg Ingeschakeld checkbox.

    enter image description here

  5. Dat maakte de global onmogelijk F10 snelkoppeling, nu uitschakelen gnome-terminals F10 shortcut:

    • In een gnome-terminal open up Toetsenborden Snelkoppelingen (Bewerken ➜ Toetsenbordsneltoetsen) en
      haal het vinkje weg Schakel de sneltoets voor het menu in (standaard F10)

      enter image description here

  6. F10 is toegewezen aan menubar_accel door iets in Ubuntu. Gnome? Metacity? Ik weet niet precies wat precies het is dat het steelt, maar de sleutel haalt Eclipse niet.

    • Voer gconf-editor uit, blader naar / desktop / gnome / interface scroll vervolgens naar beneden naar menubar_accel en verwijder de F10-waarde. [Hier gestolen]

106
2018-06-23 18:52



Hoe bewerk je "Bewerk ➜ Toetsenbord snelkoppelingen" in een terminalvenster? Eerste lijn. - jcollum
Oké, het is "open het menu Bewerken, selecteer de sneltoetsen voor het toetsenbord". Ik vergat dat de terminals menubalken hebben. Dacht dat ik dat zou moeten typen :) - jcollum
Alles hierboven doen lost de F10-toets niet op in 12.04. Het is nog steeds gebonden ergens klik met de rechter muisknop. - Paweł Gościcki
Iedereen hoe F1 Help in Ubuntu 14.04 uit te schakelen? De Help-rij is verdwenen, zo lijkt het. Ik ben heel dichtbij om terug te gaan naar ctwm. - towi
@towi In dat dialoogvenster moet u eerst op de hulplijn klikken. De sleutelinstelling moet veranderen van F1 naar "New accelerator ...". Als u hier nogmaals op klikt, verandert dit in "Uitgeschakeld". - user100464


Schakel F10 uit in gnome-terminal in 12.04

Typ dit in de console:

mkdir -p ~/.config/gtk-3.0
cat<<EOF > ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10"
}

* {
     gtk-key-bindings: NoKeyboardNavigation
}

EOF

Sluit vervolgens alle terminalsessies. Nu zou het moeten werken zoals het hoort (in mc bijvoorbeeld).


44
2018-04-30 19:25



Na het uitproberen van tientallen oplossingen, werkte DEZE EEN voor Ubuntu 12.04 LTS. - NovumCoder
WAUW! Mijn emacs zei: "Bedankt" - Cong Hui
Voor het deactiveren van andere gnome-gerelateerde bindingen zou ik voorstellen deze oplossing ook - csguimaraes


begin gconf-editor en volg /apps/gnome-terminal/keybindings/help

enter image description here

Beschrijving:

"Sneltoets op het toetsenbord voor het starten van hulp." Uitgedrukt als een tekenreeks in dezelfde indeling die wordt gebruikt voor GTK + -brondbestanden. Als u de optie instelt op de speciale reeks "uitgeschakeld", is er geen sneltoets voor deze actie. "


23
2017-08-21 20:28



helaas, dat verandert niets. Ik krijg steeds het Help-scherm wanneer ik F1 raak. Ubuntu 14.04 Desktop, eenheid. - towi
Merk op dat je dit moet instellen invalide niet alleen vrijmaken. Ik heb dat bijna gelezen. - Luc
Kan ook worden gedaan zonder GUI met: gconftool-2 -s / apps / gnome-terminal / keybindings / help "disabled" --type string - Ddorda


Ik ben nieuw voor Linux en deze F10-sleutel maakt me gek. Alle bovenstaande trucs werkten niet, maar ik vond nu een oplossing (voor Ubuntu 11.10 met Gnome 3 klassieke desktop). Voer in een terminal de volgende opdracht in:

gsettings set org.gnome.desktop.interface menubar-accel ""

Met dconf-editor kan worden vastgesteld dat de F10 echt verdwenen is. Merk op dat dit soort trucs in hoge mate afhankelijk lijken te zijn van Gnome / Ubuntu-versie.


7
2017-11-29 19:34



Een poging waard, maar werkte niet voor mij in Ubuntu 11.10 - jcollum
+1 Dit is de enige die werkt op mijn 12.04-machine. - Radu Maris


Voor het afsluiten van mc (met F10-toets). Schakel "Sleutel uit om het eerste paneelmenu te openen" in unity compiz plugin (ccsm)


4
2018-04-29 10:33





@kholis is correct voor het uitschakelen van F10 in Unity, maar als je een newb bent zoals ik, heb je wat meer informatie nodig om dit te laten werken.

Installeer compizconfig-settings-manager als dit nog niet is gebeurd:

sudo apt-get install compizconfig-settings-manager

Start de nieuw geïnstalleerde instellingenmanager en filter voor "eenheid"

Bewerk "Sleutel om het eerste paneelmenu te openen" om het uit te schakelen of wijzig het naar een andere sleutel.

Ik heb nog geen manier gevonden om de F1 te veranderen.


4
2018-04-30 17:36





De instructie bij http://ubuntuforums.org/showthread.php?t=1317325 (hieronder geciteerd) werkt ook in Ubuntu 11.04. (Het lijkt F1 in zowel de desktop als in de terminal uit te schakelen, dat wil zeggen, F1 stuurt geen ansi-reeks naar de shell in de terminal, als dat is wat OP wilde.)

  1. Ga naar Systeem - Voorkeuren - Sneltoetsen
  2. Maak een nieuwe snelkoppeling. Noem het 'doe niets' en schrijf 'vals'   (zonder aanhalingstekens) in het veld "opdracht". Druk op ok.
  3. Blader naar de onderkant van de lijst en vind je nieuwe opdracht. Klik   op de "Uitgeschakeld", aan de rechterkant, en druk op F1.

3
2017-08-22 02:12



Dank je. Ik werk aan de klassieke kabouter en niets hielp totdat ik 'niets deed'. Nogmaals bedankt. - Konrad Nowicki


Je kunt het eenvoudig uitschakelen met ccsm (Klik om te installeren als u het niet hebt geïnstalleerd).

Ga dan naar Desktop -> Ubuntu Unity Plugin -> Sleutel om het eerste paneelmenu te openen  en schakel het uit, of verander het naar een andere sneltoets.

enter image description here

Notitie: het lijkt erop dat deze methode niet werkt in Unity2D.


3
2017-10-26 22:03



Ik heb de keybinding met CCSM uitgeschakeld, maar als ik op F10 druk, wordt dat menu nog steeds geopend. - Conrad.Dean
raar, ik heb het uitgeschakeld en het raken van F10 doet niets. - Binarylife
Gebruikt u Unity2D? Omdat het in Unity 2D lijkt dat dit niet werkt. Post geüpdatet. - Binarylife


Dit is een tip voor Thnkpad-gebruikers, vooral T60. Wissel de F1-toets opnieuw in om te ontsnappen. Dit elimineert de irritante pop-up van terminalhulp wanneer je op F1 drukt. Je doet dit vaak vanwege de grappige plaatsing van ESC op T60s.


2
2017-12-03 17:42





Als je dit alleen wilt wijzigen Gnome Terminal je kunt klikken op Bewerken> Sneltoetsen in de terminal.


1
2018-04-30 18:37





Ik raad aan om F1 te gebruiken als een snelkoppeling voor iets anders. Ik voer Tilda, een commandoruimte in aardbevingstijl en de standaard sneltoets is F1. Het overschrijft de Help, dus ik heb nooit hulp bij het opstarten wanneer ik F1 raak. Zelfs als je Tilda niet zo leuk vindt, is het nog een keer saaier om F1 te verbergen om het te verbergen dan om Help te sluiten nadat je het per ongeluk hebt gestart.


1
2017-12-03 19:23