Vraag 16.04 LTS wifi-verbindingsproblemen met Realtek-adapter


Ik ontdekte verschillende problemen met wifi-verbinding na installatie van 16.04 LTS.

Ten eerste maakt wifi niet opnieuw verbinding na de slaap of winterslaap. Soms verandert het netwerkpictogram in een "op en neer pijlen" (ik weet niet waar het voor is) na het ontwaken maar is het nog steeds verbonden. Soms gaat het netwerk gewoon verloren en wordt er geen netwerk in de lijst weergegeven, dus er is geen enkele manier om wifi te gebruiken.

Ik heb eerst geprobeerd om netwerkmanager opnieuw op te starten door te draaien sudo service network-manager restart. Het werkte, maar was geen permanente oplossing.

Toen voegde ik er nog een andere thread aan toe SUSPEND_MODULES="iwlwifi"naar

/etc/pm/config.d/config

Na dit te hebben gedaan, lijkt het probleem met opnieuw verbinden te zijn opgelost (kan automatisch opnieuw verbinden en het pictogram verandert niet meer.) Ik merk echter dat de wifi-verbinding willekeurig wordt verbroken (ongeveer elke 30 minuten), zelfs wanneer de computer wordt uitgevoerd en het netwerkpictogram blijft de verbonden status wanneer de verbinding is verbroken.

Een ander probleem na het toevoegen van de code is, dat wanneer ik mijn computer in de sluimerstand zet, het scherm een ​​seconde lang uit gaat, maar dan weer ongeveer 5 seconden lang blijft branden (waarbij het systeem de wifi-verbinding verbreekt). En dan gaat de computer slapen na dit ongewone "tweefasige" proces.

Plz vindt hieronder informatie over draadloze kaarten

*-network               
       description: Wireless interface
       product: RTL8723BE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 00
       serial: b0:c0:90:5c:1c:d5
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723be driverversion=4.4.0-21-generic firmware=N/A ip=192.168.0.8 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 ioport:d000(size=256) memory:df200000-df203fff

00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Sky Lake PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 06)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (2) I219-V (rev 31)
01:00.0 VGA compatible controller: NVIDIA Corporation GK208 [GeForce GT 730] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GK208 HDMI/DP Audio Controller (rev a1)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
03:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller (rev 01)

05/01/2016 Update: Ik weet niet wat er gebeurde, maar het probleem wordt erger nu. Wifi-verbinding verdwijnt ongeveer elke 5 minuten en ik moet de netwerkbeheerder opnieuw verbinden of opnieuw opstarten.


116
2018-04-25 05:13


oorsprong


De pijlen omhoog en omlaag zijn voor bekabelde verbindingen - ik zie ze als ik bijvoorbeeld tethering gebruik op een Android-apparaat. Er zijn bijvoorbeeld veel bugmeldingen met betrekking tot uw kaart deze waar het lijkt dat het installeren van nieuwe stuurprogramma's werkte voor sommige mensen. Misschien vind je iets ... - Zanna
Je had moeten gebruiken SUSPEND_MODULES="rtl8723be" in plaats van iwlwifi aangezien je kaart iwlwifi niet gebruikt. Probeer ook echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf en start opnieuw op - Jeremy31
Het kan zowel de fwlps-optie repareren schakelt energiebeheer uit en dat kan verbroken verbindingen en andere problemen veroorzaken - Jeremy31
Ik heb veel vragen over het wifi-probleem gezien en begrijp niets waarom er zoveel problemen zijn met betrekking tot het netwerk, met name wifi in 16.04 LTS. - d a i s y
@RyanNerd en zodra ze de Mac hebben, voer je natuurlijk Ubuntu uit! De enige goede reden om de Mac op de eerste plaats te krijgen :-) - zwets


antwoorden:


Eindelijk was ik in staat om de problemen op te lossen na het uitproberen van aantallen verschillende methoden.

  1. Krijg informatie over uw PCI draadloze kaart door te draaien sudo lshw -class network
  2. Krijg uw kaartmodelinformatie volgens de productlijn.
    Bijvoorbeeld, zoals je kunt zien in de vraagbeschrijving staat er
      product: RTL8723BE PCIe Wireless Network Adapter dus het model van mijn kaart is RTL8723BE

    Of product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller dus het model van mijn kaart is RTL8101/2/6E

  3. Geef de toestemming sudo chmod 755 /etc/pm/config.d/

  4. Openen of maken config en voeg toe SUSPEND_MODULES="rtl8723be"(vervang rtl8723be door uw eigen modelnummer)
      Ren dan
      echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf
      (merk op dat bij het vervangen rtl8723be met mijn kaart die is RTL8101/2/6E ik zou alleen moeten typen .../modprobe.d/RTL8101.conf; en /2/6E mag niet worden geschreven)

Eindelijk herstart je systeem.

Nu zou je systeem automatisch opnieuw moeten kunnen verbinden na het slapen en de wifi-verbinding is nooit een keer verloren gegaan nadat ik dit had gedaan.

"De pijltjes omhoog / omlaag is waarschijnlijk een bug in de netwerkbeheerder die ertoe leidt dat netwerkbeheerder denkt dat het wifi-apparaat eigenlijk ethernet is.", Aldus Jeremy31.zie informatie over bugs hier U zou het moeten kunnen repareren door NetworkManager-1.2.0 te installeren.

Met dank aan Jeremy31 voor het leveren van de oplossingen.


44
2018-05-06 03:09



Dit werkt als een oplossing voor het ontwaakprobleem. Het is de derde oplossing die werkt voor mijn laptop met een Intel 7260 wifi-kaart. Maar zelfs na het installeren van NetworkManager-1.2.0, krijg ik nog steeds de pijlen (de mijne zijn horizontaal, niet verticaal) en krijg ik nog steeds een volledig losgekoppelde wifi-kaart wanneer ik probeer te schakelen tussen netwerken. - Rsync
Ik heb ubuntu 16.04 enkele uren geleden geïnstalleerd en kreeg hetzelfde probleem (verkeerd pictogram + wifi willekeurig verloren). Lijkt opgelost met sudo apt-get update && sudo apt-get dist-upgrade. Na het opnieuw opstarten was alles in orde: verbindingen stabieler en geen verkeerd pictogram. - gwarah
Er is geen "product:" attribuut geretourneerd voor mijn wifi-dongle. Alleen "configuratie: ... stuurprogramma = r8712u ..." - James Bowery
Wees voorzichtig met deze oplossing. Het heeft mijn netwerkactiviteiten op LM18 volledig ondersteund. Ik moest onthouden welke opdrachten ik deed, zodat ik de configuratiebestanden kon verwijderen en opnieuw kon opstarten. Druk deze pagina af voor het geval u naar het proces moet verwijzen. Ik zeg niet dat het slecht is, het werkte duidelijk voor sommige mensen. Maar dacht dat hier een waarschuwing in orde is. - RyanNerd
@KillABug - Het bovenstaande probleem en / of oplossing kan Realtek-specifiek zijn; met het Centrino-apparaat heb ik geen problemen na de slaap, maar verlies ik de verbinding willekeurig, vooral tijdens het downloaden. Het negeren van IPv6 loste het niet op. - cipricus


Ik heb precies hetzelfde probleem. Na het wakker worden, werkt wifi nog steeds, maar netwerken worden niet weergegeven. Ik los het probleem op door de netwerkbeheerder opnieuw op te starten.

sudo service network-manager restart

Nog steeds erg irritant. Ik hoop dat ze dit probleem snel oplossen.


37
2018-04-28 04:25



Dit is slechts een tijdelijke oplossing. Denk je dat het een fout is met 16.04 LTS? - Lixu
dat werkt voor mij. het is waarschijnlijk een bug. - avi software
werkt ook om te gebruiken nmcli con up wifi-sid, als je een snelle bodge wilt. - Rick-777
Dit werkte niet voor mij. Ik gebruik Xubuntu 16.04 LTS en was verbonden met een gedeeld Windows-station toen mijn computer in slaap viel. hardlopen sudo service network-manager restart Ik heb mijn systeem alleen maar erger bevroren. Ik deed toen een log uit en weer - nog erger nog, en nu verdwenen mijn bureaubladpictogrammen. Toen deed ik een volledige herstart en nu zijn mijn bureaubladpictogrammen nog steeds verdwenen. Geen idee waarom, maar ik zal de slaap zeker uitschakelen. Dit is een slechte deal. Dit soort problemen waarbij eenvoudige dingen zouden moeten werken, doet me echt Windows missen, en dat gevoel bevalt me ​​niet. Ik hoop dat Ubuntu / Xubuntu beter wordt. - Gabriel Staples
Heb je al een oplossing gevonden? - Emad Arshad Alam


Dit is zeker een bug. Bug is ingediend bij https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1574347


30
2018-05-02 17:22



Die bug is afgesloten, ken je een andere die ik kan markeren als beïnvloed door? :) - Ads20000
Misschien was die kever gesloten, maar de mijne blijft af en toe vallen; en ik gebruik nooit opschorten. askubuntu.com/questions/938321/... - SDsolar


Aanvullende informatie: Ik heb hetzelfde exacte probleem als OP beschrijft, maar alleen het probleem waarbij het nm-appletpictogram verandert in pijlen en geen wifi-info weergeeft. De wifi werkt nog steeds wanneer dit gebeurt.

$ killall nm-applet && nm-applet & 

Is de truc om het pictogram weer te geven weer te geven, dus het is slechts een tijdelijke oplossing voor het geval iemand het in een script wil plaatsen.

Kan dit probleem bevestigen op twee afzonderlijke computers met een xubuntu-desktoppakket.

Ook heb ik op beide computers recente intel wifi-kaarten. (iets in de trant van AC-7260)


10
2018-04-26 02:40



heb je een oplossing gevonden? - Lixu
Bedankt, ik heb hetzelfde probleem, maar dit gebeurt alleen als ik de verbinding met de wifi-router verlies, soms gebeurt het dat mijn router wordt afgeluisterd en de verbinding wordt verbroken. - Aleksandar Đorđević
Ik heb exact hetzelfde probleem ontmoet als hier beschreven op de onlangs uitgebrachte manjaro-i3-20161201. En laat het met succes repareren met deze truc. Dank je! - navigaid
Een ander ding dat ik handig vond is om, als je wilt, /etc/xdg/autostart/nm-applet.desktop te verwijderen om te voorkomen dat het start bij het opstarten en als alternatief gebruik je het nmtui hulpprogramma om verbinding te maken met een wifi in terminal. Ik heb de methode geprobeerd en de verbinding wordt automatisch opnieuw verbonden wanneer mijn laptop uit de slaapstand herstelt, zelfs nadat nmtui is gestopt. - navigaid


Ik had hetzelfde probleem. Ik heb het suspend-wake-probleem opgelost door dit script te maken op /etc/systemd/system/wifi-resume.service (degene van wie de OP werkte, werkte alleen voor de actieve sessie; bij opnieuw opstarten moest het opnieuw worden gebeld):

#/etc/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Voer vervolgens dit commando in terminal uit om het te activeren: sudo systemctl enable wifi-resume.service. Deze oplossing is van nog een vraag-antwoorden werkt zowel na het onderbreken als na het opnieuw opstarten.

Echter, zelfs nadat dat was verholpen, kreeg ik hetzelfde gedrag dat gebeurde bij het wakker worden van de slaapstand wanneer ik probeer schakel wifi-netwerken: de wifi is in wezen dood, met de twee pijlen, en de applet zegt:apparaat niet klaar. "Ik kan de wifi opnieuw starten door deze uit te geven sudo service network-manager restart, maar ik kan niet van netwerk wisselen.

Is er iemand anders die dit ervaart en / of een oplossing heeft ???


6
2018-04-29 01:20



Aangezien je het probleem nog steeds hebt, wat doet het script dan eigenlijk? - Lixu
Het script BEVESTIG het eerste probleem van het OP: geen wifi na het ontwaken van de slaapstand. Het lost het tweede probleem echter NIET op (voor mij): kan geen wifi-netwerken schakelen zonder wifi-toegang te verliezen. Als ik niet duidelijk was, bestaat het tweede probleem onafhankelijk van het eerste. Het script creëert niet het tweede probleem, het corrigeert alleen de eerste. - Rsync
Ik denk niet dat dit script iets voor mijn situatie doet. Het bleek dat wifi-verbinding vaker verloren ging na het gebruik ervan. - Lixu
Probeer een van de andere scripts in de buurt (bijv. askubuntu.com/questions/761180/...). Beiden werkten voor de wake suspend-kwestie. Het onvermogen om van netwerkprobleem te veranderen heeft er echter voor gezorgd dat ik terugging naar 15.10. Ook op een nieuwe installatie van 16.04 kwam ik een derde probleem tegen: netwerkbeheerder maakte een nieuwe wifi-verbinding elke keer dat ik verbinding maakte met een netwerk (bijvoorbeeld WIFI_1; WIFI_2; WIFI_3). Als gevolg daarvan moest ik het wachtwoord elke keer invoeren. - Rsync
Ik gebruik geen CV, maar dit ziet er veelbelovend uit. Bedankt dat je dit hebt geplaatst. Hier is mijn vraag en een goed antwoord op de kwestie: askubuntu.com/questions/938321/... - SDsolar


Ik gebruik LinxuMint 18 Mate (ubuntu16.04) en heb hetzelfde probleem opgelost.

Al de rest hierboven werkte niet voor mij op mijn Thinkpad T440S.

De enige oplossing die tot nu toe lijkt te werken is het upgraden van de kernel naar 4.6.3

  • Ga naar deze website.

  • Verkrijg de volgende bestanden:

    linux-headers-4.6.3-040603-generic_4.6.3-040603.201606241434_amd64.deb
    linux-headers-4.6.3-040603_4.6.3-040603.201606241434_all.deb
    linux-image-4.6.3-040603-generic_4.6.3-040603.201606241434_amd64.deb
    
  • Ga vanuit een terminal naar de map met de bovenstaande bestanden en voer het volgende uit:

    sudo dpkg -i *.deb
    sudo reboot
    

Als u Virtualbox gebruikt, voer dit dan uit sudo /sbin/vboxconfig

In het geval u ze wilt verwijderen, voert u het volgende uit:

sudo dpkg --purge linux-headers-4.6.3-040603 linux-headers-4.6.3-040603-generic 

Na wat meer tests is de situatie bijna hetzelfde, ik heb wifi, maar mijn nm-applet kan niet alle WIFI om me heen zien. Dus niet zeker of dit een goede oplossing is :-)


2
2017-08-09 09:28



Ook LM18 gebruiken. Alle andere oplossingen hebben mijn netwerkverbindingen gedood. Deze oplossing lijkt te werken. Ik gebruik Cinnamon en de kernel-upgrade heeft mijn Nvidia-stuurprogramma getroffen - niet de fout van de kernel. Ik weet zeker dat de ontwikkelaars bij Nvidia op acid b / c zitten, ze kunnen hun eigen specificaties niet volgen elke keer als ik een belangrijke kernel-upgrade doe, breng ik een uur of langer door met het bestrijden van de stoerheid van de nvidia-driver. - RyanNerd
Ik heb dit geüpdatet en het up-up gegeven omdat het upgraden naar de nieuwste kernel werkt voor LM18 waar ik zag dat andere plaatsen geen leuke dingen met mijn systeem deden. Helaas heeft het upgraden naar kernel 4.6.3 niet opgelost dat mijn wifi op willekeurige momenten stom zou gaan. Gebeurt alleen thuis. Ik heb exact dezelfde router thuis die ik op mijn werk heb. Ik weet niet zeker wat hier aan de hand is. Mijn laptop heeft een Intel Wireless 7260 die blijkbaar een slecht gedraineerde draadloze adapterversie is die verschillende problemen heeft in Linux en Windows. Dus ik denk dat ik vast zit totdat de driver is bijgewerkt voor dit stukje s__t-hardware. - RyanNerd


Er is nu helemaal geen oplossing, maar ik vond een script dat me hielp om tevreden te blijven:

#!/bin/bash

# Ping you most used DNS Server and reconnect on fail


while true; do
  if ! ping -c 1 -w 1 8.8.8.8 > /dev/null; then

    # with "sudo iwconfig" you can examine your name of 'wlan0'
    nmcli d connect wlan0

  fi
  sleep 2;
done

om Autostart dit script gewoon te openen gnome-session-properties en voeg het toe aan de lijst.

Het volledige script (zonder opnieuw verbinden) is te vinden op deze webpagina.


2
2017-10-17 19:28





Stel de WIFI-landcode in voor het huidige regelgevingsdomein van Kernels als dit niet is ingesteld

iw reg get

Om het in te stellen

sudo nano /etc/default/crda
REGDOMAIN=<ISOCODE>

Reboot.


1
2018-05-11 09:34



Hoe of waarom zou dit helpen? - A-B-B
Deze oplossing heeft me enigszins geholpen. Voordat het soms enkele minuten duurde om een ​​WiFI-verbinding tot stand te brengen (ik moest de netwerkbeheerder een paar keer opnieuw opstarten) moest ik de REGDOMAIN nu expliciet instellen. Maar nadat ik de computer uit de slaapstand heb gehaald, kan het nog steeds niet lukken om verbinding te maken en moet ik de netwerkbeheerder handmatig opnieuw opstarten. Vervelend. - kovinet