Vraag Kan R niet installeren op ubuntu 17.10


Ik heb onlangs een upgrade naar kunstig gedaan en kan deze niet installeren r-recommended langer. Ik ontvang steeds deze foutmelding:

user@box:~$ sudo apt install r-recommended 
[sudo] password for user:       
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 r-recommended : Depends: r-cran-boot (>= 1.2.19) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
user@box:~$ 

Niettemin, https://cran.r-project.org/bin/linux/ubuntu/artful/ is al beschikbaar

Bewerken: zoals gevraagd door @muru in de reacties, de uitvoer van sudo apt-get update plus de uitvoer van sudo apt-get upgrade waren

user@box:~$ sudo apt update
Hit:1 http://download.virtualbox.org/virtualbox/debian zesty InRelease
Ign:2 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                                                
Ign:3 https://cran-r.c3sl.ufpr.br/bin/linux/ubuntu artful/ InRelease                                                                                                        
Hit:4 http://dl.google.com/linux/chrome/deb stable Release                                                                                                                  
Hit:5 https://cran-r.c3sl.ufpr.br/bin/linux/ubuntu artful/ Release                                                                                                          
Hit:8 http://archive.ubuntu.com/ubuntu artful InRelease                                                                                                                     
Hit:9 http://archive.canonical.com/ubuntu artful InRelease              
Hit:10 http://archive.ubuntu.com/ubuntu artful-updates InRelease        
Hit:11 http://archive.ubuntu.com/ubuntu artful-backports InRelease
Hit:12 http://archive.ubuntu.com/ubuntu artful-security InRelease
Reading package lists... Done 
Building dependency tree       
Reading state information... Done
All packages are up to date.
user@box:~$ sudo apt upgrade 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
user@box:~$ 

3
2017-11-01 04:47


oorsprong




antwoorden:


Er lijkt een gebroken afhankelijkheid te zijn r-cran-boot. Concreet hangt het ervan af r-api-3, die niet meer bestaat, is gewijzigd in r-api-3.4.

sudo aptitude full-upgrade
The following packages will be upgraded:
  r-cran-boot{b} 
1 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 618 kB of archives. After unpacking 0 B will be used.
The following packages have unmet dependencies:
 r-cran-boot : Depends: r-api-3 which is a virtual package and is not provided by any available package

The following actions will resolve these dependencies:

 Keep the following packages at their current version:
1)     r-cran-boot [1.3-20-1build1 (artful, now)]         



Accept this solution? [Y/n/q/?] 

Ik zal op dit moment proberen een bugrapport in te dienen.

Update: de pakketonderhouder lijkt het probleem te hebben verholpen. Ik kan upgraden zonder een afhankelijkheidsfout te krijgen.


1
2017-11-01 18:22



Bedankt, @ user754850! Het spijt me het je te vragen, maar (sh | c) zou ik in de tussentijd iets verder doen sudo apt update && sudo apt install r-recommended elke dag totdat het zichzelf installeert? - Marcelo Ventura
Ik weet het niet zeker. Ik had het geluk om te krijgen r-cran-boot (en al het andere) installeren, maar ik weet niet meer hoe ik het heb gedaan! Ik denk dat ik dat heb gebruikt aptitude install r-base en vervolgens een oplossing gekozen die alles heeft geïnstalleerd, maar de r-api-3 afhankelijkheid ontevreden. - Paul Stodghill
Probeer alstublieft een bugrapport in te dienen. Ik probeerde het, maar kon het niet verwerken bugs.launchpad.net/ubuntu/+filebug - Marcelo Ventura
Het enige wat ik moest doen, was afnemen aptitudeeerste voorstel, zoals ik in mijn antwoord hieronder heb beschreven. Hartelijk dank voor uw antwoord! = D - Marcelo Ventura


Inderdaad, zoals aangegeven door Paul Stodghill in zijn antwoord, installeren met aptitude zal het lukken zolang je weet dat het eerst zal voorstellen om niets te installeren - een zinloos voorstel dat je moet weigeren - want op dat moment zal het voorstellen om te installeren r-cran-boot hoe dan ook met de onbeantwoorde afhankelijkheid van r-api-3.4, zoals te zien in deze uitvoer:

user@box:~$ sudo aptitude install r-recommended 
The following NEW packages will be installed:
  cdbs{a} dh-translations{a} intltool{a} libblas-dev{a} liblapack-dev{a} libncurses5-dev{a} libreadline-dev{a} libtinfo-dev{a} python-pkg-resources{a} python-scour{a} 
  python-six{a} r-base-core{a} r-base-dev{a} r-cran-boot{ab} r-cran-class{a} r-cran-cluster{a} r-cran-codetools{a} r-cran-foreign{a} r-cran-kernsmooth{a} 
  r-cran-lattice{a} r-cran-mass{a} r-cran-matrix{a} r-cran-mgcv{a} r-cran-nlme{a} r-cran-nnet{a} r-cran-rpart{a} r-cran-spatial{a} r-cran-survival{a} r-doc-html{a} 
  r-recommended 
0 packages upgraded, 30 newly installed, 0 to remove and 0 not upgraded.
Need to get 43.5 MB of archives. After unpacking 78.9 MB will be used.
The following packages have unmet dependencies:
 r-cran-boot : Depends: r-api-3 which is a virtual package, provided by:
                        - r-base-core (3.4.2-2zesty), but 3.4.2-2artful4 is to be installed

The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     r-cran-boot [Not Installed]                        
2)     r-recommended [Not Installed]                      

     Leave the following dependencies unresolved:         
3)     r-base-core recommends r-recommended               

Accept this solution? [Y/n/q/?] n

The following actions will resolve these dependencies:

     Install the following packages:        
1)     r-cran-boot [1.3-20-1build1 (artful)]

Accept this solution? [Y/n/q/?] y
The following NEW packages will be installed:
  cdbs{a} dh-translations{a} intltool{a} libblas-dev{a} liblapack-dev{a} libncurses5-dev{a} libreadline-dev{a} libtinfo-dev{a} python-pkg-resources{a} python-scour{a} 
  python-six{a} r-base-core{a} r-base-dev{a} r-cran-boot{a} r-cran-class{a} r-cran-cluster{a} r-cran-codetools{a} r-cran-foreign{a} r-cran-kernsmooth{a} 
  r-cran-lattice{a} r-cran-mass{a} r-cran-matrix{a} r-cran-mgcv{a} r-cran-nlme{a} r-cran-nnet{a} r-cran-rpart{a} r-cran-spatial{a} r-cran-survival{a} r-doc-html{a} 
  r-recommended 
0 packages upgraded, 30 newly installed, 0 to remove and 0 not upgraded.
Need to get 43.5 MB of archives. After unpacking 78.9 MB will be used.
Do you want to continue? [Y/n/?] y
Get: 1 https://cloud.r-project.org/bin/linux/ubuntu artful/ r-base-core 3.4.2-2artful4 [23.2 MB]
Get: 2 https://cloud.r-project.org/bin/linux/ubuntu artful/ r-base-dev 3.4.2-2artful4 [4414 B]                                                                               
(...)
Setting up r-cran-rpart (4.1-11-1build1) ...
Setting up r-recommended (3.4.2-2artful4) ...

Current status: 1 (+1) upgradable.
user@box:~$ 

0
2017-11-02 15:23





Voor gebruikers die deze fout tegenkomen in een andere instelling.

Ik had dit op 18.04 na het upgraden van 16.04.

Ik had nog een spiegel op de 16.04 voor cran. Na de upgrade had ik problemen met het upgraden van r-aanbevolen met deze zelfde soort uitvoer.

Nadat ik de bronlijst had verwijderd, in mijn geval cran.mirror.ac.za, de upgrade werkte nog steeds niet met de uitvoer:

The following packages have unmet dependencies:

 r-cran-boot : Depends: r-api-3.4
 r-cran-class : Depends: r-api-3.4
 r-cran-cluster : Depends: r-api-3.4
 r-cran-codetools : Depends: r-api-3.4
 r-cran-foreign : Depends: r-api-3.4
 r-cran-kernsmooth : Depends: r-api-3.4
 r-cran-lattice : Depends: r-api-3.4
 r-cran-mass : Depends: r-api-3.4
 r-cran-matrix : Depends: r-api-3.4
 r-cran-mgcv : Depends: r-api-3.4
 r-cran-nlme : Depends: r-api-3.4
 r-cran-nnet : Depends: r-api-3.4
 r-cran-rpart : Depends: r-api-3.4
 r-cran-spatial : Depends: r-api-3.4
 r-cran-survival : Depends: r-api-3.4

ik moest apt-get remove r-base-core, apt-get clean en dan zou ik het kunnen installeren r-recommended zonder een probleem.

Ik denk dat het probleem was dat het afhankelijk was van het pakket, r-base-core is geïnstalleerd vanaf de andere repository en niet automatisch geüpgraded met de Ubuntu-versie.

Dit kan in feite de situatie van het OP zijn geweest, of kan in elk geval hetzelfde zijn, dus ik dacht dat dit een nuttig antwoord zou kunnen zijn.


0
2017-09-03 10:56