Vraag Fout in mijn bronnenlijst


Ik weet dat er nog andere vragen zijn, maar tot dusverre heeft geen enkele van deze oplossingen voor mij gewerkt. 

Hoi, ben nieuw voor ubuntu en heb het gisteren pas gekregen. En gisteravond laat verscheen er een foutmelding in de rechterbovenhoek van mijn scherm.

De fout die verschijnt is "Er is een fout opgetreden. Voer Package Manager uit via het snelmenu of voer apt-get uit in een terminal om te zien wat er mis is."

De foutmelding was: 'Unknown Error:' '(E: Malformed Line 57 in de bronnenlijst / etc / apt / sources.list (dist parse))'.

"Dit betekent meestal dat uw geïnstalleerde pakketten onvervulde afhankelijkheden hebben"

Dus ik volgde een aantal andere soortgelijke vragen en probeerde die maar niets loste het probleem op.

Dit zijn de coderegels:

> 56 deb-src http://extras.ubuntu.com/ubuntu vertrouwde hoofdfunctie
> 57 deb http://archive.canonical.com/ partner
> 58 # deb-src http://archive.canonical.com/ partner

Ik lees online dat canoniek is als de ontwikkelaars van ubuntu of zoiets, dus ik denk dat dit serieus kan zijn, misschien ??? Alle hulp wordt op prijs gesteld.


3
2018-04-13 00:30


oorsprong




antwoorden:


Vervang de regels 57 en 58 (58 is becommentarieerd, dus wordt niet verwerkt, maar is toch fout)

deb http://archive.canonical.com/ partner  
# deb-src http://archive.canonical.com/ partner 

met het volgende:

deb http://archive.canonical.com/ trusty partner  
# deb-src http://archive.canonical.com/ trusty partner 

De reden voor uw fout is dat die twee regels op de een of andere manier in de war raakten en in syntaxis verkeerd waren: de naam van uw Ubuntu-versie (betrouwbaar = 14.04) ontbrak.


4
2018-04-13 00:39