Vraag Wifi werkt niet na de slaapstand na de 16.04-upgrade


Deze specifieke versie van de "werkt niet na opschorting" kwam na het upgraden naar 16.04. Het lijkt erop dat de upgrade een Wicd-applet bevat (toegevoegd aan de taakbalk van Metacity Classic Gnome naast het reguliere netwerkpictogram), maar lijkt niet te werken na een onderbreking. EEN sudo service network-manager restart dupliceert dit probleem. Het vereist een volledige herstart om wifi weer op gang te krijgen. Om het even welke ideeën waarom?


133
2018-04-23 11:42


oorsprong


Heb je een bug op het startvlak geplaatst voor het probleem ??? - apos
bugs.launchpad.net/ubuntu/+source/wpasupplicant/+bug/1556357 - Alberto Salvia Novella
Het lijkt erop dat dit probleem al bestaat sinds Ubuntu 14. - Dan Dascalescu
Dit is nooit gebeurd onder 14.04 LTS voor mij. De upgrade naar 16.04 LTS is zo geweldig dat ik hem kan behouden, maar hij vergeet steeds mijn WiFi-wachtwoord. - SDsolar
Dit is nooit gebeurd onder 14.04 LTS voor mij. De upgrade naar 16.04 LTS is zo geweldig dat ik hem kan behouden, maar hij vergeet steeds mijn WiFi-wachtwoord. De service loopt duidelijk; alleen dat het het wachtwoord vergeet en geen verbinding maakt. Ik heb dit geplaatst: askubuntu.com/questions/934958/... - en ik wil niet omgaan met blacklisting of iets vreemds. - SDsolar


antwoorden:


16.04 draait op systemd. Probeer het volgende:

sudo systemctl restart network-manager.service

Als dit werkt, kunt u een script maken om het te automatiseren.

Open een terminal en typ het volgende:

sudo nano /etc/systemd/system/wifi-resume.service Plak het script daar in met een rechterklik. Sluit af met CTRL + X en druk op Y om te bewaren. Nu om het te activeren: sudo systemctl enable wifi-resume.service

Script:

#/etc/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Ik hoop dat dit helpt. Het werkt op mijn laptop.


161
2018-04-23 13:17



Ik zou zeggen dat je dit niet opnieuw hoeft te installeren. Ik heb een schone installatie uitgevoerd en ik kom dit probleem tegen op 16.04. Nooit een probleem gehad met 14.04. - Michael Martin-Smucker
Soms werkt het en soms niet :( - tokam
@mikeymop Ik heb dit ook gedacht. Ik weet dat sommige delen van het systeem nog steeds upstart gebruiken, dus dat kan iets veroorzaken. Omdat 16.10 volledig is gesystematiseerd en de fout niet heeft, ben je misschien wel correct. - Joakim Koed
Hoe kan ik dit verwijderen, dit zal niet werken op mijn systeem - buzhidao
Script werkt niet voor mij. "Wifi uitgeschakeld" wordt weergegeven in mijn netwerken, ik heb realtek RTL8723be stuurprogramma - Arshad


@ 147pm Heb je dit ooit laten werken?

Ik merkte dat ik een vrij gelijkaardig probleem had, hoewel ik op Kubuntu 16.10 (op KDE gebaseerd, niet op Gnome) en op een HP ProBook-laptop sta. En, in tegenstelling tot jijzelf, was het niet mijn Wifi die stierf na opschorten / wakker worden, maar mijn ethernetpoort. Toch vraag ik me af of ze verwant zijn.

Ik zie ook dat je het probleem niet onder KDE hebt. Maar ik zou graag willen weten of de onderstaande oplossing helpt onder Gnome, omdat de oplossing niet is gebaseerd op Window Manager, bureaubladomgeving of applets.

Allereerst alleen om te bevestigen dat het opnieuw opstarten van de netwerkbeheerderservice ..

$ sudo systemctl restart network-manager.service

werkte niet voor mij.

Ik vond echter een antwoord dat werkte, dankzij de vraag en info van buzhidao op kan geen verbinding maken met internet na onderbreking en GAD3R's commentaar daar.

Met behulp van hun info, ontdekte ik dat eerst onderzoek deed naar welke ethernet-hardware en driver / module ik aan het uitvoeren was, en vervolgens die module verwijderde en opnieuw installeerde, voor mij werkte (hoewel het niet voor buzhidao gold):

Wifi:

$ lspci -knn | grep Net -A2

Ethernet:

$ lspci -knn | grep Ether -A2

De tweede (ethernet) was wat ik gebruikte, en ik vond:

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
        Subsystem: Hewlett-Packard Company RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [103c:1944]
        Kernel driver in use: r8169
        Kernel modules: r8169

dus heb ik de driver 'r8169' opnieuw geïnstalleerd:

$ sudo rmmod r8169 && sudo modprobe r8169

en voila! Dit werkte. Mijn ethernetpoort / verbinding is levend teruggekomen (na opschorten / ontwaken) zonder opnieuw op te starten.

(Ik had ook GEEN Realtek wifi-apparaat, maar een Qualcomm Atheros (mod: ath9k), wat misschien verklaart waarom wifi voor mij bleef werken nadat ik uit de slaapstand gehaald was.)

Zoals je kunt zien aan mijn commentaar op die andere post, vroeg ik me af of het probleem het gemeenschappelijke element is tussen Buzhidao en mijzelf: Realtek Semiconductor-apparaten. Hoewel ze verschillende modules gebruiken, kunnen ze enkele gemeenschappelijke code delen? Of zelfs op een of andere manier door de nieuwere kernelcode anders worden behandeld?

Heb jij zelf een op Realtek gebaseerd wifi-apparaat? (met behulp van lspci hierboven)? Heb je nog een beetje geluk met het opnieuw installeren van de module (rmmod / modprobe hierboven)?

Hoe dan ook, gewoon een schot in het donker. Als u zelf een antwoord hebt gevonden, laat het ons dan weten! Dankje.


8
2018-03-16 22:40



Ik heb ook een RTL8111 / 8168/8411-ethernet en sudo rmmod r8169 && sudo modprobe r8169 probleem opgelost. - lenooh
Hetzelfde probleem met Debian 9 met KDE. Opnieuw installeren zoals hierboven is opgelost. Heel erg bedankt. - sumitkm
Mijn computer * heeft ook een RTL8111 / 8168/8411-ethernetapparaat en sudo rmmod r8169 && sudo modprobe r81691 eindelijk het probleem voor mij opgelost. Had dit probleem niet vóór kernelversie 4.16. (* Debian 10 met GNOME, Kernel 4.16 en eigen firmware van Realtek) - ossbuntu


Om NetworkManager automatisch opnieuw op te starten na het hervatten in een omgeving zonder sudo toegang, maak een script aan in /etc/pm/sleep.d (elke naam), stel het uitvoerbare bit in via chmod +xen voeg de volgende inhoud toe:

case "${1}" in
    resume|thaw)
        # systemctl restart network-manager.service
        service NetworkManager restart
;;
esac

Voor mij, de service regel werkte, maar systemctl kan beter voor u werken.

Bron: https://askubuntu.com/a/92235/30266.


6
2017-11-05 07:50



De service NetworkManager restart werkte voor mij, maar de plaatsing van het script niet (op 16.04). Ik moest het script verplaatsen naar /lib/systemd/system-sleep/script-name-here. In dit geval is het eerste argument voor het script [pre | post], dus ik moest de case-statement wijzigen in case "${1}" in ... post) .... Ik heb ook de innerlijke verklaring ingepakt case "${2}" in ... suspend) .... - Chester
Zou moeten zijn /lib/systemd/system-sleep/ voor 15.04+ - qwr


Voor mij lijkt het willekeurig, maar soms wordt de wifi verbroken als ik verbonden ben, of geen netwerken laat zien als ik dat niet ben. Soms lijkt het erop dat mijn laptop in de slaapstand wordt gezet, maar niet altijd.

Een combinatie van deze krijgt het meestal weer zonder opnieuw op te starten:

  • sudo iwlist $(ifconfig | grep -Po '^w\w+') scan
  • sudo service network-manager stop; sleep 5; sudo service network-manager start
    • Gewoon bellen restart hier lijkt nooit voor mij te werken. Het lijkt erop dat het probeert om het op te starten voordat het klaar is met afsluiten, dus ik heb meer geluk tussen pauzeren stop en start.
  • Schakel wifi uit in UI; wacht een paar seconden; schakel het weer in

Geen van die lijkt consistent te werken, maar ik heb ze eerst op volgorde van meest waarschijnlijke-kans van slagen gezet.


2
2017-12-20 16:07





Werkmethode op Ubuntu 16.04:

Maak de service: sudo nano /lib/systemd/system/wifi-resume.service

De service roept het programma op van:
/etc/init.d/network-manager

Plak de code:

#/lib/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart network-manager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target 

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Schakel vervolgens de service in:

sudo systemctl enable /lib/systemd/system/wifi-resume.service

Dit maakt de symlinks naar de aangegeven [Install] mappen van / etc / systemd / system en activeert de service

Daarna kunt u de status controleren met: systemctl status wifi-resume.service


2
2018-01-23 00:59





Ik had hetzelfde probleem met Bluetooth: na het onderbreken werkte mijn Bluetooth-muis niet. Dus ik heb de oplossing van boven afgeleid:

sudo nano /etc/systemd/system/bluetooth-resume.service

heeft de nieuwe service ingeschakeld

sudo systemctl enable bluetooth-resume.service

en bewerkte de service

#/etc/systemd/system/bluetooth-resume.service
#sudo systemctl enable bluetooth-resume.service
[Unit]
Description=Restart bluethooth at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart bluetooth.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Ik heb ook geprobeerd om te bewerken ...

sudo nano /etc/bluetooth/main.conf

en veranderd

AutoEnable=true

MAAR dit werkte NIET voor het "hervattingsprobleem" en had hoe dan ook geen effect op nieuwe Bluetooth-apparaten!


1
2017-08-31 11:11





Ik had hetzelfde probleem op mijn laptop Dell Inspiron 15R met Ubuntu 16.04. Voor mij werkte het script rapporteerde over het tweede antwoord.

Na het script te hebben geïnstalleerd, probeerde ik de suspensie met het commando in het menu rechtsboven en zelfs de lip te sluiten, waardoor het probleem werd opgelost.

Ik moet zeggen dat het probleem afwisselend was in zijn gedrag (dat wil zeggen, soms werkte het voordat het script werd geïnstalleerd).


1
2018-01-18 14:58





Voor mij was de oplossing om te rennen

nmcli nm sleep false

in een terminal


0
2018-04-08 11:01





Ik had hetzelfde probleem met het verbinden van mijn thuis wifi na een onderbreking. Ik heb de verschillende andere voorgestelde antwoorden geprobeerd die soms wel maar niet altijd zouden werken.

Uiteindelijk is de volgende fix toegestaan ​​voor het consistent verbinden met de wifi:

1) Bewerk dit bestand:

sudo vim /etc/NetworkManager/NetworkManager.conf

2) Door dit toe te voegen:

[device]
wifi.scan-rand-mac-address=no

0
2018-03-28 06:09