Vraag Problemen met USB-muis op 12.04 LTS


Mijn muis stopt met werken na een paar seconden of hoogstens een paar minuten. Het werkt prima op mijn Raspberry Pi en op mijn Mac, maar mijn Ubuntu 12.04 LTS-systeem klaagt:

[  654.508063] usb 2-5: new low-speed USB device number 4 using ohci_hcd
[  654.712876] usb 2-5: device descriptor read/all, error -71

Wanneer ik de stekker van de muis loskoppel en opnieuw steek, zal deze nog een aantal seconden werken. Dit is duidelijk geen oplossing. Om het even welke idee├źn?


4
2018-05-23 20:55


oorsprong


Zou het toch de muis kunnen zijn? Apparaat met lage snelheid lijkt te wijzen naar een USB 1.1-muis. Misschien werkt een nieuwe muis misschien beter? Het bord is een ASUS M2N met AMD Athlon X2. - Arne
geprobeerd met een andere USB-poort (en / of een externe en externe USB-hub) - voor testdoeleinden ..? - nutty about natty


antwoorden:


Dit kan een probleem zijn met de energiebesparende functie USB-onderbreking.

Als je powernap hebt geïnstalleerd, kan dit helpen:

sudo powernap-action --disable usb_autosuspend

Zonder powernap zou je de autosuspend-functie in de usbcore-module kunnen uitschakelen:

echo "options usbcore autosuspend=0" | sudo tee /etc/modprobe.d/usbcore

Waarschijnlijk moet je de module opnieuw opstarten (of ontladen en opnieuw laden, maar veel geluk daarmee als je een USB-toetsenbord gebruikt) om te zien of de wijziging effectief is.

Als het niet helpt, doe dan het volgende om op te ruimen:

sudo rm /etc/modprobe.d/usbcore

2
2018-06-02 04:05