Vraag Ubuntu kan de netwerkwerkgroep zien maar kan Ubuntu niet vanuit Windows zien


Het spijt me dat ik een complete noob ben, net Ubuntu heb geïnstalleerd en ik probeer dingen op gang te brengen.

Doel: meerdere schijven verbinden met mijn Ubuntu, zeer oude, laptop. Dit fungeert als een NAS voor muziek, video en documenten voor thuis, windows WORKGROUP.

Waar ik nu ben:

Ubuntu draait op mijn laptop. Ik heb updates geïnstalleerd en denk dat ik actueel ben (maar ik weet niet hoe ik moet controleren / bevestigen).

Samba is geïnstalleerd op de Ubuntu-laptop. Ik heb de instructies van veel online sites gevolgd en het beste kan ik zeggen dat het correct lijkt te werken. Ik kan al mijn Windows-machines zien vanuit Home -> browse netwerk -> windows network -> WORKGROUP. Alle drie de andere computers in de werkgroep verschijnen en ik kan naar binnen gaan en bestanden en dergelijke bekijken.

Tot zover goed. Maar dat is waar ik in de problemen kom.

Vergeet niet dat het leuk is om de Ubuntu-box te laten serveren, maar ...

Geen van mijn Windows-machines kan de Ubuntu-laptop op het netwerk zien. Wanneer ik naar Mijn Computer -> Netwerk ga, zie ik mijn andere twee Windows-machines, maar niet de Ubuntu-laptop. Dit gebeurt zowel bij Win 7 als bij Win 8. Op dit moment is alles bedraad, dus draadloos is geen probleem.

Na meerdere keren opfrissen, allerlei dingen uitproberen, de afgelopen nachten de slaap hebben verloren en veel haren eruit getrokken, heb ik het begeven en besloot ik om hulp te vragen. Ja, het is een eerste stap.

Anyways, ik heb overal naar gekeken en kan niets vinden dat online kan helpen. Ik moet iets eenvoudigs hebben verknoeid, zo eenvoudig dat niemand er moeite mee heeft om het tijdens het doorlopen ervan te vermelden. Ten minste, dat hoop ik.

Alle hulp die u zou kunnen bieden zou, nou ja, nuttig zijn.

EDIT # 1:

user68186 - Ik heb de link doorgenomen die u heeft opgegeven. Ik heb een nieuw aandeel toegevoegd via de Samba GUI: / home / steve / 1-share Ik controleerde alle permissies (de schermen zien er natuurlijk een beetje anders uit) maar het lijkt erop dat alles klopt.

Ik kom hier vast te zitten: Stap 3. Ga naar Windows op de desktopcomputer en open Windows Explorer, klik op het driehoekje naast Netwerk in het linkerdeelvenster. In de vervolgkeuzelijst moet u de naam van de laptopcomputer waarop Ubuntu wordt uitgevoerd, kunnen selecteren.

De laptop staat daar gewoon niet vermeld.

EDIT # 2:

Ook kan ik de laptop niet zien als ik het IP-adres typ in Firefox. "Firefox kan geen verbinding maken met de server op 192.168.1.XXX" (waarbij XXX natuurlijk de laatste 3 nummers is)

EDIT # 3:

Bedankt Dan, dus typte ik "\ 192.168.1.xxx \ home / steve / Public" in explorer (deze map wordt gedeeld in de Samba Server-configuratie) en ik krijg het bericht "Windows can not access \ 192.168.1.xxx \ home / steve / Public". Omdat ik de indelingen niet beter ken, heb ik ook "\ 192.168.1.xxx \ home \ steve \ Public" geprobeerd, maar krijg hetzelfde bericht. Heb ook "\ 192.168.1.109 \ steve-xxx" geprobeerd en ontvang hetzelfde bericht.

Het lijkt erop dat Windows de laptop echt niet kan zien.


4
2017-08-07 19:41


oorsprong


Je moet minstens één map delen in Ubuntu voor Windows om het te zien. Zien askubuntu.com/questions/310180/... - user68186
Is de werkgroep van de Ubuntu-machine ingesteld op WERKGROEP? - dan08
Hallo, ja, de werkgroep in het Samba-configuratiebestand van Ubuntu is ingesteld op WERKGROEP. - Steve182231
Probeer beide machines opnieuw op te starten om ervoor te zorgen dat nieuwe instellingen worden geladen. - user68186
Ik heb een volledig vermogen uitgeschakeld en vervolgens ingeschakeld. Nog steeds geen vreugde. - Steve182231


antwoorden:


Mijn Windows 10-computer kon mijn Ubuntu-vak niet zien tot ik de Ubuntu-firewall uitschakelde (sudo ufw disable). Vervolgens, in het zoekvak van Windows 10, voerde ik \\ ubuntu-machinenaam in en dat werkte. (Schakel de Ubuntu-firewall in (voordat u internet gebruikt in uw Ubuntu-vak (sudo ufw enable)).


2
2017-09-21 14:39





Ik heb een vergelijkbare opstelling met een Ubuntu-machine vol stations in een LAN met Windoze-machines. Elke schijf heeft een gedeelde map erop.

Wanneer ik onder "Netwerk" op de windo machines kijk, verschijnt de Ubuntu-machine niet. Tot ik "\\ ubuntu-machine-name" typ in het vak Zoeken op de Windows-computer. Een venster van de Verkenner van het dossier opent met de gedeelde omslagen daarin, en de machine Ubuntu wordt dan vermeld onder Netwerk. Ik kan snelkoppelingen naar de gedeelde mappen maken als ik wil. Wanneer ik het venster bestandsverkenner sluit, verdwijnt de ubuntu-machine uit de netwerklijst, maar de snelkoppelingen werken nog steeds.


1
2017-08-07 19:13





Je hebt ons nooit verteld welke versie van Windows je gebruikt.

Als het XP is, gebruikt Windows standaard "beveiligd delen van bestanden".

Dit betekent dat Samba de machines op het netwerk niet kan zien.

Om het probleem op te lossen, schakelt u 'eenvoudig delen van bestanden' in.


0
2017-08-23 20:35





Tot nu toe had ik een soortgelijk probleem: ik kon via ssh en vnc verbinding maken met mijn Ubuntu-machine, maar ik kon de gedeelde bestanden onder "Netwerk" niet zien onder Windows.

Nou, ik kan ze daar nog steeds niet zien maar ik kon ze benaderen door te typen

\\192.168.xxx.xx

of

\\pc-name

in windows explorer.


0
2017-09-29 01:39





Ubuntu 18.x, selecteer of maak een map, klik er met de rechtermuisknop op en selecteer LOCAL NETWORK SHARE. Zorg ervoor dat anderen worden toegestaan ​​..... en GASTTOEGANG (VOOR MENSEN .... is aangevinkt.) Klik vervolgens op CREATE SHARE. Klik op een Windows-computer op START, typ '\\ computernaam' gevolgd door de terugkeer Het moet u de gedeelde mappen laten zien, u kunt er vervolgens naar toewijzen. Als het niet wordt gevonden of u een probleem met de rechten krijgt, start u de Windows-computer opnieuw op. Ik probeerde dit in een VM met netwerken als 'overbrugd' dus het blijft op het lokale netwerk staan, ik heb er toegang toe gekregen vanaf een andere machine, maar de VM gaf me rechtenproblemen. Na een 'reboot' van de VM werkt alles.


0
2018-06-09 00:21