Vraag Installeer php-extensies op Ubuntu 12.04


Ik wil de nieuwste versies van curl, php5-xmlrpc en php5-intl-extensies voor php 5.4 installeren. Ik heb de nieuwste versie van php 5.4 (geïnstalleerd via ppa: ondrej / php5-oldstable), dus de standaard precieze pakketten voor de genoemde extensies werken niet. Ik weet dit omdat ik dat eerst heb geprobeerd en ook pakketten heb geprobeerd voor latere versies zoals 12.10 en 13.04.

De vraag is hoe ik de nieuwste versies van deze uitbreidingen installeer en waar haal ik ze vandaan. Alle hulp wordt op prijs gesteld.


4
2017-09-21 22:23


oorsprong




antwoorden:


php5-xmlrpc is gebundeld in PHP vanaf 4.1.0: http://php.net/manual/en/xmlrpc.installation.php

php5-intl is te van PHP 5.3.0: http://www.php.net/manual/en/intl.installation.php

Voor curl moet je nog enkele bibliotheken installeren om het te laten werken:

 sudo apt-get install curl libcurl3 libcurl3-dev php5-curl

3
2017-09-22 01:42



bedankt, maar zoals ik al zei, werken de standaardwaarden in repos niet omdat ik de nieuwste versie van php heb (5.4). Dat zou goed werken voor iemand met php 5.3 maar niet in mijn geval :( - mojo706