Vraag remmina werkt niet meer "kan geen verbinding maken met RDP-server localhost"


Tot ergens gisternacht, werkte remmina goed. Ik kon RDP door een SSH-tunnel voeren en alles ging goed.

Toen stopte het met werken. Ik kan zover komen als het wachtwoorddialoogvenster voor mijn werkmachine, maar dan staat er alleen maar Cannot connect to RDP server localhost.

Ik kan zelfs geen logs vinden die er interessant uitzien. Ik heb remmina opnieuw geïnstalleerd, mijn gewist .remmina directory, herstartte mijn machine en startte zelfs mijn gateway opnieuw op.

Gewoon om het echt raar te maken, mijn laptop (die dezelfde setup heeft - de laatste Ubuntu en Remmina) kan de verbinding prima maken. Het gaat zelfs via dezelfde router, zij het draadloos.

Nog ideeën?


27
2017-09-26 20:29


oorsprong


Ik krijg te maken met hetzelfde probleem op ubuntu 18.04 en het werkt perfect als ik de beveiligingsoptie van onderhandelen verander in RDP via het tabblad Vooruit. - Paras


antwoorden:


Ik heb geen idee waarom het werkte, maar ik begon de instellingen een voor een te veranderen. Toen ik de verbindingseigenschappen bewerkte, keek ik op het tabblad "geavanceerd" en veranderde de beveiliging van "onderhandelen" naar "TLS", en voila, alles werkt.

Vreemd genoeg werkt "onderhandelen" nog steeds op de laptop, maar ik ben in ieder geval weer in zaken met mijn grotere monitor :)


38
2017-09-26 22:15



Na het overstappen van 'onderhandelen' naar 'TLS' zag ik het Windows-aanmeldscherm dat me vroeg om het wachtwoord te wijzigen. Het lijkt er dus op dat verlopen wachtwoorden het probleem kunnen voorkomen. Thx voor de oplossing. - Thorsten Niehues


Dit is mij net overkomen en ik heb het gevonden dit antwoord waardoor het probleem is opgelost. Net rm ~/.freerdp/known_hosts en probeer opnieuw.

Blijkbaar gebeurt dit wanneer de toetsen op de tunnelserver veranderen. Zien deze bug.

BIJWERKEN

De eerste link verwijst nu naar een verwijderd antwoord, dus hier zijn enkele aanvullende informatie van die link:

  • Het lijkt erop dat het bestand "known_hosts" enkele routeringsgegevens voor elke server bevat, dat gegevens soms verouderd raken en wanneer Remmina   probeert verbinding te maken via de verouderde gegevens, het mislukt. Verwijderen van de   known_hosts-bestand lost dit probleem op. - Erel Segal-Halevi 13 december '12   om 10:06

  • FWIW, mijn probleem had niets te maken met known_hosts (zoals hieronder uitgelegd), maar alles wat te maken heeft met beveiligingsinstellingen: zie    http://www.bauer-power.net/2013/10/unable-to-connect-to-rdp-server-in.html   voor details. - Tomislav Nakic-Alfirevic 24 april '14 om 10:58 uur

  • Totaal gewerkt, ik vroeg me af waar de certificaten werden opgeslagen. Ik had hetzelfde probleem voor het grootste deel, ik gebruikte Remmina tot RDP tot een bepaald niveau   machine, dan is het op een dag gestopt met werken (niets op de afstandsbediening   machine veranderd). Andere RDP-verbindingen die ik had opgeslagen, werkten nog steeds,   behalve deze ene machine. Het is toevallig gebeurd om NLA auth te gebruiken   lijkt deel uit te maken van het probleem met de nieuwste Remmina niet op te slaan   certs. - Nicholi 26 april 2013 om 20:26 uur

  • bedankt, het gebruikte om perfect te verbinden toen ik de server opnieuw formatteerde en het stopte met werken, het verwijderen van de regel voor deze werkende host. -   Bor691 15 januari '14 om 8:50 uur

  • Ik moet twee services op hetzelfde adres gebruiken, maar verschillende poorten en dit herhaaldelijk gebruiken, is de enige manier om met beide te verbinden. -   Gringo Suave 13 oktober '14 om 18:55 uur


37
2017-08-08 08:33



Het was overladen om toe te voegen sudo voor de rm opdracht. Voor zover ik zie, verwijdert de gebruiker zijn eigen bestand, dus sudo alleen advertentierisico. Mis ik iets? - Volker Siegel
Ik begrijp dat dit een oude vraag en een antwoord is. Een van de redenen waarom ik nooit een externe link post als antwoord of vraag, is omdat na iets dat de link DEAD zou kunnen zijn, zoals in dit geval. Als dat gebeurt, kan een antwoord nutteloos worden. Ik wijs alleen op de voor de hand liggende of StackOverflow moet voorkomen dat gebruikers van deze website externe links plaatsen. - ThN
Ter info: het bestand in kwestie lijkt nu op ~ / .config / freerdp / known_hosts te staan ​​- het staat tenminste op mijn systeem (Linux Mint 18.1). Er is ook een ~ / .config / freerdp / known_hosts2 die extra informatie bevat die misschien meer up-to-date is. Remmina 1.20. - Chris Hillery


Dit gebeurde met mij toen ik mijn remmina-configuratie (onder ~/.remmina) van de ene machine naar de andere. Misschien waren de remmina-versies anders; het veranderen van de beveiliging hielp niet maar het verwijderen en recreëren van de verbinding deed dat wel.


4
2018-02-12 22:25





Het probleem is met de instelling viewmode = 1 in het opgeslagen conf-bestand. Als u het formaat van het venster wijzigt, moet het worden vernieuwd en wordt de sessie gestart. Als u deze Boolean wijzigt in 0, wordt het venster standaard omgezet en wordt het bij het laden vernieuwd. Het probleem is dat als je het formaat van het venster aanpast nadat de sessie is gestart, remmina deze instelling terug zal veranderen.

A work around would be to set the window_maximize=0 to true and then just click/press the maximize button/shortcut to bring it back to your settings. 
window_maximize=1 
window_height=960 
viewmode=1 
Window_width=1440

1
2018-02-27 14:21





Het werkte voor mij door het wijzigen van de beveiliging naar NLA om een ​​onbekende reden.


1
2018-05-03 08:38



Welkom bij Ask Ubuntu! Ik raad het aan Bewerk dit antwoord om het uit te breiden met specifieke details over hoe dit te doen. (Zie ook Hoe schrijf ik een goed antwoord? voor algemeen advies over welke soorten antwoorden het meest waardevol worden geacht op AskUbuntu.) - David Foerster
Afzonderlijke antwoorden die u kunt overstemmen en down-loaden, lijkt mij nuttig. Het bewerken van antwoorden van andere mensen om in te voegen "wel, hoe zit het met X", lijkt het tegenovergestelde van nuttig. Het is één ding om fouten te corrigeren, ga je gang en bewerk. Maar een nieuw persoon vertellen over bewerken in plaats van te zeggen wat voor hen werkte, lijkt het tegenovergestelde van goed. - Warren P


Waarschijnlijk dom antwoord, maar het probleem voor mij was dat ik probeerde verbinding te maken via een open Wi-Fi-netwerk (niet-versleuteld) en remmina zou dat niet toestaan. Nadat ik verbinding had gemaakt met een beveiligd netwerk, werkte alles weer zoals gepland.


0
2018-06-15 22:38



Zou het niet mooi zijn als Remmina daadwerkelijk nuttige foutmeldingen liet zien in plaats van alleen maar faalde? - Warren P