Vraag Hoe kan ik Adobe AIR installeren?


Ik ben een zware gebruiker van bepaalde applicaties die op AIR zijn gebouwd.

Het lijkt erop dat AIR de ondersteuning voor Linux heeft stopgezet. Zelfs de oudere versies in de Adobe AIR-archieven lijken alleen 32-bits Linux-distributies te ondersteunen en ik ben momenteel 64-bits.

Is er zelfs een kleine mogelijkheid dat ik onder deze omstandigheden AIR zou kunnen uitvoeren? Zo ja, kunt u mij vertellen waar kan ik hiervoor een gedetailleerde stapsgewijze installatie krijgen?


153
2017-12-13 14:51


oorsprong


Merk op dat Adobe de ondersteuning voor AIR op Linux heeft beëindigd. Adobe gaat ook weg van verouderde technologieën zoals Flash en AIR naar HTML5, wat de toekomst is. - Anonymous
Ik heb adobe air vanuit het .deb-bestand in oneric geïnstalleerd - Tachyons


antwoorden:


Ik heb Air nodig voor ongeveer drie programma's - YNAB, LongTailPro, Xtend:

  1. Download de nieuwste versie Air 2.6.0 voor Linux naar uw bureaublad:

  2. Ctrl + Alt + T om terminal te openen

  3. sudo apt-get install ia32-libs  - (32 bit onzin als je dit wilt uitvoeren in x64 Ubuntu; als je problemen hebt, kijk dan "Afhankelijk: ia32-libs-multiarch maar niet installeerbaar" - Oplossing)

  4. cd Desktop (wijzig beginscherm tot bureaubladscherm)

  5. chmod +x AdobeAIRInstaller.bin (verander modus - voer toestemming uit ja)

  6. ./AdobeAIRInstaller.bin (nadat u de Adobe Air-licentie hebt geaccepteerd, wordt u om uw wachtwoord gevraagd, heeft het root-toegang nodig om het te kunnen installeren)

Misschien krijg je na het laatste commando een foutmelding?

Sorry, er is een fout opgetreden. Adobe AIR kan niet worden geïnstalleerd. Installeer Gnome Keyring of KDE KWallet voordat u Adobe AIR installeert.

Dit kan worden opgelost:

  • Typ in een terminal (standaardsnelkoppeling: Ctrl + Alt + T):

    locate libgnome-keyring.so
    
  • Dit is mijn resultaat (de jouwe kan anders zijn):

    /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0
    /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0
    
  • Zoals hieronder aangegeven door @jmendeth, is het gebruik van LD_LIBRARY_PATH de gemakkelijkste manier om het installatieprogramma te vertellen waar deze bestanden te vinden zijn:

    • Voor 32-bits Ubuntu (getest op 12.04):

      LD_LIBRARY_PATH=/usr/lib/i386-linux-gnu ./AdobeAIRInstaller.bin
      
    • Voor 64-bits Ubuntu is de opdrachtregel waarschijnlijk:

      LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu ./AdobeAIRInstaller.bin
      

Als de truc LD_LIBRARY_PATH niet werkt, kun je dit proberen:

  • Maak een symbolische link naar uw locatieregels die u vond met de vorige commando's:

    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0
    
  • Gebruik de volgende opdrachten voor 32-bits systemen:

    sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
    sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0
    
  • Herhaal vervolgens stap 4 & 6 (sla 5 over, want de toestemming om het bestand uit te voeren is niet gewijzigd).

  • Verwijder symbolische koppelingen na installatie van Adobe AIR 2.6.0:

    sudo rm /usr/lib/libgnome-keyring.so.0
    sudo rm /usr/lib/libgnome-keyring.so.0.2.0
    

Referentie:


225
2018-04-09 02:26



Super goed! Het is geïnstalleerd. Nu als ik alleen een AIR-pakket kan installeren ... - BrianXP7
Heeft AIR geen respect LD_LIBRARY_PATH? Ik vraag het alleen' - Alba Mendez
Ik heb een account gemaakt om deze +1 te overtuigen - Paul Bellora
Ik kan je onmogelijk +1 genoeg geven. - Jonah
Het werkt niet voor mij op Xubuntu 13.10. sudo apt-get install ia32-libs Pakket ia32-libs is niet beschikbaar, maar wordt door een ander pakket aangeduid. Dit kan betekenen dat het pakket ontbreekt, is verouderd of alleen beschikbaar is vanuit een andere bron. De volgende pakketten vervangen het echter: lib32asound2 lib32z1 lib32ncurses5 lib32bz2-1.0 ./AdobeAIRInstaller.bin /tmp/air.kmEATV/setup: fout bij het laden van gedeelde bibliotheken: libgtk-x11-2.0.so.0: kan het bestand met gedeeld object niet openen: Nee dergelijk bestand of map - Slava Fomin II


Ubuntu 13.10, 14.04, 15.04 en 15.10 (64 bit)

  1. Installeer i386-bibliotheken die nodig zijn voor een succesvolle installatie en werking van Adobe Air- en luchttoepassingen.

    sudo apt-get install libxt6:i386 libnspr4-0d:i386 libgtk2.0-0:i386 libstdc++6:i386 libnss3-1d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libcanberra-gtk-module:i386 gtk2-engines-murrine:i386
    
  2. Installeren libgnome-keyring0:i386 pakket.

    sudo apt-get install libgnome-keyring0:i386
    
  3. Maak symlinks naar gnome-keyring zodat Adobe Air het kan zien.

    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
    
    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0 
    
  4. Download Adobe Air-installatieprogramma van hier.

  5. Geef execute permissie en voer dat .bin-bestand uit.

    sudo chmod +x AdobeAIRInstaller.bin
    sudo ./AdobeAIRInstaller.bin
    

Bron

Opmerking voor Ubuntu 16.04 (64 bit)

Installeer het pakket voor Ubuntu 16.04 en hoger libnss-mdns:i386 in plaats van het pakket lib32nss-mdns. Dit zal het probleem van "Pakket niet gevonden fout" gerelateerd aan dat pakket oplossen.


43
2018-03-28 23:36



Deze werkt ook voor 14.04 - adosaiguas
Goed om te weten .. ik zal mijn antwoord updaten. - Avinash Raj
Dit werkt ook voor 15.04 (64-bits). Bedankt. - Dmitry Wojciechowski
Werkt ook voor 15.10 (ik gebruik ontwikkelversie) - Yana Agun Siswanto
16.04, kreeg daar een fout van lib32nss-mdns was vermist. Wanneer het installatieprogramma geopend is Gtk-Message: Failed to load module "overlay-scrollbar" Gtk-Message: Failed to load module "gail" Gtk-Message: Failed to load module "atk-bridge". Lijkt correct te zijn geïnstalleerd. Maar de app waarvoor ik AIR nodig had, heeft een meer recente versie nodig: / - raphael


Als alternatief kunt u een vooraf gebouwde .deb installeren

Er is air 2.6 (laatst ondersteunde Linux-versie) beschikbaar hier voor beide architecturen (beide gebruiken er 32 bit onder, maar het werkt tenminste). Dankzij prusswan voor het wijzen.

Zorg ervoor dat je 32 bit libs hebt die het nodig heeft:

sudo apt-get install ia32-libs

Ik heb de AMD64-versie gedownload (adobeair_2.6.0.19170_amd64.deb) en op mijn computer geïnstalleerd (am64 met Precise Pangolin 12.04)

sudo dpkg -i adobeair_2.6.0.19170_amd64.deb

Toen installeerde ik de applicatie die Adobe Air nodig had en het werkte.

Update voor Ubuntu 13: 10+,

Als ik deze techniek probeer, krijg ik "Pakket ia32-libs-gtk is niet geïnstalleerd"

ik keek op het pakket en probeerde het installeren van die afhankelijkheden en andere gerelateerde pakketten die ik direct kan bedenken:

sudo apt-get install gtk2-engines:i386 libart-2.0-2:i386 libcairo2:i386 libcanberra-gtk0:i386 libdatrie1:i386 libgail-common:i386 libgconf2-4:i386 libgtk2.0-0:i386 liblua5.1-0:i386 libpango1.0-0:i386 libpixman-1-0:i386 libqt4-network:i386 libqt4-test:i386 libqtcore4:i386 libthai0:i386 libbonobo2-0:i386 libglade2-0:i386 libgnomecanvas2-0:i386 libidl0:i386 liborbit2:i386 libwmf0.2-7:i386 gtk2-engines-murrine:i386

Maar dat werkte niet voor zowel de deb of origineel binair bestand.


18
2018-05-29 19:56



Ik heb het internet hoog en laag doorzocht en uw installatielink is de enige die werkte. Opmerking voor toekomstige bezoekers: als u AdobeAIRInstaller.bin gebruikt en een Gtk WARNING **: cannot open display: fout, probeer dit! - eleanor.mal
dit is veel gemakkelijker dan jeffhendricks.net/?p=68 - realgt
Gleed een beetje dieper dan nora en vond het antwoord met betrekking tot het probleem "can not open display". Probleem is dat de rootgebruiker geen verbinding kan maken met het X-display in Ubuntu (met standaardinstellingen), maar we moeten ons installatieprogramma als root uitvoeren (fail-design). Installeer eerst sux (switchuser met X-inloggegevens). Toestaan ​​dat de rootgebruiker verbinding maakt met het X-display. Krijg de huidige weergave-instellingen. Gebruik vervolgens sux om over te schakelen naar rootgebruiker. Start het installatieprogramma met weergave-instellingen. 1. sudo apt-get install sux 2. /usr/bin/xhost + 3. echo $DISPLAY (gebruik dit in stap 5) 4. sudo sux - 5. DISPLAY=:0.0 ./AdobeAIRInstaller.bin - Nicholi


Ubuntu 14.04 - 32 en 64 bit - eenvoudige installatie van .deb

Vanwege de manier waarop multiarch werkt, kunt u nu eenvoudig het i386 .deb-bestand op nieuwere 64bit Ubuntu installeren en het zal automatisch de juiste afhankelijkheden installeren. (Ook de 64 bit .deb is gewoon de 32-bits herverpakt met een afhankelijkheid van ia32-libs)

  1. Download de 32 bit (ja zelfs voor je 64 bit Ubuntu) deb: http://update.devolo.com/linux/apt/pool/main/a/adobeair/adobeair_2.6.0.19170-devolo1_i386.deb (Dank aan het antwoord van yuvilio) Het 64-bits pakket op dezelfde site is een opnieuw verpakte versie van de 32-bits, u zult problemen ondervinden als u het 64-bits pakket gebruikt, gebruik het 32-bits pakket voor zowel 32 als 64-bits systemen Ubuntu 13.10+.

  2. Open in het softwarecentrum, klik Installeren

    enter image description here Negeer de waarschuwing over de kwaliteit van het pakket


Als je een Steam-spel hebt dat Air nodig heeft, kun je het spel gewoon installeren en uitvoeren en wordt Air geïnstalleerd tijdens de eerste run van het spel.

Voorbeeld games die Air gebruiken:

  • Verdedigers Quest
  • Anodyne (raakt in de war als je Air al hebt laten installeren, uitvoeren sudo apt-get remove adobeair en probeer het spelinstallatieprogramma opnieuw omdat het met Air wordt geleverd)

Ik vond deze tijdens een Wekelijkse bescheiden verkoop om enkele open source-projecten te ondersteunen.


13
2018-03-30 11:46





Stap 1: Krijg wat lucht Download vervolgens het Adobe Air .bin-bestand (directe link hier).

Stap 2: Installatie

Open een terminal (toepassingen> Accessoires> Terminal) en navigeer naar uw map Downloads (of de map waarin u het .bin-bestand hebt opgeslagen).

* cd Download/

We moeten het .bin-bestand toestemming geven om te installeren, dus voer de volgende opdracht zorgvuldig in:

* chmod +x AdobeAIRInstaller.bin

Laten we het nu installeren:

* ./AdobeAIRInstaller.bin

De installatie moet echter wel doorlopen en als het goed is, verschijnt er een nieuw menu-item in 'Toepassingen> Accessoires' met de naam 'Adobe Air Application Installer'.


6
2018-01-10 04:14



Dit werkt niet op Ubuntu 13.10 x64 - Paul Gregoire


... eindelijk na wat problemen en na veel zoekopdrachten op dit forum zijn Google en andere pagina's erin geslaagd om het te doen. Eerst wil ik de community bedanken die me meer ambitie heeft gegeven om het te doen, dan dat ik stop om AdobeAir te installeren.

Het hele probleem was het pakket ia32-libs(Het ia32-libs-pakket was een hack om 32-bits pakketten op een 64-bits installatie te installeren. Sinds Ubuntu versie 11.10 (Oneiric) is Multi Arch toegevoegd. Een van de doelstellingen hiervoor is het verwijderen van het pakket ia32-libs) ... pakket dat Canonical heeft besloten om ondersteuning voor het te beëindigen.

Alles wat ik moest doen om te installeren ia32-libs pakket was om deze repo toe te voegen:

1- ''deb http://archive.ubuntu.com/ubuntu/ raring hoofdbron van het multiverspackage-universum''

Ik volgde de stappen van deze snelle en eenvoudige tutorial:

http://wiki.phoenixviewer.com/ia32-libs-in-ubuntu-13-10

2- dan is deze pagina die me naar dit mooie leidt stappen om Adobe Air te installeren voor 64-bits systemen

www.thepowerbase.com/2013/06/how-to-install-adobe-air-in-ubuntu-13-04/

-----------------documentatie die ik heb gebruikt:---------------

www.askubuntu.com/questions/87447/how-can-i-install-adobe-air
helpx.adobe.com/air/kb/archived-air-sdk-version.html
www.wiki.phoenixviewer.com/ia32-libs-in-ubuntu-13-10
www.ubuntuforums.org/showthread.php?t=2181649
www.askubuntu.com/questions/91815/how-to-install-software-or-upgrade-from-old-    unsupported-release  

Postscriptum --- zoals opgemerkt door Alvar, Adobe Air voor Linux wordt niet langer ondersteund ---


4
2017-11-06 09:08



Bekijk deze link. Het werkte goed. tkalin.com/blog_posts/... - Michael Mikowski
@MichaelMikowski Je link heeft me geholpen. De bovenstaande links hadden geen oplossing voor handmatige coping-bibliotheek die niet kon worden geïnstalleerd. Daarna heb ik AdobeAir geïnstalleerd. - ubuntico


Helaas, vele jaren te laat "Adobe AIR for Linux wordt niet langer ondersteund." na wat de Adobe-pagina zegt. Het gebruik van het "AIR-archief" is mogelijk om niet-ondersteunde versies te krijgen, de 2.6.0-versie is de meest recente beschikbaar. Als u een programma moet installeren waarvoor een nieuwere versie is vereist, gaat u mogelijk naar een virtuele box met een Windows-gast.

De aanbevolen stappen voor Ubuntu 16.10:

voor 32-bit machine

wget -O adobe-air_i386.deb http://drive.noobslab.com/data/apps/AdobeAir/adobeair_2.6.0.2_i386.deb
sudo dpkg -i adobe-air_i386.deb
sudo apt-get install -f && rm adobe-air_i386.deb

voor 64-bits machine

wget -O adobe-air_amd64.deb http://drive.noobslab.com/data/apps/AdobeAir/adobeair_2.6.0.2_amd64.deb
sudo dpkg -i adobe-air_amd64.deb
sudo apt-get install -f && rm adobe-air_amd64.deb

De aanbevolen stappen voor Ubuntu 16.04 / 14.04 / 12.04 / Linux Mint 18/17/13 (beide geëxtraheerd uit hier):

wget -O adobe-air.sh http://drive.noobslab.com/data/apps/AdobeAir/adobe-air.sh
chmod +x adobe-air.sh;sudo ./adobe-air.sh

1
2018-03-30 17:53





Ik heb Ubuntu 14.04 64-bit. De enige manier om Adobe Air te installeren die voor mij werkte, was het eerste deel hiervan te volgen instructies voor het installeren van Balsamiq op Ubuntu, dat is wat ik in de eerste plaats probeerde te doen.

Een korte samenvatting van die instructies: - Downloaden dit Adobe Air-installatieprogramma - Installatie van het 32-bit libgtk-pakket (maar ik sloeg deze stap over, het werkte niet voor mij en leek niet nodig) - Het maken van symbolische koppelingen naar twee libgnome-keyring-bestanden - Het Adobe Air-installatieprogramma uitvoerbaar maken en uitvoeren met sudo


0
2018-01-29 22:46