Vraag Na het bijwerken naar 16.04 werkt de Bluetooth A2DP-modus niet meer


Ik heb een mooie bluetooth-audio-ontvanger aangesloten op mijn HiFi-stereo, en ik was in staat om hem in 14.04 te verbinden als een A2DP-spoelbak met mooie kwaliteit.

Na het upgraden naar 16.04, maakt het apparaat alleen verbinding als een headset en wanneer ik probeer dit in de A2DP-modus te schakelen, heb ik deze fout in mijn syslog:

May 21 11:35:50 RRyS pulseaudio[6159]: [pulseaudio] module-bluez5-device.c: Refused to switch profile to a2dp_sink: Not connected

en de kwaliteit van audio is abismaal. Hoe kan ik het repareren?


28
2018-05-21 10:32


oorsprong


Ik hoop dat dit nuttig is voor iemand. Ik ben er 3 uur lang mee bezig geweest ... Ik ben dol op upgrades! ;-) - Rmano


antwoorden:


Wat voor mij werkt, is om het Bluetooth-apparaat aan te sluiten, over te schakelen naar de HSP / HFP-modus, de verbinding te verbreken, opnieuw verbinding te maken en vervolgens over te schakelen naar de A2DP-modus.


35
2017-08-11 18:30



Hier ook. Het zou echter niet zo moeten zijn en het werkte in de vorige versie goed. - eldad-a
Ook voor mij werkte dat. Maar een echte pijn in de a ** voor iets dat (bijna) foutloos werkte in 15.10 en daarvoor. - Dolanor
Oh geloof me, daar ben ik het mee eens. het is een enorme pijn. De enige distro die ik heb gevonden die BT nu correct uit de verpakking behandelt, is Solus OS. - rmfought
Dit is super raar maar het werkte! - ArcaneDominion
Heilige rotzooi. Ik had niet verwacht dat dit zou werken, maar het gebeurde wel. - Parth Thakkar


Er zijn verschillende bugs over geopend, kijk bijvoorbeeld deze (begonnen in 15.05) en deze andere, vrij ouder; de oorzaken in het algemeen zijn niet goed begrepen.

Voordat u begint met het wijzigen van systeembestanden, kunt u ook controleren Bluetooth-luidspreker geen geluid in Ubuntu 16.04 (lijkt een andere bug) en A2DP bluetooth werkt niet op 16.04 (opgelost in opmerkingen door een kernel-upgrade).

De oplossing die voor mij werkte, is de volgende --- dank aan gebruiker RobertFM in het startpunt en SimFox3 in Arch-forums. Alle volgende instructies moeten worden uitgevoerd vanuit een rootshell (sudo -i). Zorgvuldig en drievoudig controleren.

  1. Maak allereerst een back-up van deze bestanden (je weet maar nooit):

    cp /etc/bluetooth/audio.conf /etc/bluetooth/audio.conf.bak
    cp /etc/pulse/default.pa /etc/pulse/default.pa.bak
    cp /usr/bin/start-pulseaudio-x11 /usr/bin/start-pulseaudio-x11.bak
    
  2. Bewerk /etc/bluetooth/audio.conf en maak het vergelijkbaar met deze:

    # Configuration file for the audio service
    # This section contains options which are not specific to any
    # particular interface
    [General]
    Enable=Gateway,Source
    
    # Switch to master role for incoming connections (defaults to true)
    Master=true
    
    # If we want to disable support for specific services
    # Defaults to supporting all implemented services
    #Disable=Gateway,Source,Socket
    Disable=Socket
    
    # SCO routing. Either PCM or HCI (in which case audio is routed to/from ALSA)
    # Defaults to HCI
    #SCORouting=HCI
    
    # Automatically connect both A2DP and HFP/HSP profiles for incoming
    # connections. Some headsets that support both profiles will only connect the
    # other one automatically so the default setting of true is usually a good
    # idea.
    AutoConnect=true
    
    # Headset interface specific options (i.e. options which affect how the audio
    # service interacts with remote headset devices)
    [Headset]
    
    # Set to true to support HFP, false means only HSP is supported
    # Defaults to true
    HFP=true
    
    # Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
    MaxConnected=2
    
    # Set to true to enable use of fast connectable mode (faster page scanning)
    # for HFP when incoming call starts. Default settings are restored after
    # call is answered or rejected. Page scan interval is much shorter and page
    # scan type changed to interlaced. Such allows faster connection initiated
    # by a headset.
    FastConnectable=true
    
    # Just an example of potential config options for the other interfaces
    #[A2DP]
    #SBCSources=1
    #MPEG12Sources=0
    
  3. Bewerk /etc/pulse/default.pa en becommentarieer de lijn

    #load-module module-bluetooth-discover
    

    (je hoeft echt alleen maar de. toe te voegen # aan het begin)

  4. Bewerk /usr/bin/start-pulseaudio-x11 en voeg de regel toe /usr/bin/pactl load-module module-bluetooth-discover na het laden van de module module-x11-xsmp; in de praktijk zou je het bestand aan het einde moeten bewerken om een ​​strofe te krijgen

    if [ x"$SESSION_MANAGER" != x ] ; then
        /usr/bin/pactl load-module module-x11-xsmp "display=$DISPLAY session_manager=$SESSION_MANAGER" > /dev/null
        # add this line here:
        /usr/bin/pactl load-module module-bluetooth-discover
    fi
    
  5. Reboot.

    Nu moet je je apparaat op A2DP kunnen instellen en genieten van muziek van hoge kwaliteit:

    Sound settings

    Merk op dat u ooit uw apparaat moet loskoppelen en opnieuw verbinden om A2DP opnieuw in te schakelen:

    Bluetooth devices

    ... ja, het is een blikje bugs. Maar als het werkt, werkt het prachtig.

  6. Problemen na opnieuw opstarten

    Na dit alles lijkt de truc soms slechts te werken na de volgende herstart. Probeer in een dergelijk geval te volgen antwoord van rmfought:

    Wat voor mij werkt, is om het Bluetooth-apparaat aan te sluiten, om over te schakelen naar   HSP / HFP-modus, ontkoppelen, opnieuw verbinden en vervolgens overschakelen naar de A2DP-modus.

    ... werkt ook voor mij (opnieuw, soms). Ik moest zelfs een paar ontkoppelen om de dongle opnieuw te pairen.

  7. Als het nog steeds niet werkt ...

    Als dit ook niet voor u werkt, kunt u proberen met dit script --- de auteur houdt het up-to-date.


32
2018-05-21 10:32



audio.conf is niet aanwezig in ubuntu 16.04, alleen main.conf, zal dat werken? - Joakim Koed
@JoakimKoed --- je hebt gelijk, ik heb gecontroleerd --- ik had een audio.conf-remove waarschijnlijk overblijfsel van de upgrade. Ik heb het eenvoudigweg opnieuw gemaakt - dus nu twijfel ik, misschien zijn alleen de punten 3 en 4 nodig? - Rmano
Stap 3 en 4 herstelden niet voor mij en ik maakte audio.conf opnieuw volgens het bovenstaande en geen oplossing. Het verwijderen van het Bluetooth-apparaat en het repareren van fixes, maar dat elke keer dat u bluetooth-audio wilt gebruiken, is niet haalbaar. - Thomas Carlisle
@ThomasCarlisle sorry om dat te horen - hier werkte het (niet nodig om opnieuw te associëren) na de eerste keer. Moet een ander ding zijn ... - Rmano
Briljant! Het doet de truc met mij! Ik stel voor dat u er een verwijzing naar in uw antwoord toevoegt, omdat alles bij elkaar een volledig werkende oplossing voor het probleem lijkt te bieden. Proost! - romanovzky


Dit is niet noodzakelijk een oplossing voor degenen die de microfoon nodig hebben, maar dit werkte voor mij in Ubuntu 16.04:

sudo nano /etc/bluetooth/audio.conf

En dan toevoegen Disable=Headset onder [General].

[General]
Disable=Headset

En herstart de bluetooth-service

sudo service bluetooth restart

En alle geloofwaardigheid van deze man: https://jimshaver.net/2015/03/31/going-a2dp-only-on-linux/


5
2017-09-03 23:31



Helaas niet gelukt voor mij. Mijn bluetooth dock-pictogram is grijs ... Misschien is het de driver / module? XPS 13 9350 en ubuntu 16.04. - Dolanor
@Dolanor Niet zeker of dit nog steeds een probleem is, maar als het dock-pictogram grijs is, betekent dit hoogstwaarschijnlijk dat uw Bluetooth-adapter is geblokkeerd met een softblok. Proberen rfkill unblock bluetooth en misschien zelfs bluetoothctl en dan power on (in de bluetoothctl-CLI). - FMaz
Dit werkte in mijn geval zorinos 12 - FDisk