Vraag FSTAB Mount nieuwe LVG


Ik heb problemen met het automatisch monteren van mijn nieuw gecreƫerde LVG. Ik heb geprobeerd de volgende regel toe te voegen aan / etc / fstab:

/dev/vgBackup/lvBackup /home/stuart/volume_backup ext3 defaults 0 1

Ik probeerde ook de / dev / vgBackup / lvBackup te ruilen met iets soortgelijks UUID=f7b9a5e3-4fa3-4bfd-b9af-bf126c296213 gebaseerd op de ID die opkwam toen ik de drive manueel monteerde van nautilus door op het volume te klikken (het verscheen in / media). Helaas krijg ik in beide gevallen een opstartbericht waarin staat dat de montage mislukt en ik druk op S om over te slaan.

Handmatig monteren van de schijf van de CLI met:

sudo mount /dev/vgBackup/lvBackup /home/stuart/volume_backup 

werkt echter.

Misschien is fstab de verkeerde tool om te gebruiken? In het ideale geval moet de schijf beschikbaar zijn om naar te schrijven voor de stuart-gebruiker in plaats van root.

Extra informatie

  • De drive gebruikt momenteel het ext3-bestandssysteem
  • 3.5TB in grootte.
  • bestaat uit een fysieke schijf van 3TB en 500G

4
2017-10-13 16:20


oorsprong




antwoorden:


De gebruikelijke manier om LVM-volumes te monteren lijkt via de symlink van de apparaat-map te zijn op / dev / mapper /vgname-lvname, bijvoorbeeld als ik de volgende volumes heb

$ sudo lvs
  LV     VG   Attr   LSize  Origin Snap%  Move Log Copy%  Convert
  root   t60p -wi-ao 89.92g                                      
  swap_1 t60p -wi-ao  3.00g  

dan

$ grep '/dev' /etc/fstab
/dev/mapper/t60p-root /                 ext4    errors=remount-ro 0       1
/dev/mapper/t60p-swap_1 none            swap    sw                0       0

Dit voorbeeld is afkomstig van een 12.04 Server-installatie met LVM voor de gehele schijf die tijdens de installatie is geselecteerd, dus de fstab is die van het installatieprogramma. Als ik uw naamgevingsconventie correct begrijp, zou het equivalent voor uw back-upvolume zijn

/ Dev / mapper / vgBackup-lvBackup /home/stuart/volume_backup ext3 defaults 0 1


6
2017-10-13 17:35



Bedankt! Dat werkte voor mij. Toen ik sudo blkid -c / dev / null draaide, toonde het duidelijk dat het eigenlijk op ext4 was ingesteld, maar ik zweer dat toen ik make2fs draaide, ik een ext3 bestandssysteem creƫerde. Is het mogelijk dat ik ext4 partities en een ext3 bestandssysteem heb gemaakt, een fout die me later zal bijten? - Programster
@steeldriver Het werkt niet 100% voor mij. Zie mijn vraag op askubuntu.com/questions/728174/.... Help alsjeblieft alsjeblieft? Bij voorbaat bedankt. - Ashu