Vraag "Zie: Disabled Privacy Extensions" en ipv6 uitschakelen?


Er zijn veel van "lo: Disabled Privacy Extensions"in var/log/messages . Ik heb gegoogled en vastgesteld dat ipv6 is gerelated, dus ik heb geprobeerd ipv6 uit te schakelen.

Ik heb de volgende regels toegevoegd aan /etc/sysctl.conf 

net.ipv6.conf.all.disable_ipv6=1
net.ipv6.conf.default.disable_ipv6=1
net.ipv6.conf.lo.disable_ipv6=1

en blacklist ipv6 naar /etc/modprobe.d/blacklist.conf 

daarna heb ik het netwerk opnieuw opgestart door /etc/init.d/networking restart .

Mijn vraag is: De ip addr toont nog steeds het inet6-adres gekoppeld aan eth0 in vormen zoals  inet6 fe80 :: 212: 79ff: fecf: edaf / 64 scope-link

Betekent dit mijn ipv6 niet gehandicapte?


4
2018-02-03 11:11


oorsprong


Schakel IPv6 niet uit. Als u geen IPv6-router in uw LAN hebt, zal uw apparaat dat niet gebruiken. Maar als u echt IPv6 wilt uitschakelen, hoeft u alleen de module 'ipv6' te verwijderen. Maar dat zou je niet moeten doen. En nee, als u een link lokaal adres ziet, zoals fe80::/10, je hebt IPv6-ondersteuning op je machine. - Anders


antwoorden:


Verdien IPv6 in Ubuntu

Methode 1

gksudo gedit  /etc/modprobe.d/aliases

Zoek de lijn: alias net-pf-10 ipv6 veranderen naar alias net-pf-10 off

Als de bovenstaande wijziging niet werkt, moet u de volgende wijzigen      alias net-pf-10 off ipv6

Methode 2

Bewerk / etc / default / grub-bestand

gksudo gedit  /etc/default/grub

Verandering

GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash”

naar

GRUB_CMDLINE_LINUX_DEFAULT=”ipv6.disable=1 quiet splash”

Sla op en verlaat het bestand

Werk de grub bij vanaf de opdrachtregel

sudo update-grub

Hou me op de hoogte.

Vriendelijke groeten,

Ilias el Matani


4
2018-02-04 15:27



ja, bedankt, dat is wat ik wil - Smartkid


ipv6-ondersteuning lijkt ingebouwd te zijn in de nieuwste ubuntu-kernels, dus je kunt de module niet op de zwarte lijst plaatsen.

Om ipv6 uit te schakelen moet je doen sysctl -p /etc/sysctl.conf voordat de wijzigingen in dat bestand worden gebruikt. (ervan uitgaande dat u uw computer niet opnieuw hebt opgestart, in welk geval de wijzigingen al actief zouden moeten zijn).

Maar waarom wil je ipv6 uitschakelen? De logberichten zullen uw computer niet beschadigen.

Oh, en als je alleen het privacy extensies gedeelte van ipv6 wilt uitschakelen (wat je waarschijnlijk niet op een server nodig hebt), plaats dan de sleutel net.ipv6.conf.all.use_tempaddr = 0 in /etc/sysctl.conf


1
2018-02-03 13:05



Ik wil ipv6 uitschakelen omdat: 1) te veel "lo: Disabled Privacy Extensions" in het logboek en 2) mijn website kan draaien met ipv4, dus waarom zou ik ipv6 inschakelen? :-) - Smartkid
@Smartkid: Nou, er is dit uitputting ding: APNIC - Carsten Thiel
@Smartkid doh! het lijkt erop dat ipv6 nu in de kernel is ingebouwd. Maar het sysctl doen zou het moeten uitschakelen. Niet dat je een goede reden lijkt te hebben om het te doen. Jouw website zullen moet je ipv6 uiteindelijk ondersteunen als je van plan bent om het te bewaren, en het kost je niets als je het hebt ingeschakeld. - petergil
ah, dat is waar. Ik denk dat ik verwend ben sinds ik een ISP heb die ipv6 eigenlijk ondersteunt. Het is echt heel praktisch. - petergil
Het is beter om de privacy-extensie in te schakelen (als u deze gebruikt), want als ze zijn uitgeschakeld, kunt u alleen op basis van uw IP-adres identificeren! - Joschua


In een openSUSE 11.2-box met een veel nieuwere kern dan origineel, kreeg ik ook dit bericht.

De use_tempaddr-instelling hierboven is al -1, dus dat is geen oplossing.

Maar elders hebben verschillende mensen gezegd dat het afsluiten van vsftpd hun berichten stopt.

En als een LXC-gebruiker weet ik toevallig iets ongewoons dat vsftpd doet met de ondersteuning van naamruimten in nieuwere kernels, wat een probleem veroorzaakt wanneer vsftpd in een LXC-container wordt gebruikt.

Het blijkt alleen maar uit te schakelen dat op namespace gebaseerde isolatiefunctie in vsftpd genoeg is om de berichten op zijn minst voor mij te stoppen.

Voeg het volgende toe aan /etc/vsftpd.conf:

isoleren = NEE
isolate_network = NEE

Start dan vsftpd opnieuw.

ipv6 en vsftpd zijn beide nog steeds ingeschakeld, maar geen privacy-extensieberichten meer.


1
2018-03-09 23:17





Zoals beantwoord door Brian K. White, Ik heb net opnieuw geconfigureerd /etc/vsftpd.conf met de ongedocumenteerden isolate_network=NO en het heeft de truc gedaan. Een klein verschil met zijn antwoord is dat ik niet hoefde in te stellen isolate=NO.

Deze configuratievariabele retourneert vsftpd om fork () te gebruiken. Anders zou het de parameter clone () gebruiken met CLONE_NEWNET. Dit zou het proces dat toegang geeft tot de bestanden in een aparte netwerkomgeving brengen die geen toegang heeft tot enig netwerk. (Ik heb deze informatie gevonden bij een ander antwoord op ServerFault)

Ik volgde dit pad, omdat ik die logboekberichten zag verschijnen nadat ik vsftpd had ingesteld.


1
2017-08-03 07:37





Controleren of IPv6 is ingeschakeld of uitgeschakeld

$ cat /proc/sys/net/ipv6/conf/all/disable_ipv6

0 betekent dat het is ingeschakeld en 1 is uitgeschakeld.

Om IPv6 uit te schakelen

$ su -
# nano /etc/sysctl.conf

en voeg deze regels toe aan het bestand sysctl.conf

#disable ipv6
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

Sla het bestand sysctl.conf op met nieuwe config en start vervolgens uw systeem opnieuw op

# reboot

Controleer uw systeem opnieuw

$ cat /proc/sys/net/ipv6/conf/all/disable_ipv6

Nu zou u moeten zien "1" betekent dat IPv6 is uitgeschakeld op uw systeem.

Hoe IPv6 op Ubuntu en Linux Mint uit te schakelen


0
2017-12-23 09:11



Nee, om IPv6 uit te schakelen, moet je doen zoals @Ilisa doet in het andere antwoord. En om te zien of je IPv6-ondersteuning hebt, kun je gewoon opstarten ip -6 add en kijk of je een link lokaal adres hebt. - Anders