Vraag Hoe installeer ik Skype 4.3? [duplicaat]


Deze vraag heeft hier al een antwoord:

Opmerking: de oude Skype voor Linux-toepassing (v4. *) Is nu beëindigd en is verwijderd uit de partnerrepository's van Canonical, dus deze vraag en de antwoorden zijn verouderd. Raadpleeg alstublieft een nieuwer antwoord van onze canonieke Skype installatie vraag.

Skype 4.3 is zojuist uitgebracht met aanzienlijke verbeteringen. Als een normale Skype-gebruiker wil ik de nieuwste Skype gebruiken op mijn Ubuntu 14.04, maar er zijn geen updates van Update Manager. Zelfs op de Skype-website is alleen Skype 4.3 alleen beschikbaar voor Ubuntu 12.04. Is er hoe dan ook het gebruik van deze nieuwste Skype op Ubuntu 14.04 of hoeveel moeten we wachten op de update?


161
2018-06-25 13:54


oorsprong


Je hebt al een paar howto-antwoorden. Ik wilde gewoon toevoegen dat er een bug op de wishlist is over het bijwerken van de Canonical Partner-repository: launchpad.net/bugs/1280109 Voel je vrij om aan te geven dat het je beïnvloedt, en misschien een reactie toevoegen. ;) - Gunnar Hjalmarsson
De versie van Skype die beschikbaar is in de Canonical Partner Repository is nu bijgewerkt. - Christopher Kyle Horton
wil gewoon zeggen dat het installeren van deze versie van skype de "can not sign problems" voor versie 4.2 op linux oplost ... - belun
help.ubuntu.com/community/Skype - phillipsk


antwoorden:


Stap 1: vorige versie verwijderen.

sudo apt-get remove skype skype-bin:i386 skype:i386
sudo apt-get install sni-qt:i386

Het is belangrijk dat u oudere versies van Skype op uw Ubuntu installeert, Wis de oude Skype-map voordat u de nieuwste versie installeert. Wis dat dan met behulp van:

rm -rf ~/.Skype

Stap 2: Voorbereiden op het installeren van Skype.

  • Gebruikers van 64-bits Ubuntu moeten inschakelen multiarch als dit nog niet is ingeschakeld door de opdracht uit te voeren

    sudo dpkg --add-architecture i386
    
  • Lijst met repositories en "updates bijwerken":

    sudo apt-get update
    
  • Optioneel, installeren GDebi (zie hieronder):

    sudo apt-get install gdebi #(read Why you need to install gdebi...)
    

Stap 3: Skype installeren

Methode 1: downloaden en installeren vanuit bestand

wget download.skype.com/linux/skype-ubuntu-precise_4.3.0.37-1_i386.deb
sudo gdebi skype-ubuntu-precise_4.3.0.37-1_i386.deb

Methode 2: Installeer Skype van Canonical Partner Repository

Voeg dus de Canonical Partner Repository toe aan de lijst "updates" door de opdracht te volgen:

sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"

Installeer vervolgens Skype via de Software-Center of via de Terminal.

sudo apt-get update && sudo apt-get install skype

bron


Waarom u gdebi moet installeren in plaats van dpkg of Ubuntu-softwarecentrum te gebruiken.

dpkg (voor Debian-pakket) is een softwaretool van de opdrachtregel die verantwoordelijk is voor het installeren, maken, verwijderen en beheren van Debian (packets deb), het type pakket dat door Ubuntu wordt verwerkt. Het maakt ook het Debian-pakketbeheer mogelijk van bronnen buiten de apt-repositories.

Om pakketten te installeren, dpkg heeft een grafische interface, gdebi , kunt u gebruiken als u liever de opdrachtregel vermijdt.

gdebi is een applicatie-installatie en beheer van Debian (.deb) -pakketten. Dit hulpprogramma werkt zowel in de grafische modusconsole als de installatie van pakketten buiten APT-stortingen: vanaf een website, CD-ROM, draagbare media, enz. Het heeft dezelfde functionaliteit als apt-get of Ubuntu Software Center : het zorgt ervoor dat het te installeren pakket compatibel is met de versie en architectuur van het Ubuntu-systeem waarin u het probeert te installeren en zorgt er ook voor dat aan alle afhankelijkheden die het pakket vereist, is voldaan. Anders worden de afhankelijkheden van internet gedownload. Gebruik van tabbladen, gdebi biedt ook toegang tot belangrijke informatie, zoals mappaden om de verschillende bestanden van .deb-pakket te installeren.

Tenslotte gdebi is een lichtgewicht deb-pakket-installatieprogramma dat de standaard was in Ubuntu Desktop. Nu gebruikt Ubuntu Ubuntu Software Center dat traag is en soms krijg je The package is of bad qualityfout.


Lees meer over GDebi:

Om een ​​pakket te installeren dat u van een website hebt gedownload in plaats van vanuit een softwarerepository. Deze pakketten worden .deb-bestanden genoemd. Omdat ze mogelijk zijn gemaakt voor een andere Linux-distributie, is het mogelijk dat er afhankelijkheidsproblemen zijn met Ubuntu, wat betekent dat ze mogelijk niet kunnen worden geïnstalleerd.

gdebi is een eenvoudige tool om .deb-bestanden te installeren. Het heeft een grafische gebruikersinterface maar kan ook in uw terminal worden gebruikt. Hiermee kunt u lokale deb-pakketten installeren het oplossen en installeren van de afhankelijkheden. Het controleert automatisch pakketten op hun afhankelijkheden en zal proberen om ze te downloaden van de Ubuntu-software repositories indien mogelijk. U moet mogelijk eerst installeren gdebi - installeer eenvoudig de gdebi pakket met een van de pakketbeheerders zoals dkpg, Synaptic of open een terminal en typ sudo apt-get install gdebi. Als je eenmaal hebt geïnstalleerd gdebi, gebruik de bestandsbrowser om het pakket te vinden dat u wilt installeren.

Dubbelklik op het pakket om het te openen gdebi. Als aan alle afhankelijkheden voor het geselecteerde pakket is voldaan, klikt u gewoon op Install package knop om het te installeren. gdebi  zal je waarschuwen als er niet-afhankelijke afhankelijkheden zijn, wat betekent dat er afhankelijkheden zijn die niet zijn opgelost in de repository's die je gebruikt.


235
2018-06-25 14:13



Ik heb iets overschreven, wat niet moet. apt-get install -f -o Dpkg::Options::="--force-overwrite" libqtwebkit4:i386 en het bevestigde de installatiefout die ik ontving als gevolg van afhankelijkheidsprobleem. - Mayura
Waarom de noodzaak om te installeren gdebi? Het Ubuntu Software Center of dpkg -i, die beide al zijn geïnstalleerd, kunnen .deb-bestandinstallaties aan. - Christopher Kyle Horton
@KasiyA Ik snap nog steeds niet waarom je dat zou doen nodig hebben om gdebi te installeren. Uw antwoord luidt gewoon als "het is comfortabeler dan dpkg en sneller dan Software Center". Dat is misschien waar, maar het is persoonlijke voorkeur. Je laat het klinken als gdebi is essentieel voor het uitvoeren van Skype 4.3. - us2012
Dit gaf me een fout bij mijn installatie van 12.04 x64: sudo dpkg --add-architecture i386, maar de rest werkte prima. - Andrejs Cainikovs
Ter informatie: dit zal ook het populaire Skype-pictogram voor de taakbalk creëren voor eenvoudige toegang, terwijl de "normale" installatie via Ubuntu-softwarecentrum dat niet zal doen. - Sliq


Installeren vanuit Ubuntu Software Center

Vanaf 2 augustus 2014 kunt u Skype 4.3 nu rechtstreeks vanuit het Ubuntu Software Center installeren.

Hiertoe moet u eerst de Canonical Partner Repository inschakelen met behulp van de volgende stappen (gebaseerd op de stappen die door OMG! Ubuntu zijn verstrekt; zie bron):

  • Zoek en open 'Software Sources' of 'Software & Updates' in de Unity Dash
  • Selecteer het tabblad 'Andere software'
  • Vink de vakjes aan naast de twee items met de naam 'Canonical Partners'
  • Sluit af en klik op 'OK' in de prompt voor het opnieuw laden van software

Zoek vervolgens naar Skype in het Ubuntu Software Center en installeer het zoals u met andere software zou doen.

(Bron)

Installeren vanaf de Skype-website

U kunt de nieuwste versie van Skype als een .deb-pakket downloaden rechtstreeks van zijn website. Kies de versie 12.04 (multiarch) als u Ubuntu 12.04 LTS of nieuwer gebruikt; het werkt nog steeds als u op 14.04 LTS werkt, want dat is precies wat Microsoft noemt als de minimale Ubuntu-versie.

Zodra u het hebt, voert u de volgende opdrachten uit om ervoor te zorgen dat uw systeem vrij is van eerdere installaties:

sudo apt-get remove skype skype-bin:i386 skype:i386

Dubbelklik vervolgens op het gedownloade .deb-bestand om het te openen in het Ubuntu Software Center en installeer het zoals bij elke andere software.

Voer daarna ook de volgende opdracht uit in de terminal om ervoor te zorgen dat ondersteuning voor het indicatormenu beschikbaar is:

sudo apt-get install sni-qt:i386

Nu kun je Skype in het dashboard vinden, uitvoeren en ervan genieten!

(Bron: WebUpd8)


60
2018-06-25 14:20



Is "Software Sources" doorzoekbaar vanuit de Dash? Ik zou hebben gezegd: druk op Alt + F2 en voer de opdracht software-properties-gtk uit - Gunnar Hjalmarsson
Inderdaad, op Ubuntu 14.04 lijkt het erop dat de optie die je echt wilt "Software & Updates" is (hoewel die query het wel als een optie oproept). Een antwoord bijwerken om dit te weerspiegelen. - Christopher Kyle Horton
OK; eigenlijk had ik (om een ​​onbekende reden) een lokaal desktopbestand met "NoDisplay = true", dus ik heb het helemaal niet in de Dash gezien. Ik heb dat bestand gewoon verwijderd. Sorry voor het lawaai. ;) - Gunnar Hjalmarsson
Na het installeren met een van de bovenstaande methoden, kan Skype vastlopen na het inloggen. Daarvoor moet je ~ / .Skype laten vallen en dan inloggen. Het zal perfect zijn. - Tanvir Ahmad
@tonygil Ik heb niet geprobeerd 4.3 te installeren vanuit het Software Center, maar ik heb met succes Skype 4.3 op meerdere Ubuntu-computers geïnstalleerd met behulp van de laatste methode. Zorg ervoor dat je de nieuwste versie van het .deb-bestand hebt. - Christopher Kyle Horton