Vraag lib32bz2-1.0 ontbreekt op 16.04 [duplicaat]


Deze vraag heeft hier al een antwoord:

Ik heb geprobeerd dit pakket te installeren (benodigd voor Android studio).

Dit is de fout die ik krijg

E: Unable to locate package lib32bz2-1.0
E: Couldn't find any package by glob 'lib32bz2-1.0'
E: Couldn't find any package by regex 'lib32bz2-1.0'

Ik heb het al geprobeerd:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install lib32bz2-1.0

&

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install lib32bz2-1.0:i386

Ik heb ook gezocht http://packages.ubuntu.com en vond het niet lib32bz2-1.0 voor Ubuntu 16.04. Dus hoe krijg ik dit pakket dat beschikbaar is voor betrouwbaar en nauwkeurig?


4
2018-05-20 08:45


oorsprong




antwoorden:


Het schema voor naamgeving lib32bz2 suggereren een zeer oude stijlmanier om het naast elkaar bestaan ​​van meerdere architecturen op hetzelfde systeem te beheren. Gebruik het pakket libbz2-1.0:i386 in plaats daarvan.


9
2017-07-18 06:38





Ik vond een oplossing voor 16.04 op https://stackoverflow.com/questions/29916379/unable-to-run-mksdcard-tool-during-android-studio-installation-on-ubuntu-15-04/39567843.

sudo apt-get install libz1:i386 libncurses5:i386 libbz2-1.0:i386 libstdc++6:i386

1
2017-09-19 07:47