Vraag Toetsenbordvergrendeling in IntelliJ IDEA op Ubuntu 14.04


Kan je me helpen met een rare kwestie? Ik gebruik Intellij IDEA 13 op Ubuntu 14.04 en van tijd tot tijd sluit mijn toetsenbord (ja, helemaal, het gaat niet om snelkoppelingen) zich vast in IDEA. Ik kan nog steeds alles doen wat ik wil in IDEA met mijn muis, ik kan ook overal het toetsenbord gebruiken behalve IDEA. En het kan alleen worden opgelost door IDEA tot nu toe opnieuw op te starten.

Kan iemand een hint geven alstublieft?


165
2017-07-24 06:58


oorsprong


Kan het zijn dat je toetsenbord gewoon door een veld in IntelliJ wordt vastgelegd? Is het een willekeurig iets of triggert iets specifieks het? - Ruraj
Ik denk niet dat een bepaald veld zo'n toetsenbord kan vastleggen, maar ik zal het de volgende keer nauwkeuriger controleren. En het lijkt willekeurig te zijn. - Treble Snake
Mijn collega en ik ervaren precies hetzelfde (dezelfde OS en IntelliJ 13.1.4). Ik moet IntelliJ eenmaal per paar uur opnieuw opstarten (ik kan Alt-F4 echter wel gebruiken) - uiterst irritant. Ik vind het ook heel willekeurig gebeuren. De laatste keer dat ik bezig was met het bewerken van een HTML-bestand. Niet tijdens het indrukken van een snelkoppeling. - Halle Knast
Ik had twee instanties van IntelliJ die liepen en ze bevroor beiden. Weet niet of het relevant is, maar wanneer ik de IDE sluit, kost het ontkoppelen van een draaiende applicatieserver meestal erg weinig tijd. Na een bevriezing gebeurt, moet ik annuleren omdat het niet lijkt te eindigen. - Halle Knast
Dit is een Java-probleem dat andere Java Swing GUI's, inclusief SOAP UI, beïnvloedt. "ibus-daemon -rd" lost het probleem ook op - rjdkolb


antwoorden:


Er is een een open vraag in jetbrains youtrack voor intellij idea die twee oplossingen aanbevelen:

  1. Toetsenbordinvoer kan worden ontgrendeld door IBus-daemon opnieuw te starten vanaf een console:

    ibus-daemon -rd
    
  2. IBus kan worden uitgeschakeld voor IDEA door env uit te schakelen. variabele XMODIFIERS, maar het vermogen om nationale karakters in IDEA in te voeren zal verloren gaan:

    XMODIFIERS="" idea.sh
    

Ik heb de tweede gebruikt en mijn probleem opgelost.


206
2017-10-18 16:50



> "ibus-daemon -rd" vanaf een console. Dat werkte! Heel erg bedankt!) - Treble Snake
6 maanden later wordt optie 1 niet langer aanbevolen, omdat dit JVM-crash kan veroorzaken: / - mike
Wat bedoel je met nationale karakters, @Mike, het werkte voor mij vandaag, op 2 juni - Abderrahmane TAHRI JOUTI
"ibus-daemon -rd" - Ik overweeg serieus om dit op mijn arm te tatoeëren. - Balázs Mária Németh
Laatste update van het probleem (17 juni 2015) beveelt aan export IBUS_ENABLE_SYNC_MODE=1 - Nacho Coloma


Ik was in staat om het op te lossen met wat ik vond hier dat is eigenlijk toevoegen export XMODIFIERS="" op idea.sh


14
2018-03-05 16:45



lijkt hier te werken! - Marc Hauptmann


Voor een permanente oplossing, de  01 oktober 2015 update over het probleem beveelt aan om:

Upgrade IBus naar versie 1.5.11 of voeg toe export IBUS_ENABLE_SYNC_MODE=1 aan jouw ~/.profile, herstart dan een sessie.

Als alternatief kunt u IBus uitschakelen op System Settings | Language Support | Keyboard input method.

IDEA 15 zal een waarschuwing weergeven als een incompatibele versie van IBus in gebruik is.


5
2017-11-30 11:53





Ik heb dit geprobeerd en het werkt tot nu toe maar ik zal updaten als het weer bevriest. Ik heb een suggestie gezien op youtrack die suggereert iBus uit te schakelen, wat lijkt te interfereren, vooral vanwege het gebruik van de ctrl + spatie-snelkoppeling om de taalinstellingen te veranderen. U kunt dat doen door naar:

taalondersteuning> toetsenbordinvoermethode> geen

enter image description here

**** BIJWERKEN *****

Nadat ik het een tijdje had gebruikt, werkte deze techniek nog steeds niet, omdat ik bleef bevriezen. Ik denk dat ik voorlopig zal vasthouden aan de volgende oplossing om IBM opnieuw op te starten, wat een beetje lastig is, maar wat kun je doen.

ga naar terminal

type:

ibus-daemon -rd

1
2018-04-05 00:33



bedankt, ibus-daemon -rd is wat ik zocht. - Lambart