Vraag Start autofs bij het opstarten


ik heb autofs alle setup, en het correct mounts mijn gedeelde mappen.

Op dit moment moet ik echter handmatig starten sudo upstart autofs start na elke opstart, voordat de automounting daadwerkelijk werkt.

ik denken in geïnstalleerd autofs handmatig via synaptic, hoewel het een tijdje geleden is. De computer in kwestie wordt gebruikt als een lichtgewicht server en wordt zelden opnieuw opgestart, dus het handmatig starten van een service is niet zo'n groot probleem, maar mijn back-ups werken pas als autofs wordt uitgevoerd, dus ik maak me zorgen.


5
2017-10-24 14:07


oorsprong


Ik kan niet helpen, maar ik kan dat bevestigen autofs van de repositories is zeker automatisch gestart bij inloggen / opstarten en zal alles wat het in /etc/auto.master ziet automatisch koppelen. - Scaine
@Scaine - Nou, verdomme als ik weet wat er aan de hand is, dan. Misschien was het verpakt in de xubuntu-installatie en net niet ingeschakeld totdat ik het heb ingesteld. - Fake Name
Ik zou autofs opnieuw installeren via synaptic, maar het helemaal niet werken, was een enorme pijn, en ik weet niet of een re-install mijn configuratiebestanden zou bedotten. Eerlijk gezegd, gezien hoeveel een volledige PITA was om te werken, wil ik echt niet autofs zelf aanraken, uit angst om het te verbreken. - Fake Name
Het grootste deel van de configuratie voor autofs is gewoon /etc/auto*.*. Je hebt een hoofdbestand, twee of drie scripts (auto.smb, auto.net en dergelijke) en voor elke netwerkshare heb je auto.smb.SERVERNAME of iets dergelijks. Het moeten (grijn) wees relatief gemakkelijk om een ​​back-up te maken en herstel vervolgens! Zou moeten zijn... - Scaine
Iedereen? Dit is nog steeds een probleem voor mij .... - Fake Name


antwoorden:


Voeg dit toe aan /etc/rc.local

Met behulp van een editor:

grafisch

gksu gedit /etc/rc.local

Opdrachtregel

sudo -e /etc/rc.local 

voeg het volgende toe of bewerk het:

#!/bin/sh -e
#
# rc.local 
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

service autofs start &

mount -a

exit 0

Je kunt daar waarschijnlijk wat aan verbeteren, een slaap van 4 60 seconden is waarschijnlijk overdreven, ik zou er een proberen en het aantal verhogen indien nodig.

Maak het uitvoerbaar

sudo chmod u+x /etc/rc.local

Start opnieuw op en het zou moeten werken. Als dat niet het geval is, probeert u een slaap toe te voegen volgens het onderstaande bugrapport.

Zie ook Bug report


4
2017-12-08 23:34



Ik denk dat de herstarts misschien niet nodig zijn. Alles wat ik moet doen om te krijgen autofs Normaal werken is een kwestie van a sudo service autofs start. Het probleem is niet dat het faalt, het is dat het nooit begint. Hoe dan ook, ik zal dit proberen als ik later thuis kom van mijn werk. - Fake Name
Ik ben het ermee eens, het begin ... slaap ... herstart ... slaap ... lijkt overdreven, waarschijnlijk geschreven in frustratie, maar waarschijnlijk na een korter script faalt. Probeer het en u kunt het natuurlijk optimaliseren voor uw behoeften. - Panther
Heeft u nog steeds hulp nodig? - Panther
Nee, dat deed het. Ik heb net gezet service autofs start in rc.local, zonder slaap of herhalingen. Ik vraag me nog steeds af hoe ik autofs heb geïnstalleerd zonder dat het is ingesteld om te starten. - Fake Name
Bedankt voor het reageren op de vereiste voor de slaap. Ik zal mijn antwoord herzien. Voor zover het niet uit de doos werkt, ja het is een bug. Mijn gok is dat autofs te snel wordt uitgevoerd, zonder te wachten tot een service is voltooid. - Panther