Vraag Hoe schakel ik de gastsessie uit?


Hoe schakel ik de gastsessie uit in Ubuntu 11.10 of hoger? Ik wil niet dat mensen mijn computer kunnen gebruiken zonder een wachtwoord te gebruiken om in te loggen!


181
2017-09-22 15:45


oorsprong


Kun je niet echt een use case bedenken waarbij je het gastaccount wilt uitschakelen? : P In mijn geval, ben ik de enige die op mijn pc werkt, dus het heeft geen zin voor mij om deze te activeren. En ik kan ook andere scenario's bedenken, maar zou van het begin af gaan denk ik :) - Nejest
@mikewhatever - LightDM is een desktopmanager, geen beveiligingsmanager. Het als geen bedrijf doet iets met beveiliging en gebruiker gerelateerd. Het verbreken van het Unix-beveiligingsmodel zou voldoende moeten zijn. Maar als dat niet het geval is, probeer dan te zoeken naar de beveiligingsgerelateerde bugrapporten. Mensen blijven per ongeluk uit de Unity / LightDM-sandbox (ik heb er zelf ten minste twee ingediend). Wat denk je dat een aanvaller zou kunnen doen?


antwoorden:


Bijgewerkt: 2016-aug

Voor Ubuntu 16.04 LTS (15.10 of later)

Aangepast van: LightDM Ubuntu Wiki - configuratie

  • Door het systeem geleverde configuratiebestanden in /usr/share/lightdm/ zijn niet bedoeld om door de gebruiker te bewerken zijn. In plaats daarvan zouden gebruikers moeten gebruiken: /etc/lightdm/
  • Nieuwere versies van LightDM (Ubuntu 15.10 of later) gebruiken [Seat:*] in plaats van [SeatDefaults]

Voer dit (eenmalig) uit op de terminal:

sudo sh -c 'printf "[Seat:*]\nallow-guest=false\n" >/etc/lightdm/lightdm.conf.d/50-no-guest.conf'

Om ongedaan te maken (herstel de optie Gast), verwijder het gecreëerde bestand:

sudo rm /etc/lightdm/lightdm.conf.d/50-no-guest.conf

Voor Ubuntu 14.04 LTS (tot 15.04)

Aangepast van: Ubuntu Forums - lightdm config bestanden locatie in 14.04

Voer dit (eenmalig) uit op de terminal:

sudo sh -c 'printf "[SeatDefaults]\nallow-guest=false\n" >/usr/share/lightdm/lightdm.conf.d/50-no-guest.conf'

U heeft niet langer 'Gast' als aanmeldingsmogelijkheid bij uw volgende aanmelding.

Om ongedaan te maken (herstel de optie Gast), verwijder het gecreëerde bestand:

sudo rm /usr/share/lightdm/lightdm.conf.d/50-no-guest.conf

Voor Ubuntu 12.04 LTS (tot 13.10)

Eenvoudigste methode.

Voer dit (eenmalig) uit op de terminal:

sudo /usr/lib/lightdm/lightdm-set-defaults -l false

U heeft niet langer 'Gast' als aanmeldingsmogelijkheid bij uw volgende aanmelding.

  • Dit voegt eenvoudig toe allow-guest=false naar /etc/lightdm/lightdm.conf.

  • Zou moeten werken 11.10 verder (sinds deze gebruiken lightdm ook).

Om ongedaan te maken (herstel Gast-optie):

sudo /usr/lib/lightdm/lightdm-set-defaults -l true

117
2017-07-27 23:38



Dit werkt voor mij op 13.10. - wim
Werkte voor mij op 14.04 beta 2. BTW, SeatDefaults is geen spelfout, verander het niet naar SetDefaults. - Nitish Parkar
Dit werkte voor mij op Xubuntu 14.04.1 LTS. Ik zou echter deze zin corrigeren: "Bij uw volgende aanmelding heeft u niet langer de 'Gast' als login-optie. ' In feite bleef het tot lightdm is opnieuw gestart in mijn geval. - Melebius
Onnodige citaten in de laatste bewerking; alsjeblieft zie help.ubuntu.com/stable/ubuntu-help/... Ook de /etc/lightdm/lightdm.conf.d map wordt pas automatisch gemaakt in 16.04.1, dus in eerdere versies moet deze worden gemaakt voordat de opdracht wordt uitgevoerd (sudo mkdir /etc/lightdm/lightdm.conf.d). - Gunnar Hjalmarsson
Werkte voor 16.04, hoewel moet herstart lightdm om deze wijziging toe te passen (let op: hiermee wordt ook uw huidige sessie beëindigd): sudo /etc/init.d/lightdm restart - Jeff Ward


Gebruik deze methode alleen als u Ubuntu Desktop gebruikt. Als u een andere smaak zoals Xubuntu of Lubuntu gebruikt, raadpleegt u dit antwoord in plaats daarvan.

Als u de standaard LightDM gebruikt, bewerk dan /etc/lightdm/lightdm.conf zodat het er zo uitziet:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

Als u GDM gebruikt (dit was de standaard in vorige Ubuntu-releases), verwijder dan de installatie gdm-guest-sessie.


Voor Ubuntu 13.10 naar 14.10, het bestand is verplaatst naar /etc/lightdm/lightdm.conf.d/50-unity-greeter.conf

Voor Ubuntu 14.10 of hoger, het bestand is verplaatst naar /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf


115
2017-09-22 15:48



Het antwoord lijkt te zijn verouderd voor 13.10 - wim
De instructies zijn hetzelfde voor 13.10, behalve dat het bestand is verplaatst naar: /etc/lightdm/lightdm.conf.d/50-unity-greeter.conf - Andrew Ensley
@Andrew: het is logischer om een ​​nieuw bestand te maken, bijvoorbeeld /etc/lightdm/lightdm.conf.d/50-no-guest.conf. De optie allow-guest is niet specifiek voor een eenheid. - Gunnar Hjalmarsson
Ubuntu 14.04: Ik vond het .conf hier: /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf . Om het bestand te vinden dat ik heb gebruikt locate - Charles
Werkt ook in levendige (15.04), met config in /usr/shareook. - setempler


Typ dit in de terminal

gksu gedit /etc/lightdm/lightdm.conf

U ziet het volgende:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu

Toevoegen allow-guest=false tot het einde, zodat uw eindresultaat er als volgt uit zou moeten zien:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

Sla het document op en sluit de teksteditor.

Terug in de Terminal, herstart de display manager. (Hiermee beëindigt u de grafische aanmeldingssessie en sluit u onmiddellijk alle programma's die erop worden uitgevoerd. Zorg er dus voor dat uw werk - net als bij geopende documenten - eerst wordt opgeslagen!)

sudo restart lightdm

Nadat de grafische aanmeldingssessie is beëindigd, keert u terug naar het inlogscherm, waar u merkt dat gastaccount is uitgeschakeld.

Dat is het - het gastenaccount is niet meer bruikbaar.


24
2017-10-25 01:08





U kunt dat doen met Ubuntu Tweak.

Gebruik deze opdrachten om het te installeren:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

Na het installeren, navigeer naar tweaks → Aanmeldingsinstellingen en schakel de "Gastaccount" uit.

ubuntu tweak login settings


17
2017-10-21 17:54



Leuke vondst, en trouwens, Ubuntu Tweak gaat door. - mikewhatever
Wauw! geweldig om te weten, @mikewhatever! (dat was snel, hij heeft ons veel gemist ...) - Eliran Malka


Ren gewoon

gksudo gedit /etc/lightdm/lightdm.conf

Voeg de volgende regel toe

allow-guest=false

Dan (dit zal u meteen uitloggen, alle programma's verlaten die in uw grafische sessie worden uitgevoerd, dus sla uw werk eerst op):

sudo restart lightdm

11
2017-07-27 16:42





Hoe deze optie in de toekomst uit te schakelen

Ik kwam net hetzelfde probleem tegen met mijn nieuwe vertrouwde / 14.04-installatie. Tot mijn verrassing kon ik het ook niet vinden lightdm.conf.d map binnen /etc/lightdm/ net users.conf.

Onderzoek

$ find / -iname *lightdm* 2>/dev/null | grep -v /mnt | grep -v /media | grep -v /home
[...]
/usr/share/lightdm/lightdm.conf.d
[...]

Aha, daar ben je. Wat zit daar in?

$ ls -1 /usr/share/lightdm/lightdm.conf.d/
50-greeter-wrapper.conf
50-guest-wrapper.conf
50-ubuntu.conf
50-unity-greeter.conf
50-xserver-command.conf

Oké, wat zit daar in?

$ cat /usr/share/lightdm/lightdm.conf.d/*
[SeatDefaults]
greeter-wrapper=/usr/lib/lightdm/lightdm-greeter-session
[SeatDefaults]
guest-wrapper=/usr/lib/lightdm/lightdm-guest-session
[SeatDefaults]
user-session=ubuntu
[SeatDefaults]
greeter-session=unity-greeter
[SeatDefaults]
# Dump core
xserver-command=X -core

Conclusie

We vinden een aantal configuratiebestanden die lijken op de INI-indeling volgens het naamschema van 50-${some-descriptive-name}.conf en het configureren van sleutels voor de sectie [SeatDefaults].

We gaan deze bestanden niet bewerken omdat deze door de pakketbeheerder moeten worden beheerd, maar nu hoe we onze moeten toevoegen en beheren aangepaste configuratiebits naar /etc.

Oplossing

Gezien het bovenstaande is dat lightdm de display-manager en de configuratiebestanden lijken op het bovenstaande. De volgende oplossing zou moeten werken:

  1. Maak de ontbrekende mappen aan:

    $ sudo mkdir -p /etc/lightdm/lightdm.conf.d
    
  2. Voeg een aangepast configuratiebestand toe door te draaien:

    $ sudo nano /etc/lightdm/lightdm.conf.d/50-disable-guest-session.conf
    

    en plak de volgende regels:

    [SeatDefaults]
    allow-guest=false
    

    Sla dan op (Ctrl+O) en sluiten (Ctrl+X).

  3. Log nu uit en schakel over naar een virtuele terminal (Ctrl+alt+F1), voer dan uit:

    $ sudo service lightdm restart
    

    De gastsessie-optie zou nu verdwenen moeten zijn. Als iets niet goed werkt, weet je nu waar de standaardconfiguratie is opgeslagen en dat je het niet hebt gewijzigd.

Verder lezen


4
2018-03-16 02:32



Of, als u geen extra bestand wilt maken, plaatst u het in de bestaande /etc/lightdm/lightdm.conf - tombert


Voor Ubuntu 13.10, voeg toe

allow-guest=false

naar het bestand /etc/lightdm/lightdm.conf.d/10-ubuntu.conf.


3
2017-10-20 13:27





13.04 en later

  1. Voer deze opdracht uit in een terminal

    sudo /usr/lib/lightdm/lightdm-set-defaults -l false
    
  2. Start uw computer opnieuw op of start opnieuw op lightdm met het volgende commando
    (Hiermee wordt u onmiddellijk afgemeld, uw gegevens worden opgeslagen)

    sudo restart lightdm
    

Blijkbaar werkt het in 13.10 (kan mezelf niet testen, maar er is een opmerking hier).

Ik gebruik 13.04 en dit alles wordt toegevoegd allow-guest=false naar /etc/lightdm/lightdm.conf, maar het kan anders zijn in 13.10.

Oorspronkelijk door David 6 vanaf hier: https://askubuntu.com/a/169105/176889


3
2017-10-21 07:33



Bedankt. Het creëerde een lightdm.conf-bestand, hetzelfde als bij jou, met allow-guest = false erin. - 11chubby11
Je zou ook moeten doen sudo restart lightdm om de wijzigingen door te voeren. Zonder dat zal de gastsessie nog steeds worden vermeld op het inlogscherm wanneer u uitlogt. - Burhan Ali


Installeer ubuntu-tweak, ga naar het tabblad aanpassen, zet de gast-knop uit en start opnieuw op. Dat is het!

Men kan de terminal gemakkelijker vinden, maar in het geval dat de noodzaak om de gastaccount aan te zetten zich voordoet, zou men deze pagina opnieuw moeten bezoeken en de instructies moeten zien (of liever ongedaan moeten maken). Dat is het voordeel van het GUI-ding ... eentje herinnert het zich gemakkelijk.


2
2017-09-27 17:33





Verandering allow-guest=true naar 'false' in /etc/lightdm/lightdm.conf

U kunt vervolgens de service opnieuw opstarten of opnieuw starten in de terminal:

sudo restart lightdm

Ervan uitgaande dat u gebruikt lightdm welke is standaard- in 11.10.


2
2017-10-21 10:42





Ik zit in hetzelfde geval, het bestand /etc/lightdm/lightdm.conf bestaat niet in UBUNTU 13.10.

Ik probeer het te maken /etc/lightdm/lightdm.conf bestand met deze regel allow-guest=falseen CRASH start het systeem niet goed, alleen de consolemodus ...

Ik probeer het bestand te bewerken /etc/lightdm/lightdm.conf.d/10-ubuntu.conf, en werkt naar behoren.

Bewerk het bestand

sudo vim /etc/lightdm/lightdm.conf.d/10-ubuntu.conf

En voer de regels in die je nodig hebt

# to disable guest login
allow-guest=false
# to enable user login manually
greeter-show-manual-login=true

En de laatste, herstart je systeem

sudo reboot

Ik denk dat dit prima werkt als je alleen de ligthgdm herstart

sudo service lightdm restart

0
2017-10-23 14:05