Vraag Ubuntu 14.04 helderheidsprobleem (Lenovo Z500)


Mijn helderheidsregeling werkte niet eerder, maar het kon me niet echt schelen, maar op de een of andere manier verlaagde ik mijn schermhelderheid tijdens het downloaden van een competitie via playonlinux. Nu werken de helderheidsregelaars niet met de FN toetsen of in de instellingen, en zijn vastgelopen op zeer laag.

Ik heb dit geprobeerd http://itsfoss.com/fix-brightness-ubuntu-1310/en alles hier https://sites.google.com/site/easylinuxtipsproject/display, maar ze hebben niets gedaan.

Ik gebruik een Lenovo Z500 met grafische kaarten van Intel. Ik heb een Nvidia GeForce GT 635M maar gebruik deze niet.

Ik heb gemerkt dat er de mappen zijn ideapad, intel_backlight en thinkpad_screen in /sys/class/backlight/, elk met de bestanden actual_brightness, brightness, en max_brightness. Alleen in intel_backlight is actual_brightness ingesteld op de maximale waarde. Er staat echter dat ik niet de toestemming heb om ze te veranderen sudo.


Tijdelijke oplossing: ik heb helderheid hersteld door de helderheid te gebruiken FN toetsen buiten Ubuntu (voordat het begint of in de BIOS-instellingen), maar nog steeds wanneer ik op een van de helderheidsknoppen druk, wordt het erg zwak en kan het niet worden gewijzigd.


5
2018-01-18 10:58


oorsprong


xbacklight -set 100 zou moeten werken - kenn
nee, dat heb ik geprobeerd, het doet niks - Toby
Als je het antwoord zelf hebt gevonden, plaats dan je oplossing als een antwoord en markeer het als geaccepteerd. - LiveWireBT
je kunt dit proberen. xrandr --output LVDS1 --brightness 0.8 - BKS
@neoFox Het verandert niets aan de werkelijk helderheid. - Hi I'm Frogatto


antwoorden:


Twee jaar geleden kocht ik deze laptop die redelijk goed werkt met Linux. Toen ik een upgrade uitvoerde naar mijn nieuwe distro, Elementary OS Freya, merkte ik het probleem op dat achtergrondverlichting niet kon veranderen. Ik zou het alleen op het grubscherm kunnen veranderen. Na het uitproberen van elke gids op het internet loste ik het probleem gedeeltelijk op door de kernel (en het bijbehorende Intel grafische stuurprogramma) naar versie 3.13 te downgraden. Gisteren gaf ik nog een keer proberen. Het had veel geluk :)

Hier de oplossing:

Op het GRUB-configuratiebestand /etc/default/grub wijzig de volgende regel:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

door deze string toe te voegen: acpi_backlight=vendor.

In mijn geval is het:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Update grub door te starten:

sudo update-grub

Maak vervolgens een xorg-configuratiebestand zoals dit:

/usr/share/X11/xorg.conf.d/80-backlight.conf

en kopieer hierin deze tekst:

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"     "sna"
    Option      "Backlight"       "ideapad"
    BusID       "PCI:0:2:0"
EndSection

Bewaar het bestand, reboot, Genieten :-)

Deze truc zou kunnen werken op andere Lenovo Ideapad-laptops. Ik heb getest op Lenovo Ideapad z500 op Elementary OS Freya en Debian 8 Jessie.

Als je een andere laptop hebt, kun je het op deze manier proberen: Wijzig grub zoals in het eerste deel van de gids, werk GRUB bij, start opnieuw op en controleer vervolgens welke achtergrondverlichtingsstuurprogramma's (ik weet niet wat ze zijn) worden weergegeven. Geven:

ls /sys/class/backlight/

en als het geeft:

backlight_driver1
backlight_driver2
backlight_driver3

Maak vervolgens het xorg-bestand met een van de stuurprogramma's in de lijst:

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"     "sna"
    Option      "Backlight"       "backlight_driver1"
    BusID       "PCI:0:2:0"
EndSection

En herstart. Als het werkt, geniet van, anders wijzig het bestand met een ander in de lijst op dezelfde manier.


6
2018-02-10 10:19



Op sommige laptops is de eerste stap voldoende om dit te verhelpen. - Błażej Michalik


Je zou dit kunnen proberen

  1. Toevoegen GRUB_CMDLINE_LINUX="acpi_backlight=vendor" naar /etc/default/grub.
  2. Update grub en start opnieuw op. uitvoeren sudo update-grub && reboot.

1
2018-01-18 11:05



Nee, er is niets veranderd. - Toby