Vraag Hoe libdb4.8 ++ - dev of equivalent te installeren op 13.10?


Ik probeer een mod te testen die ik van Peercoin heb gemaakt.

Ik moet installeren libdb4.8++-dev, maar het is niet beschikbaar.

Hoe kan ik het of een equivalent installeren?

Notitie: dit is geen dupe omdat ik geen pakket met mijn aangepaste wijziging van Peercoin kan installeren.


5
2017-12-20 02:05


oorsprong




antwoorden:


Van nullnoname antwoord. Dit is wat ik deed voor ubuntu 16:

sudo add-apt-repository ppa:bitcoin/bitcoin
sudo apt-get update
sudo apt-get install -y libdb4.8-dev libdb4.8++-dev

6
2018-04-24 16:22





Als u absoluut db-4.8 gerelateerde pakketten nodig hebt in Ubuntu 13.10 en nieuwer, kunnen deze worden geïnstalleerd vanaf Bitcoin-team PPA. (ppa: bitcoin / bitcoin)


3
2017-08-15 08:39





Nou, het compileert met libdb++-dev en sudo apt-get install libminiupnpc-dev -y dankzij deze man.

Echter, "Upstream Bitcoin beschouwt db-4.8 als de enige ondersteunde versie. 5.1 is bekend dat het werkt, maar databases zijn incompatibel met officiële builds gemaakt met db-4.8."

Als de mijnbouw, voeg de -detachdb vlag naar ./ppcoin-qt (waarschijnlijk het beste om het toch maar te doen).


1
2017-12-20 05:16





Je zou het ook vanaf de bron kunnen compileren. $ wget 'http://download.oracle.com/berkeley-db/db-4.8.30.NC.tar.gz' $ tar -xzvf db-4.8.30.NC.tar.gz $ cd db-4.8.30.NC/build_unix/ $ ../dist/configure --enable-cxx $ make $ make install

Vertel uw systeem waar te vinden db4.8 $ export BDB_INCLUDE_PATH="/usr/local/BerkeleyDB.4.8/include" $ export BDB_LIB_PATH="/usr/local/BerkeleyDB.4.8/lib" $ ln -s /usr/local/BerkeleyDB.4.8/lib/libdb-4.8.so /usr/lib/libdb-4.8.so


0
2017-11-15 09:15





Vertel uw systeem waar te vinden db4.8:

$ export BDB_INCLUDE_PATH="/usr/local/BerkeleyDB.4.8/include"

$ export BDB_LIB_PATH="/usr/local/BerkeleyDB.4.8/lib"

$ ln -s /usr/local/BerkeleyDB.4.8/lib/libdb-4.8.so /usr/lib/libdb-4.8.so

Na 3 uur googlen gaf ik het bijna op, toen werkte deze voor mij!


0
2018-01-08 02:01