Vraag Het 'terminal-plus'-pakket voor de Atom-editor werkt niet


Ik gebruik de Atom-editor op ubuntu 14.04 LTS 64 bit en ik heb een terminalplus-pakket geïnstalleerd. Ik kan een nieuwe terminal maken, maar ik kan er niet in schrijven zoals je ziet in de onderstaande schermafbeelding

PS: ik weet niet of dit verband houdt met deze fout: Uncaught TypeError: kan eigenschap 'focus' van null niet lezen  wat ik heb.


5
2017-08-12 22:24


oorsprong


De terminal-plus pakket is al een tijdje niet bijgewerkt. Ik vermoed dat dit een fout is in het pakket en waarschijnlijk niet gerelateerd is aan Ubuntu. - edwinksl
Oké, bedankt @edwinksl :) - zeroday
Ik gebruikte het gewoon, maar niet meer. AFAIK, er zijn vergelijkbare pakketten die nog steeds worden bijgewerkt, dus je moet een zoekopdracht uitvoeren. - edwinksl
Ik heb een Atom-pakket ontwikkeld dat als een gehandhaafd substituut dient terminal-plus: terminal-fusion. Het heeft een paar extra thema's en functies. - BH2017
Dit pakket heeft problemen tijdens het installeren. Ik kon het niet laten werken en schakelde uiteindelijk over naar "Platformio-ide-terminal" het kan ook worden aangepast - Pini Cheyni


antwoorden:


De terminal-plus Het pakket wordt niet onthouden met de laatste update die in november 2015 is. Dus ik zou willen adviseren om naar mijn Atom-pakket over te stappen (houd er rekening mee dat dit pakket alleen compatibel is met Linux-platforms, als u een terminalpakket wilt gebruiken voor uw niet-pakket. - Linux-machines alstublieft gebruiken platformio-ide-terminal in plaats daarvan!), terminal-fusion. Om het te installeren, voert u gewoon uit:

$ apm install terminal-fusion --no-confirm

waar $ geeft een gebruikersconsole aan (dat is ook zo niet voer dit commando uit als root!). Ik zou adviseren dat je de-installatie ongedaan maakt terminal-plus eerst via hardlopen:

$ apm remove terminal-plus --no-confirm

Als je graag je waardering voor mijn pakket wilt laten zien, kun je het met meespelen apm, door rennen:

$ apm star terminal-fusion

of bekijk het op GitHub door in te loggen op GitHub en op "Star" te klikken bij de URL https://github.com/fusion809/terminal-fusion.

EDIT: Dit antwoord is nu verouderd. Ik vrees dat terminal-fusion niet langer wordt onderhouden, dus gebruik in plaats daarvan platformio-ide-terminal. Om het te installeren, voer het uit:

$ apm install platformio-ide-terminal --no-confirm

waar is $ is de gebruikersconsole. Om het in de schijnwerpers te zetten en daarmee je waardering te tonen aan de auteur (die ik niet ben, maar ze verdienen toch je waardering):

$ apm star platformio-ide-terminal

10
2017-10-01 06:35



Overweeg om dit antwoord te accepteren en eventueel op te waarderen als u dat leuk vindt. - BH2017
Bedankt Brenton. Begonnen met behulp van platformio-ide-terminal op mijn Mac! (: - Anirudh M