Vraag Hoe Eclipse te installeren?


Ik wil de nieuwste versie van Eclipse installeren, maar het Ubuntu Software Center bevat een oudere versie.

Is er een PPA of een andere manier om de nieuwste Eclipse te installeren? Beschrijf de stappen voor de volledige installatie.


194
2018-02-16 11:54


oorsprong


Heb je geprobeerd het te installeren van USC? - Mitch♦
USC? wat bedoel je daarmee ? Ik ben nieuw bij Ubuntu - Ant's
'Ubuntu Software Center', zoals hieronder getoond. Ik heb Eclipse geïnstalleerd op een paar verschillende computers met behulp van de software center-methode zoals weergegeven - en vervolgens PyDev van binnenuit Eclipse. Werkt glad. - memilanuk
@memilanuk Helaas als je dat doet, moet je een versie verzinnen die bijna 2 jaar oud is. - Jon Bentley
@memilanuk Natuurlijk. Ik heb de data gelezen. Mijn opmerking is niet minder geldig voor iemand die vandaag de draad leest dan toen - het pakket dat verouderd is wordt zelfs genoemd in het OP (in 2011) als de motivatie voor de vraag. Het punt is dat de Ubuntu-repositories geen goede bron zijn voor het verkrijgen van de nieuwste versie van dit specifieke pakket. - Jon Bentley


antwoorden:


Als u Eclipse van hun officiële website hebt gedownload, volgt u deze stappen voor de installatie.

  1. Extraheer de eclipse.XX.YY.tar.gz met

    tar -zxvf eclipse.XX.YY.tar.gz
    
  2. Word root en kopieer de uitgepakte map naar /opt

    sudo mv eclipse.XX.YY /opt
    
  3. Maak een desktop-bestand en installeer het:

    gedit eclipse.desktop
    

    en kopieer het volgende naar de eclipse.desktop het dossier

    [Desktop Entry]
    Name=Eclipse 
    Type=Application
    Exec=env UBUNTU_MENUPROXY=0 eclipse44
    Terminal=false
    Icon=eclipse
    Comment=Integrated Development Environment
    NoDisplay=false
    Categories=Development;IDE;
    Name[en]=Eclipse
    

    en zorg ervoor dat dat zo is uitvoerbare toestemming, voer dan het volgende commando uit om het automatisch in de eenheid te installeren:

    sudo desktop-file-install eclipse.desktop
    
  4. Maak een symlink in /usr/local/bin gebruik makend van

    sudo ln -s /opt/eclipse/eclipse /usr/local/bin/eclipse44
    
  5. Om het eclipse-pictogram in het streepje weer te geven, kan het pictogram van de zonsverduistering worden toegevoegd als

    sudo cp /opt/eclipse/icon.xpm /usr/share/pixmaps/eclipse.xpm
    
  6. Vergeet niet dat je OpenJDK of Sun Java moet hebben om de verduistering te kunnen uitvoeren. Controleren deze vraag voor meer informatie over Java-installatie. Hier is een eenvoudig voorbeeld van het installeren van Open JDK 1.6:

    sudo apt-get install openjdk-6-jdk
    
  7. Start Eclipse en geef het de vereiste rechten om het osgi-bestand te wijzigen:

    sudo chown -R $USER:$USER /opt/eclipse/configuration/org.eclipse.osgi
    

    NB! U moet eerst Eclipse starten, omdat de org.eclipse.osgi map is gemaakt alleen na de eerste lancering.

Dat is het.


242
2018-04-03 00:14



Ik adviseer op die manier, met een kleine wijziging: gebruik de eclipsversie bij het maken van de symlink (bijv .: ln -s /opt/eclipse/eclipse /usr/local/bin/eclipse42), en gebruiken Exec=eclipse42 op het bureaublad. Op die manier kunt u meerdere verschillende versies van eclips installeren. - ortang
Vergeet niet dat je OpenJDK of Sun Java moet hebben om de verduistering te kunnen uitvoeren. Voer sudo apt-get install openjdk-6-jdk uit of bekijk deze link voor Sun Java ubuntugeek.com/... - Andy Braham
Ook vermeldenswaard dat voor 13.10, eclipse.desktop behoefte aan Exec=env UBUNTU_MENUPROXY=0 eclipse zodat de menu's werken per stackoverflow.com/questions/19452390 - TimD
Werkt voor mij behalve /opt/eclipse/configuration/org.eclipse.osgi bestaat niet ... - Gerhard Burger
@GerhardBurger Het lijkt erop dat de map "/opt/eclipse/configuration/org.eclipse.osgi" niet bestaat totdat Eclipse zelf is gelanceerd ... - dtmland


12.04 LTS

De voorkeursmethode: Software Center

  1. Selecteer Eclipse in het Ubuntu-softwarecentrum. Ik heb het Extensible Tool Platform en Java IDE ook geïnstalleerd, maar installeren is optioneel.

    eclipse in software center

  2. Voer uw wachtwoord in het verificatievenster in. Hiermee krijgt u 3.7.1 binnen een pakketbeheersysteem.

Alternatieve opties

De volgende methode die de meeste voorkeur heeft: PPA

Vanaf dit moment heeft het eclipse-team PPA geen eclipspakket voor 12.04. Ik zal het antwoord bijwerken terwijl de dingen zich ontwikkelen.

Wanneer het beschikbaar komt, als je al hebt geïnstalleerd via Software Center:

sudo add-apt-repository ppa:eclipse-team/ppa
sudo apt-get update
sudo apt-get upgrade

De minst geprefereerde methode: draagbaar

Voor een draagbare installatie kunt u nog steeds rechtstreeks downloaden van de Eclipse-website. Dit geeft je de mogelijkheid om verschillende Eclipse-installaties aan te passen voor verschillende talen, bijvoorbeeld CDT, Java en PyDev of Aptana. Automatische updates zijn niet toegestaan. Installeren via Software Center is altijd de voorkeursmethode.

Ik testte de draagbare 3.7.1 en 3.7.2 tar-ballen en ze werken prima op 12.04 LTS.

Een bijkomend nadeel van draagbare installaties is dat je je opstartprogramma moet bijwerken als je de map verplaatst of direct start.


52
2017-11-20 22:12



Ik volgde de "voorkeursmethode", maar nieuwsgierig waarom dit meer de voorkeur heeft dan de anderen? - T. Webster
Doorzoek de site voor vragen over java-apps die niet worden weergegeven in de app-switcher en andere dingen (bijvoorbeeld reproduceerbare problemen). Ik heb deze problemen niet als ik het vanuit repo installeer, maar mensen klagen daar consequent over wanneer een repo-installatie het probleem zou hebben vermeden in plaats van een kaasplateau te vereisen. - RobotHumans
Nou, de voorkeursmethode is zeker netjes voor mij geïnstalleerd. Ik bedank dat ik anders voor de messier-methode zou hebben gekozen - T. Webster
Deze methode is zeker eenvoudiger, hoewel ik het zou combineren met de geaccepteerde antwoordmethode voor de snelkoppeling van de launcher / desktop. - ashes999
@ Seanny123 De PPA is niet bijgewerkt sinds 12.04. Dit antwoord bestaat al een tijdje. - RobotHumans


Hoe installeer ik Eclipse 4.2 op Ubuntu 12.04

Omdat de Eclipse-pakketten in de Ubuntu-repositories verouderd zijn, moeten we de nieuwste releases handmatig installeren. Je kunt het tar.gz-bestand gewoon downloaden van eclipse.org.

  1. Eclipse downloaden. ik heb eclipse-jee-juno-SR1-linux-gtk.tar.gz

  2. Pak het uit door een opdrachtregel uit te voeren

    tar -xzf eclipse-jee-juno-SR1-linux-gtk.tar.gz
    

    Of met extractie van Archive Manager.

  3. Verplaats de map met afgedekte eclips naar /opt/ folder

    mv eclipse /opt/
    sudo chown -R root:root /opt/eclipse
    sudo chmod -R +r /opt/eclipse
    
  4. Maak een eclips-uitvoerbaar bestand in uw gebruikerspad

    sudo touch /usr/bin/eclipse
    sudo chmod 755 /usr/bin/eclipse
    

    Maak een bestand met de naam eclipse in /usr/bin/ met je favoriete editor (nano, gedit, vi...)

    Kopieer dit erin

    #!/bin/sh    
    export ECLIPSE_HOME="/opt/eclipse"
    $ECLIPSE_HOME/eclipse $*
    

    En sla het bestand op

  5. Maak een Gnome-menu-item

    Maak een bestand met de naam eclipse.desktop in /usr/share/applications/ met je favoriete editor (nano, gedit, vi...)

    Kopieer dit erin

    [Desktop Entry]
    Encoding=UTF-8
    Name=Eclipse
    Comment=Eclipse IDE
    Exec=eclipse
    Icon=/opt/eclipse/icon.xpm
    Terminal=false
    Type=Application
    Categories=GNOME;Application;Development;
    StartupNotify=true
    

    En sla het bestand op

  6. Start Eclipse

    /opt/eclipse/eclipse -clean &

  7. Nu kunt u Eclipse vergrendelen op de startbalk door op de rechterknop te klikken Lock to Laucher


37
2018-02-16 12:12



Goede instructies, maar ik vind dat je dat niet moet doen chown en chmod de map / opt / eclipse. Ik kon plug-ins niet installeren nadat ik dat had gedaan. - TomTasche
Zoals in punt 3 maar met de normale gebruiker? - Joe
Doe gewoon niets anders dan mv eclipse /opt/ in stap 3. - TomTasche
De laatste regel van het scriptbestand zou moeten zijn $ECLIPSE_HOME/eclipse "$@" niet $ECLIPSE_HOME/eclipse $*. Hiermee worden zaken als argumenten met spaties erin behouden. - jbo5112
Je zou het waarschijnlijk moeten gebruiken /usr/local/bin in plaats van /usr/bin - kzh


Ik raad u aan om rechtstreeks te downloaden van de eclipse website. het installatieproces heel eenvoudig, pak gewoon de bestanden tar.gz uit, om het te verwijderen is ook vrij eenvoudig, simpelweg door de eclipsmap te verwijderen: D


17
2018-05-31 10:46



Ik ben het hier mee eens. De meeste gebruikers zullen perfect worden bediend door Eclipse in hun eigen homedirectory's te installeren, alleen voor hen. De ingebouwde pakketbeheerder van Eclipse kan worden gebruikt om het up-to-date te houden en nieuwe componenten te installeren. Verschillende gebruikers op dezelfde machine zullen waarschijnlijk verschillende pakketten voor Eclipse willen installeren en kunnen zelfs verschillende hoofdversies gebruiken. Evenzo voor versies van Eclipse die een uitvoerbaar installatieprogramma bieden, zullen de meeste gebruikers nog steeds willen installeren in hun persoonlijke mappen (en niet van eigenaar of rechten veranderen). - Eliah Kagan


Vanaf uw bureaublad, klik op het Ubuntu Software Center enter image description here

Als het eenmaal is geopend, zoek je naar Eclipse

enter image description here

enter image description here

Wanneer de zoekopdracht is voltooid, wordt Eclipse weergegeven. alles wat je hoeft te doen is klikken op installeren, leun achterover en ontspan totdat de installatie is voltooid.

Als u nog vragen heeft, aarzel dan niet om te vragen.


11
2018-05-31 10:48



Hoe installeren we eclipse versie 4.2 (SR2) met Ubuntu Software Center? Het lijkt versie 3.8 - Joe
Het gebruik van het USC haalt vrijwel altijd een versie (of wat je ook bent) naar beneden, die 2+ jaar oud is. Blijkbaar zou het te veel tijd kosten voor iemand om te controleren of de nieuwste versie van grote, populaire programma's werkt met de nieuwste versie van ubuntu.


Dit zijn de instructies waarvan gekopieerd is http://www.inforbiro.com/blog-eng/ubuntu-12-04-eclipse-installation/

Hoe installeer ik het Eclipse IDE-platform op Ubuntu 12.04 LTS Precise Pangolin

1) Open een terminal en voer het commando in

sudo apt-get install eclipse-platform

2) Nadat Eclipse is geïnstalleerd, kunt u ontwikkelingsplug-ins installeren op basis van uw behoeften, bijvoorbeeld:

installeert het Java Development Tools (JDT) -pakket voor Eclipse

sudo apt-get install eclipse-jdt

zal C / C ++ ontwikkelgereedschapspakketten voor Eclipse installeren

sudo apt-get install eclipse-cdt

10
2017-09-24 08:11





Je kunt gebruiken ubuntu-make installeer Eclipse op Ubuntu:

Ubuntu Make installeren:

Voor Ubuntu 14.04 LTS:

sudo add-apt-repository ppa:ubuntu-desktop/ubuntu-make
sudo apt-get update
sudo apt-get install ubuntu-make

Voor Ubuntu 16.04 LTS en nieuwer:

Ubuntu make staat al in de officiële repositories.

sudo apt-get install ubuntu-make

Eclipse installeren:

umake ide eclipse

Eclipse verwijderen:

umake ide eclipse --remove

8
2018-02-16 14:22



installeert het de laatste eclips? - Soumyadip Das
"Ubuntu make is altijd nieuwste versie van upstream ophalen ..." - Ubuntu Maak Wiki  ;) - hg8
Op Ubuntu 16.10 heb ik de officiële installatiebronnen gebruikt om Ubuntu Make 16.05 te installeren. Ubuntu Maak gejammer over de download page changed its syntax or is not parsable. Ik loste dat op door de instructies in dit antwoord te volgen voor de oudere versies van Ubuntu. Ik heb de repository handmatig toegevoegd en vervolgens Ubuntu make geïnstalleerd en vervolgens Eclipse geïnstalleerd. - Martin Andersson
Om de installatie van beide te scripten, deed ik het voor het eerst sudo add-apt-repository -y ppa:ubuntu-desktop/ubuntu-make, dan sudo apt-get update, Tenslotte sudo umake ide eclipse-jee dest-dir=/apps/eclipse. - Martin Andersson
Momenteel wordt Eclipse Java EE IDE voor webontwikkelaars opgehaald, Versie: Neon.2 Release (4.6.2), Build id: 20161208-0600 - Michael S.


Download altijd de verpakte eclips van hun website. Het is het beste voor u om de eclipse.tar.gz in uw opt-map en maak er symbolisch voor en gebruik die rond uw systeem.

Dus als u in de toekomst een upgrade uitvoert, zullen al uw snelkoppelingen en koppelingen niet verdwijnen.

Dit is de gewenste opstelling voor eclipse. IMO


6
2018-01-19 22:29





Ik heb dit kleine script gemaakt om op een aantal kaneelmachines te installeren. Mogelijk moet u specifieke dingen voor uw behoeften wijzigen, maar u kunt dit als een eigen sjabloon gebruiken.

#!/usr/bin/env bash

wget -P /tmp/ http://eclipse.mirror.triple-it.nl/technology/epp/downloads/release/kepler/SR1/eclipse-standard-kepler-SR1-linux-gtk-x86_64.tar.gz

tar -xzf /tmp/eclipse-standard-kepler-SR1-linux-gtk-x86_64.tar.gz -C /opt/
chown -R root: /opt/eclipse/

cat <<- 'EOF' > /usr/bin/eclipse42
    #!/bin/sh    
    export ECLIPSE_HOME="/opt/eclipse"
    $ECLIPSE_HOME/eclipse "$@"
EOF

chmod +x /usr/bin/eclipse42

cat <<- EOF > /usr/share/applications/eclipse42.desktop
    [Desktop Entry]
    Encoding=UTF-8
    Name=Eclipse
    Comment=Eclipse IDE
    Exec=eclipse42
    Icon=/opt/eclipse/icon.xpm
    Terminal=false
    Type=Application
    Categories=GNOME;Application;Development;IDE;
    StartupNotify=true
EOF

U kunt Kepler nu uitvoeren door te typen eclipse42 of wacht tot het menu wordt vernieuwd (of voer het in restart) om het daar te vinden.

Reageer gerust op wijzigingen die u zou aanbevelen.


4
2017-07-27 12:02



U moet iets niet installeren onder /usr/* tenzij je een dpk voorbereidt. U dient uw eigen beheerdersbestanden te installeren onder /usr/local/* of /opt/NAME/*. Omdat bijvoorbeeld /usr/bin is voor de systemen / distributiepakketten, /usr/local/bin is voor beheerders eigen bestanden en /opt/PACKAGE/bin is voor de commerciële software PAKKET. Als u installeert in /opt/PACKAGE het is meestal het gemakkelijkst om een ​​script of links te maken /usr/local/bin  die het programma starten. Op die manier is het bereikbaar voor alle gebruikers PATH. - Anders


Zoals bij elke andere Eclipse-versie, hoef je het niet van de repositories te halen. Download gewoon het juiste archief van eclipse.org, extract en voer Eclipse uit.

Eclipse in de repositories is vaak verouderd. Het wordt meestal elke ubuntu-release bijgewerkt.


3
2017-10-18 16:09





ik gebruik Ubuntu GNOME 16.04 en de versie in het softwarecentrum is oud. Ik volgde het begin van het community-antwoord door de eclips van hun website te downloaden en vervolgens onverpakt met:

tar -zxvf eclipse.XX.YY.tar.gz

Daarna was het net zo eenvoudig als:

cd eclipse-isntaller/
./eclipse-inst

Dan komt er een GUI doorlopen.

Hierna kunt u zowel de tar.gz als de map verwijderen:

rm eclipse-inst-linux64.tar.gz 
rm -rf ./eclipse-installer/

2
2018-05-31 19:06