Vraag Irritant flikkeren in 16.04 LTS - Chrome


Ik heb een upgrade uitgevoerd van 4.4.0 naar 4.4.8 en vervolgens 4.5.2 op Ubuntu 16.04 LTS 64-bit, en het gebeurt nog steeds.

Bij 4.5.2 komt het nog vaker voor, en vooral in Chrome (heb nog geen firefox of opera geprobeerd). Elke keer dat ik een nieuwe webpagina open. Is er een manier om dit op te lossen, of is het een fout?

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
04:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Venus XTX [Radeon HD 8890M / R9 M275X/M375X] (rev 81)

Proost.


196
2018-05-03 06:31


oorsprong


Hetzelfde als ik ervaar op Ubuntu 14.04.4 - Billal Begueradj
Ik word ook geconfronteerd met hetzelfde probleem, vooral tijdens het gebruik van Facebook. Dat is te vervelend. - sgiri
Proberen --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers   wat extra info hier: productforums.google.com/forum/#!topic/chrome/... - Postadelmaga
Googler hier. Deze bug wordt bijgehouden in de Chromium-probleemtracker bij # 606152 - Flikkerend op Intel met uploads met één kopie. - Dan Dascalescu
Ik schakelde over op HWE stack (kernel 4.8 en X-7.7). Het stopte met het flickeren. Er is een probleem met i915 (Intel HD Graphics Driver) in kernel 4.4-serie. - Manoj Sawai


antwoorden:


Na enig onderzoek, vond ik een oplossing voor dit probleem. Het werkt nu voor mij.

Ik heb hardwareversnelling voor mijn browser uitgeschakeld

Settings > Advance Settings > System > uncheck the hardware acceleration

Ik hoop dat dit werkt op uw machine.


ik gebruik google-chrome-stable Version 50.0.2661.94 (64-bit) op Ubuntu 16.04

-----BEWERK----

Als u vertraging ondervindt bij het scrollen en schermbreuk. Doe zoals voorgesteld door Amos Folarin in de reactie hieronder:

Ga naar: chrome://flags/#smooth-scrolling en Schakel het in.


186
2018-05-05 17:54



Ik probeerde dat, lost het probleem op, maar maakt mijn scrolling-lag en het scherm scheurt. - Mookey
Dit moet echt niet worden geaccepteerd, want het is geen oplossing, het is absoluut een work-around. - theV0ID
Dit heeft geen effect op het flikkeren voor mij. - DavidJ
Deze oplossing werkte voor mijn XPS13 9343, het flikkeren is definitief gestopt of is niet merkbaar. Ik probeerde ook de andere oplossing die hier werd voorgesteld, waarbij chrome: // flags / # enable-gpu-rasterization op 'Force-enabled for all layers' werd ingesteld, maar dit werkte niet, alleen het uitschakelen van hardwareversnelling in chrome leek te werken. Maar ga akkoord met @ theV0ID dat hij geen idee heeft. - Amos Folarin
Probeer ook chrome: // flags / # smooth-scrolling in te schakelen voor soepel scrollen. Ik gebruik XPS13 + Ubuntu16.04 werkt goed met de optie voor hardwareaccelero uitgeschakeld - Amos Folarin


Ik had hetzelfde probleem, het instellen van GPU-rastering op 'Geforceerd ingeschakeld voor alle lagen' lijkt eindelijk te werken:

Chrome Flags: GPU rasterization


158
2017-08-08 07:52



snelle link: chrome: // flags / # enable-gpu-rasterization - JohannesNE
werkte ook voor mij. - Sufiyan Ghori
Het werkte niet meer, het flikkeren is terug, denk ik na het upgraden naar Chrome-versie 53.0.2785.92 (64-bit) - Omid
Dit vermindert drastisch flikkering, maar het is er nog steeds in Google Inbox, bijvoorbeeld (momenteel de enige plaats waar ik het zie). - TiGR
Werkt, maar nu wordt alleen de linkerbovenhoek van sommige afbeeldingen weergegeven. Wat deed het voor mij was chrome: // flags / # ignore-gpu-blacklist - Jasny - Arnold Daniels


Open een terminal en voer deze opdracht in:

sudo nano /usr/share/applications/chromium-browser.desktop

en scrol omlaag totdat je bij deze regel komt:

Exec= chromium-browser

Voeg vervolgens deze twee parameters toe

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

Druk op Ctrl + O om op te slaan en Ctrl + X om af te sluiten.

Voer vervolgens deze opdracht in:

sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf

en voeg deze regels toe

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
   Option      "DRI"    "3"
EndSection

Druk op Ctrl + O en vervolgens op Ctrl + X.

Open Chromium en schrijf naar adresbalk: chrome://flags/ en ga naar binnen.

  • Enable-zero-copy
  • Schakel de lijst voor het renderen van software in
  • Schakel 2D-lijstdiagramweergave in

Eindelijk open chrome instellingen en klik op:

  • gebruik hardware versnelling indien mogelijk

38
2017-07-27 08:10



Werkte op mijn Dell XPS 15 95050 Intel® Core i7-6700HQ CPU @ 2.60GHz Intel® HD Graphics 530 (Skylake GT2). - Prydie
In mijn geval (na het uitproberen van meerdere oplossingen) heb ik eenvoudig die vlaggen ingeschakeld die u noemde (zero-copy, Override Software Rendering List, Display 2D List Canvas) en het lijkt te zijn opgelost (op Intel HD Graphics). - Nahuel
De twee opdrachtregelschakelaars (uitschakelen van tijdelijke oplossingen / inschakelen van native gpu-geheugenbuffers) lijken niet meer te werken, maar maken de 20-intel.confbestand werkte voor mij! Ook gpu-rastering ingeschakeld (niet zeker of het belangrijk is). - terabaud
De enige werkende oplossing voor mij. Bedankt - Darkside
Gewoon toevoegen 20-intel.conf werkte voor mij - hoefde niets anders te doen. - Vadi


Ik heb het als volgt opgelost:

sudo apt-get purge xserver-xorg-video-intel

start vervolgens opnieuw op. Dit komt omdat Intel-stuurprogramma's naar de modi-instellingen zijn gegaan. Zie voor meer info deze opmerking in de bug-thread Chromium.


37
2017-08-19 14:25



Ik ging naar de route met de Chrome-vlaggen en ging toen deze route in de plaats en reset de vlaggen naar de standaardinstelling en wist de intel-dingen. Tot nu toe, zo goed. - Sethen
bedankt. Ik heb een Intel NUC die een paar jaar oud is en een paar updates heeft doorgemaakt. Het is op 16.04.2 maar je suggestie vond wel pakketten om te verwijderen. Het flitst niet meer (mijn HDMI-video flitste aan en uit na ongeveer 1 of 2 Hz na enkele recente updates, ik dacht dat het een hardwarefout had ontwikkeld na 8 jaar service). - Tim Richardson
Dit antwoord zou een stuk hoger moeten zijn! - Galgalesh
Dit is het? Het werkt foutloos !!! Totaal onderschat antwoord. Heel erg bedankt, vriend! - uloco
Bedankt! Dat loste het probleem voor mij op. Uw antwoord zou een paar punten hoger moeten zijn dan het is. - Anthony D.


Geen van deze antwoorden leek me te helpen. Wat ik uiteindelijk deed doen lijkt om het te repareren (mijn referentie was deze site http://www.bang-olufsen.com/ welke flikkerde als CRAZY en nu werkt het soepel) is dit:

1.- Navigated to chrome://gpu/. Dit is wat het liet zien:

enter image description here

2.- Ik heb geprobeerd de problemen een voor een op te lossen. In mijn geval heeft het inschakelen van deze vlaggen een aantal van deze opgelost: GPU rasterization, Override software rendering list. Toen was het zo:

enter image description here

3.- Ik bewerkte de desktop launcher en voegde de parameters toe --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers.

4.- Daarna worden er geen problemen meer gedetecteerd, wordt alles weergegeven als 'hardware versneld' en, nog belangrijker, niet meer flikkerend:

enter image description here

Als u eerst de parameters aan het opstartprogramma toevoegt, zou de lijst met problemen korter moeten zijn en het zal waarschijnlijk gemakkelijker zijn om erachter te komen welke vlaggen u zullen helpen met de problemen die u nog hebt.


24
2017-09-14 12:29



Dit is een goede referentie. Ik heb het gebruikt om mijn probleem met firefox op te lossen, waar het eenvoudig werd opgelost door het vakje "Gebruik hardwareversnelling" uit te schakelen in de geavanceerde instellingen. - Bach
Dit verminderde het flikkeren voor mij, maar het gebeurt nog steeds vaak ... - addison


Met Chrome-versie 51.0.2704.103 (64-bit) de vlaggen

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

werk niet meer.

De beste manier om dit te doen is een stap terug naar Chrome 50 (versie 50.0.2661.86 (64-bits)), hier is een instructie om een ​​stap terug te doen: hoe downgrade ik Google Chrome? 

Belangrijk is dat we druk uitoefenen op Google om dit probleem op te lossen, te stemmen voor de bug in Chromium en op de Google-productpagina:

https://bugs.chromium.org/p/chromium/issues/detail?id=606152

https://productforums.google.com/forum/#!topic/chrome/CtKF2BiskT8;context-place=forum/chrome


7
2018-06-19 08:02



Werkt niet voor mij. - ComBin
@ComBin: heb je geprobeerd een stap terug te zetten naar v50 en de vlaggen gebruikt? Volg echter de link naar de chroombug maar er zijn heel veel verschillende oplossingsvoorstellen om deze versie van chrome / -ium te laten werken. - user157697
ik wil geen v50, bedankt. Ik ben de beste manier gevonden om het te repareren, zie mijn antwoord hieronder. - ComBin
AHa, in de chroombug bedoelden de jongens dat dit enorme prestatieproblemen zou hebben. Ik zal echter enkele suggesties van de chroombuggen proberen wanneer ik de tijd heb, voor zover ik begrijp dat Chromium alleen het symptoom is en niet de oorzaak. Ik zal je op de hoogte houden als ik iets beters / anders vind. Proost. - user157697


chrome://flags/ > GPU rasterization > Enable,

Dit werkte eindelijk voor mij! Vond dit onderaan dit Google-formulier! https://productforums.google.com/forum/#!msg/chrome/CtKF2BiskT8/dLXKfU2XAQAJ


5
2017-10-16 20:44





Ik denk dat ik de oplossing heb gevonden:

flags --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers en ook enable-zero-copy ENABLE

    sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf
    Section "Device"
       Identifier  "Intel Graphics"
       Driver      "intel"
       Option      "AccelMethod"  "sna"
       Option      "TearFree"    "true"
       Option      "DRI"    "3"
    EndSection

4
2017-07-07 15:14



Er ontbreken enkele vlaggen, hier is mijn stap voor stap: bugs.chromium.org/p/chromium/issues/detail?id=606152#c72 - Hermann Bier
Ik heb mijn probleem kunnen oplossen met alleen de sectie in het 20-intel.conf-bestand zonder extra vlaggen in chrome op bionic beaver 18.04 - Brandon Søren Culley


Probeer te laden met sommige GPU-opties uitgeschakeld:

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

Nadat u dat hebt geprobeerd, kunt u ook enkele rendering-instellingen gebruiken in about: // -vlaggen om te zien of iets daar helpt, maar het grootste deel van mijn renderflickers werd opgelost door de twee opdrachtregelvlaggen. Als u een .desktop-startprogramma hebt, voegt u die vlaggen toe aan de top Exec-vermelding vóór de '% U'. U kunt ze ook toevoegen aan de andere Exec-items om de vlaggen op alle opstartmodi te laten toepassen.


2
2018-05-04 15:44