Vraag Kan ATI-eigen stuurprogramma's niet installeren in 12.10


Ik heb een laptop met ATI Radeon 6770M HD Hybrid grafische kaart. In Ubuntu 12.04 installeerde ik de fglrx-driver via "extra stuurprogramma's" en het werkte. (Ik kan zelfs van GPU wisselen). Maar in de nieuwe Ubuntu 12.10 wordt Unity na installatie niet geladen.

Alleen de muis en de achtergrond. Als ik de instellingen initialiseer sudo aticonfig --initial dan geeft het na het rebooten een waarschuwing dat ik in de lage grafische modus ben! Hoe dit op te lossen?

Eerder gebruikte ik de softwarebron om de stuurprogramma's te installeren. Maar toen ik de terminal gebruikte, kreeg ik de volgende waarschuwing:

update-alternatives: warning: forcing reinstallation of alternative /usr/lib/fglrx/ld.so.conf because link group x86_64-linux-gnu_gl_conf is broken

Update: een bugrapport in het startvenster geplaatst: https://bugs.launchpad.net/fglrx/+bug/1068661


46
2017-10-19 06:05


oorsprong


Ik heb net een bugrapport ingediend: bugs.launchpad.net/fglrx/+bug/1068661 - THpubs
Ik denk dat dit probleem is omdat de ATI-stuurprogramma's de huidige X Server 1.13 nog niet ondersteunen. Dus we wachten op ATI. - Phil Hannent
Ik heb zojuist mijn opmerkingen toegevoegd aan dat bugrapport. Ik vind het enigszins schokkend dat een dergelijke bug de finale haalt, omdat ATI-kaarten niet zo zeldzaam zijn ... - CadentOrange
AMD heeft een speciale 12.9 bètastuurprogramma uitgebracht die zou werken met de xserver 1.13 in 12.10: support.amd.com/us/kbarticles/Pages/...; dit lijkt echter nog niet in de standaardrepository te zijn ingepakt. Het ondersteunt ook alleen HD 5000 of later kaarten: askubuntu.com/questions/203232/... - Andrew Mao
Jongens, voeg deze informatie toe in beide antwoorden of voeg het toe aan bestaande antwoorden, informatie moet daar worden geplaatst, niet begraven in reacties! - Jorge Castro


antwoorden:


Ik begon met een schone 12.10 installatie (geen upgrade) Mijn kaart is een Radeon HD 5450

Het eerste wat ik deed was het installeren van Linux-source en Linux headers

sudo apt-get install linux-source
sudo apt-get install linux-headers-generic

Ik merkte dat velen met Nvidia-kaarten dit moesten doen en ik ben er zeker van dat ik iets zag dat het ook ATI-gebruikers heeft geholpen.

Net als iedereen als ik een van de eigen stuurprogramma's na het opnieuw opstarten heb geïnstalleerd, kon ik inloggen maar verloor ik de eenheid.

Een ding dat ik opmerkte is dat het installeren van de driver geen Catalyst-controlecentrum heeft geïnstalleerd (niet zeker of dit voor alle anderen hetzelfde is)

Dus ik installeerde Synaptic-pakketbeheer en installeerde fglrx-updates vanaf daar

enter image description here

Nu is het Catalyst-controlecentrum geïnstalleerd.

Bij het opnieuw opstarten echter, in plaats van te kunnen inloggen zonder Unity, hing het systeem aan het startscherm.

Dus ik solliciteerde nomodeset en deze keer startte het op met Unity aanwezig

Hier is het resultaat van fglrxinfo

enter image description here

En hier is wat softwarebronnen zegt

enter image description here

Met nomodeset toegepast Ik krijg misschien niet het startscherm bij het opstarten, maar fglrx-updates werken goed. Ik zou zelfs willen zeggen dat het beter presteert dan in 12.04

Meer informatie

Grub biedt me 2 kernels aan

3.5.0-18-generic en 3.5.0-17-generic

De latere '18' is goed, de oudere '17' laadt nog steeds zonder eenheid


25
2017-10-21 17:35



Op een zojuist geïnstalleerde Ubuntu 12.10 die ik heb geïnstalleerd linux-headers-generic, fgrlx-updates en fgrlx-amdcccle-updates vervolgens opnieuw opgestart en de driver (inclusief Catalyst Control Center) geïnstalleerd. Dat deed ik niet nomodeset, maar in tegenstelling tot u, heb ik niet geprobeerd om de gepatenteerde driver eerder te installeren. - Moshe Revah
@ Zippoxer misschien zou u deze informatie aan dit bugrapport kunnen toevoegen bugs.launchpad.net/fglrx/+bug/1068661  Het kan anderen helpen en helpen om de bug sneller te sorteren. - Chris Carter
Kan 'nomodeset' niet toepassen of het helpt niet. Ik heb nomodeset toegevoegd om door deze instructie te booten ubuntuforums.org/showthread.php?t=1613132 maar het splash-scherm blijft hangen. Hoe herstel je het? - megas
Dit heeft voor mij gewerkt op een HD5450. Ik heb eerder zoveel andere gidsen geprobeerd zonder succes. ik had linux-source en linux-headers-generic al geïnstalleerd, dus ik hoefde deze tijd niet. Ik volgde je instructies en alles werkt perfect. Ik hoefde echter niet van toepassing te zijn monodeset. Heel erg bedankt! - Jean-Louis Mbaka
@ Jean-Louis nomodeset, niet monodeset. Helaas heb ik dit advies geprobeerd, maar zelfs met nomodeset is mijn eenheid verdwenen en mijn terminal werkt niet. Verknald. - raindrop


Voor degenen die hybride systemen (ATI / intel) hebben en fglrx niet meer werkt in 12.10, kan het probleem zijn zoals hier beschreven (fglrx incompatibiliteit met de recente versie van de intel driver): https://bugs.launchpad.net/ubuntu/+source/fglrx-installer-updates/+bug/1068404

Wat ik zou voorstellen zou zijn

  1. Verwijder alle fglrx * -pakketten:

    sudo apt-get purge fglrx*
    
  2. Voeg mijn PPA toe aan uw repositorieslijst:

    sudo add-apt-repository ppa: andrikos

  3. Update uw pakketinformatie:

    sudo apt-get update 
    
  4. Werk het fglrx en intel drivers:

    sudo apt-get install fglrx xserver-xorg-video-intel
    
  5. Vergeet niet om de fglrx bestuurder

    sudo aticonfig --initial --force
    

7
2017-10-27 17:56



Hallo Nick, ik heb je oplossing geprobeerd, helaas ging het niet op voor mij. Ook vraag ik me af of het commando onder 4. sudo aticonfig --initial zou moeten zijn? Ik kon ook de opdracht onder de man-pagina's van aticonfig niet vinden; zien man.cx/aticonfig(1) - davorao
Ja davorao, het is de eerste keer dat ik het nu aan het repareren ben. Welk systeem heb je? Deze oplossing is voor de hybride ATI / intel onder ubuntu 12.10 - Nick Andrik
Hallo Nick, mijn systeem is een Intel HD3000 die fungeert als de geïntegreerde GPU met een Radeon HD 6490M als de afzonderlijke GPU. De laptop in kwestie is de Samsung Chronos 7 700z3a-S03-DE. Ik heb geprobeerd om de xserver-xorg-video-intel deb van uw PPA te gebruiken, maar kon het niet laten werken. - davorao
Ik heb deze oplossing geprobeerd. Het werkte. Maar ik heb een vervelende "AMD-test only" box en (niet zeker of het verbonden is, maar zeer waarschijnlijk) mijn muis hangt soms en soms ook met toetsenborden - vooral wanneer ik iets in de eenheidsbalk selecteer. Denk je dat het verbonden is? Stabielere oplossing zou beter zijn! - greg606
Ik zou geloven dat dit een andere bug is. Als mijn oplossing voor je werkte, kun je alsjeblieft stemmen zodat meer mensen het zien? Bedankt - Nick Andrik


Ik ging naar terminal (Ctrl+alt+F1 bijvoorbeeld) en deed:

sudo apt-get remove fglrx

Nu is mijn computer behoorlijk langzaam, maar ik kan er tenminste gebruik van maken en wachten tot het probleem is verholpen.


4
2017-10-19 06:25





Ik heb het probleem gevonden. Op upgrade van Ubuntu 12.04 -> Ubuntu 12.10, de inhoud van lightdm.conf in /etc/lightdm/zijn volledig gewist. Installeren of herconfigureren van lightdm installeert dit bestand NIET hier, dus lightdm weet niet hoe hij zichzelf moet weergeven. U moet het volgende doen:

sudo apt-get purge fglrx lightdm && sudo apt-get install lightdm ubuntu-desktop && sudo nano /etc/lightdm/lightdm.conf

voeg de volgende tekst in:

[SeatDefaults]
user-session=ubuntu
greeter-session=unity-greeter
allow-guest=false

Sla het bestand op via CTRL + X en start opnieuw op. U hoeft fglrx niet te verwijderen, maar ik weet het niet.


4
2017-10-19 07:33



kun je ons de stappen die je hebt gevolgd vertellen? Fglrx geïnstalleerd vanuit de extra stuurprogramma's en gdm geïnstalleerd? - THpubs
sudo apt-get purge fglrx lightdm && sudo apt-get install lightdm ubuntu-desktop && gereviseerde inhoud hierboven over het configureren van lightdm. - mmstick
een klein probleempje ... herkende alleen dat je hebt bijgewerkt vanaf ubuntu 12.04. Ik ben op een nieuwe installatie - THpubs


Dit werkt voor mij.

    sudo apt-get install linux-headers-generic

Ga naar amd.com en download hun nieuwste bètastuurprogramma (dat net is bijgewerkt naar 12.11). Uitvoeren en installeren.

Houd er rekening mee dat de stabiele bestuurder niet met eenheid zal werken.

Ga hierheen om een ​​script te krijgen om het watermerk te verwijderen: http://areyoueye.net/?p=187

Slainte!


4
2017-10-24 23:45



Hallo @ryanpcmcquen heb je een zuivere AMD / ATI grafische kaart of heb je een Intel die werkt als de geïntegreerde naast de AMD / ATI-discreet. Ik vind dat voor degenen met alleen AMD / ATI-kaarten uw oplossing met de nieuwe AMD Catalyst 12.11-stuurprogramma's werkt, maar voor degenen met een toegevoegde geïntegreerde Intel-kaart biedt dit niet de oplossing. - davorao
Ik heb de A8, dus geen Intel. - ryanpcmcquen
Dit werkte voor mij met de Radeon HD 5670. - thelastshadow
Het gebruik van de bètadriver was de enige oplossing die echt op mijn systeem werkte, ook met behulp van een enkele Radeon HD-kaart. - Bruno Pereira


Er is een open bug op dit moment met fglrx-installer en Ubuntu 12.10

https://bugs.launchpad.net/ubuntu/+source/fglrx-installer/+bug/1025488

ik zeg altijd "zoek naar open en bevestigde bugs" voordat je iets doet, vooral wanneer de distributie nieuw is.

U kunt deelnemen aan deze bug als deze van invloed is op u, door opmerkingen daar te plaatsen en op de knop "Ja dat het invloed op mij heeft" te klikken (u moet een Launchpad-account hebben).


1
2017-10-25 07:53





Oplossing voor mij:

  1. verwijder de huidige fglrx sudo sh /usr/share/ati/fglrx-uninstall.sh sudo apt-get remove --purge fglrx*

  2. voeg ppa repository toe sudo apt-add-repository ppa:andrikos/ppa

  3. update pakkettenlijst sudo apt-get update

  4. installeer pakketten sudo apt-get install fglrx-updates


1
2017-11-09 22:23





Ik kreeg hetzelfde probleem. Mag ik een mogelijke oplossing gevonden. Eerst opende ik het Ubuntu-Software-Center en ik was op zoek naar "extra stuurprogramma's". Na installatie van de "extra stuurprogramma's" installeerde ik het ATI-stuurprogramma en na een herstart startte mijn notebook normaal met eenheid en met de juiste juiste driver.

Opmerking: de installatie van de Software-Sources-knop werkte niet in mijn geval.


0
2017-10-21 20:19



Dat zou in mijn oplossing passen, zou er iets mis kunnen zijn met het pakket dat in softwarebronnen wordt aangeboden? - Chris Carter
Werkte niet voor mij :( - THpubs