Vraag Ubuntu 16.04-upgrade: autorisatieprobleem


Ubuntu 16.04 is een nachtmerrie! Ik heb mysql php zoneminder moeten repareren ... mijn website werkt niet meer en owncloud geeft me een foutmelding.

Wanneer ik owncloud probeer te openen, krijg ik het volgende:

Internal Server Error
The server encountered an internal error or misconfiguration and was
unable to complete your request.
Please contact the server administrator at xxxxx@xxxxx.xxx to inform
them of the time this error occurred, and the actions you performed just    
before this error.
More information about this error may be available in the server error log.

Bovendien, wanneer ik de error.log controleer, zie ik:

AH00027: No authentication done but request not allowed without
authentication for /owncloud. Authentication not configured?

Ik vermoed dat updates ook mijn update hebben bijgewerkt apache2  van apache2.2  naar apache2.4.18 en ik ga ervan uit dat dit de reden is waarom mijn website volledig is afgespoten en dus is owncloud. Ik heb geen idee wat ik met deze fout moet doen. Raar ding is .. Het werkt prima op mijn telefoon om de lijst met bestanden te bekijken. Ik kan niets downloaden, maar ik denk dat ik de lijst kan bekijken omdat het een app niet is. website "en de app doet de auth zoals het hoort.

Ik heb eindelijk zoneminder om te werken, dus ik weet dat MySQL en PHP werken. Ik heb geprobeerd het op te zoeken en heb alleen dingen gevonden zoals je nodig hebt om authz_core_module geïnstalleerd te hebben. Ik geloof dat ik dat doe ... authz_core is ingeschakeld in mijn apachemodules. Ik ben op verlies ... geen suggesties?

Bewerk: Nog steeds bezig met het probleem ... Ik heb de regel in de owncloud.conf gewijzigd van Geldige gebruiker vereisen naar Alle verleend vereisen en nu krijg ik dit wanneer ik de pagina probeer te laden:

<!DOCTYPE html>
<!--[if lte IE 8]><html class="ng-csp ie ie8 lte9 lte8" data-placeholder-focus="false" lang="en" ><![endif]-->
<!--[if IE 9]><html class="ng-csp ie ie9 lte9" data-placeholder-focus="false" lang="en" ><![endif]-->
<!--[if (gt IE 9)|!(IE)]><!--><html class="ng-csp" data-placeholder-focus="false" lang="en" ><!--<![endif]-->
    <head data-requesttoken="">
        <meta charset="utf-8">
        <title>
        ownCloud        </title>
        <meta http-equiv="X-UA-Compatible" content="IE=edge">
        <meta name="referrer" content="never">
        <meta name="viewport" content="width=device-width, minimum-scale=1.0, maximum-scale=1.0">
        <meta name="apple-itunes-app" content="app-id=543672169">
        <meta name="theme-color" content="#1d2d44">
        <link rel="shortcut icon" href="Memcache \OC\Memcache\Redis not available for local cache Is the matching PHP module installed and enabled?

Misschien helpt dit ... denk dat hoe meer informatie, hoe beter.


0
2018-04-25 06:25


oorsprong




antwoorden:


Ik had hetzelfde probleem. Dit probleem is opgelost door mijn config / config.php te vervangen door de versie uit het owncloud-pakket en de mysql-instellingen opnieuw in te voeren. Ik hoop dat dit je probleem ook oplost


1
2018-04-27 16:32



Ik kon er geen vinden die bij het pakket zat, behalve een voorbeeld dat niet erg nuttig was, maar ik hernoemde mijn config.php en probeerde toen de site binnen te gaan ... en het gaf me een instellingsscherm waar ik kon binnenkomen de data. Zodra dit is voltooid, is er een fout opgetreden omdat de gebruiker al bestond. Ik verwijderde de gebruiker van de db en probeerde het opnieuw en kreeg een andere fout, maar het had een gedeeltelijke config.php gemaakt. Ik keek gewoon rond en haalde mijn oorspronkelijke items eruit die het nog steeds nodig had. Het lijkt erop dat mijn probleem de regels bevatten die // OC // Memcache bevatten. Met die verdwenen kreeg ik een update-scherm en nu werkt het - John Orion


Ik ontdekte dat ik owncloud opnieuw moest installeren na het upgraden van ubuntu 15.10 naar 16.04. Ik denk dat het de upgrade was van php5 naar php7 die alles brak. Owncloud ondersteunt php7, maar misschien is herinstallatie vereist om het te gebruiken. Om op te merken, installeerde ik owncloud vanuit het pakket beschikbaar via opensuse. De stappen die ik nam waren:

sudo apt-get remove owncloud

Vervolgens heb ik het bronlijstbestand bewerkt dat de upgrader heeft uitgeschakeld en de bronregel niet beantwoord (verwijder het # -symbool vooraan)

sudo vim /etc/apt/sources.list.d/owncloud.list

Vervolgens heb ik geüpdatet en opnieuw geïnstalleerd

sudo apt-get update
sudo apt-get install owncloud

Toen ik terugging naar mijn owncloud-URL, presenteerde het een typisch owncloud-upgradescherm dat ongeveer 1-2 minuten duurde, waarna mijn login verscheen. Ik hoop dat dit voor je werkt.


0
2018-04-25 14:49



Bedankt ... ik heb owncloud feitelijk opnieuw geïnstalleerd omdat toen ik voor het eerst een upgrade uitvoerde ik de site probeerde en het werkte niet .. toen ik in de map met de eigen map keek, waren de meeste bestanden verdwenen. Ik deed niet dat de upgrade bronnen zou uitschakelen, dus ik heb ze teruggezet ... geprobeerd om de ene te veranderen in 16.04 maar het bestaat nog niet, dus ik liet het op 15.10 en installeerde het opnieuw. Toen kreeg ik die fouten ... Vreemd ding is .. Ik besloot om het opnieuw te proberen met je stappen, maar toen ik de owncloud verwijderde, zei hij dat het niet was geïnstalleerd. Ik gebruik synaptic om visueel te zien welke owncloud-items zijn geïnstalleerd en niet. - John Orion
Helaas loste dit mijn probleem niet op. Ik heb het geïnstalleerd zodat ik het kan de-installeren, daarna heb ik het opnieuw geïnstalleerd maar ik heb nog steeds dezelfde fouten. Ik denk dat het meer te maken heeft met Apache dan met owncloud. Zoals ik al zei, mijn website werkt niet meer .. laat alleen een blanco pagina zien en geen fouten die ik overal kan vinden om me te wijzen waar ik hem moet repareren. Ik denk dat het te maken heeft met het auth-ding omdat al mijn pagina's toegang hebben tot MySQL en ik neem aan dat het faalt omdat het waarschijnlijk niet eens probeert toegang te krijgen tot de sql-server. - John Orion


Ik had verschillende problemen met mijn 16.04-upgrade, maar kreeg het uiteindelijk wel goed. Zorg ervoor dat er een owncloud.conf is in / etc / apache2 / sites-enabled en / etc / apache2 / conf-enabled. Zorg er ook voor dat uw datadirectory correct is geconfigureerd in /var/www/owncloud/config/config.php en zorg er ook voor dat de gebruiker / groep van www-data eigenaar is en lees- / schrijfrechten heeft. Als u nog steeds problemen ondervindt, zoekt u de handmatige installatie-instructies en zorgt u ervoor dat alle benodigde php-modules zijn geïnstalleerd en ingeschakeld (kan niet linken omdat de owncloud-website om een ​​bepaalde reden op mijn werk is geblokkeerd). De handmatige instructies hebben alle modules als php5_modulename, dus gebruik gewoon php_modulename om de php 7-versie te krijgen.

Vergeet niet het apache-foutenlogboek te bekijken op /var/log/apache2/error.log om na te gaan of het u nuttige fouten oplevert.


0
2018-04-25 16:00



Goed geïnstalleerd met de juiste rechten. Probeerde om de handmatige installatie op te zoeken, maar het is niet "gebruiksvriendelijk". Het zegt dat al deze modules zijn geïnstalleerd maar niet uitleggen hoe te controleren of zoiets. Ik ga ervan uit dat alles is geïnstalleerd omdat het werkte. Zelfs na het controleren van alles krijg ik nog steeds dezelfde fout als hierboven "Geen authenticatie gedaan" Ik denk dat het een PHP / Apache-probleem is, maar wederom geen idee hoe PHP7 moet worden ingesteld .. de INI's zijn anders, dus ik kan niet eens proberen om zeker te zijn alles is hetzelfde ingesteld als in PHP5 en zoals ik al eerder zei ... mijn hele website toont gewoon een lege pagina - John Orion
net gecontroleerd met phpinfo .. ja, alle vereiste items zijn geïnstalleerd. - John Orion


De oplossing zou niet moeten zijn om uw gebruik te vervangen config.phpeigencloud configuratiebestand, met de standaard. Door dat te doen, heb je uitgeschakeld aanvullende instellingen die u hebt gemaakt, zoals caching.

Probleem hierbij is dat je onder andere de OS-versie hebt bijgewerkt en ook de PHP-versie. REDIS PHP-extensie is gecompileerd voor een eerdere versie van PHP en er is een mismatch tussen deze twee.

Je kunt in de shell rennen:

php -v

Het bovenstaande geeft iets terug als:

PHP Warning: PHP Startup: redis: Unable to initialize module REDIS compiled with module API=20050922 PHP compiled with module API=20090626

Deze opties moeten overeenkomen op Onbekend op regel 0

Je kunt de REDIS-serverconfiguratie tijdelijk uitschrijven in OwnCloud config / config.php om het operationeel te maken, maar ik raad aan om dit probleem op te lossen (hetzelfde als het vervangen van aangepaste config.php door standaard config.php en het invoeren van nieuwe waarden).

Nu, naar de oplossing :) ... om dit te verhelpen, moet je de REDIS PHP-extensie compileren (upgraden). Er is een GITHub-project. Ga naar shell en:

Voer TMP dir in, maak een map met de naam "redisphpexten ga erin ...

cd /tmp
mkdir redisphpext
cd redisphpext

Download het GitHub-project en pak het uit:

wget https://github.com/nicolasff/phpredis/archive/master.zip
unzip master.zip
cd phpredis-master

Compileren :) :

phpize
./configure
make
make install

Verwijder daarna de opmerkingen uit de REDIS-configuratie in config / config.php (als u er commentaar op hebt gegeven).

Dat zou uw probleem moeten oplossen en u zou uw OwnCloud volledig operationeel moeten hebben.

P.S: Als je de "redis.ini" hebt verknoeid, zou je er één regel in moeten toevoegen:

echo "extension=redis.so" > /etc/php5/conf.d/redis.ini

of je kunt vi, vim, nano ... gebruiken om handmatig lijn in te voeren redis.ini:

extension=redis.so

Dat is alles.


0
2018-05-26 10:07





Ik heb net gewerkt aan het upgraden van de server die Owncloud aan heeft staan ​​van Ubuntu 14.04 tot 16.04, ik vond dat dit was wat ik moest doen om alles te herstellen;

  • Voeg de Owncloud apt-repository opnieuw toe
  • do sudo apt-get update
  • do sudo apt-get install owncloud

Door dit te doen werden de vereiste afhankelijkheden geïnstalleerd en werd Owncloud in de onderhoudsmodus geschopt. Owncloud herkende zijn eigen installatie en liet alleen de bestaande gegevens achter en pakte de oude config op.

Vervolgens moest ik apache2 opnieuw configureren volgens de Owncloud-documenten. Zodra apache opnieuw was geconfigureerd, kon ik dat doen occ maintenance:mode --off in de root van Owncloud.


0
2018-02-24 18:40