Vraag Bluetooth detecteert geen apparaten [dupliceren]


Deze vraag heeft hier al een antwoord:

Ik probeer de Sony MDR-ZX550BN-headset te koppelen aan een Lenovo G580-laptop met Ubuntu 16.04. Laptop kan geen headset of andere apparaten detecteren (headset gekoppeld met smartfon werkt prima).

Sommige bronnen zeggen dat het bewerken van /etc/bluetooth/main.conf helpt. Ik heb dat gedaan, maar er gebeurde niets.

Andere bron zei dat het uitschakelen van UEFI het probleem zal oplossen. Maar dat gebeurde niet.

Blueman detecteert ook niets.

Is er een redding voor mij behalve terugkeren naar Windows?

Hier is de uitvoer van lspci -knn | grep Net -A2; lsusb

    04:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)
    Subsystem: Lenovo BCM43142 802.11b/g/n [17aa:0611]
    Kernel driver in use: bcma-pci-bridge
Bus 002 Device 003: ID 04f2:b2e1 Chicony Electronics Co., Ltd 
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 004: ID 105b:e065 Foxconn International, Inc. BCM43142A0 Bluetooth module
Bus 001 Device 003: ID 046d:c52f Logitech, Inc. Unifying Receiver
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 003: ID 090c:1000 Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.) Flash Drive
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 12d1:14dc Huawei Technologies Co., Ltd. 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

0
2017-12-12 21:46


oorsprong




antwoorden:


Ok, dus de oplossing is:

wget https://github.com/gnebehay/gnebehay.com/raw/master/contents/blog/lenovo-flexpad-bluetooth-debian/BCM43142A0-105b-e065.hcd
sudo cp BCM43142A0-105b-e065.hcd /lib/firmware/brcm/BCM.hcd

Schakel vervolgens uit en schakel in (niet opnieuw opstarten).

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1509803/comments/87


1
2017-12-13 01:06