Vraag DWA 131 draadloze adapter werkt niet 16.04 LTS


Help me alstublieft bij het oplossen van het probleem met mijn draadloze USB-adapter.

OS - Ubbuntu 14.04.1 LTS Draadloze adapter - DWA 131 nano USB-adapter, HW-versie - E1.

Probleem: - USB-stick wordt gedetecteerd. Ik heb hieronder stuurprogramma geïnstalleerd. Maar het probleem blijft bestaan. Zoek de schermafbeeldingen om mijn huidige configuratie te begrijpen ...


Code:

himansu@himansu-Inspiron-5537:~/Desktop/DWA/Win7x86$ lsusb
Bus 001 Device 006: ID 0c45:64ad Microdia 
Bus 001 Device 005: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 004: ID 04f3:0042 Elan Microelectronics Corp. 
Bus 001 Device 003: ID 8087:07dc Intel Corp. 
Bus 001 Device 007: ID 1058:0839 Western Digital Technologies, Inc. 
Bus 001 Device 002: ID 8087:8000 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 002: ID 2001:3319 D-Link Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Ik heb een stuurprogramma voor deze adapter toegevoegd aan PPA. Ik heb het inf-bestand (stuurprogrammapakket voor Windows) geverifieerd en heb vastgesteld dat de driver (rtl8192eu) correct is.

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get update
sudo apt-get install rtl8192eu-dkms

Volgde onderstaande stappen ook

sudo apt-get install git
git clone https://github.com/Mange/rtl8192eu-linux-driver.git
cd rtl8192eu-linux-driver
make
sudo make install
sudo modprobe 8192eu

Ik volgde de stappen in de volgende link (ik kan de link niet plaatsen) .. Ik krijg de melding "Ongeldige chauffeur!" bericht zoals hieronder vermeld.

himansu@himansu-Inspiron-5537:~/Desktop/DWA/Win81x86$ sudo ndiswrapper -i Dnetrtwlanu.inf 
driver dnetrtwlanu is already installed
himansu@himansu-Inspiron-5537:~/Desktop/DWA/Win81x86$ sudo ndiswrapper -l
[COLOR=#ff0000]dnetrtwlanu : invalid driver!

Ik heb de driver voor Linux van onderstaande link ontvangen.

http://files.dlink.com.au/Products/D...r_v4.3.1.1.zip

Nu heb ik een upgrade naar 16.04 LTS uitgevoerd om te hopen dat mijn draadloze adapter werkt. Maar nog geen geluk. Help me alstublieft het probleem op te lossen ..

Ik zou het erg op prijs stellen.


De map / het bestand is verwijderd en heeft het systeem rebboted zoals voorgesteld.

code
himansu @ himansu-Inspiron-5537: ~ $ sudo ndiswrapper -r dnetrtwlanu [sudo] wachtwoord voor himansu: himansu @ himansu-Inspiron-5537: ~ $ sudo ndiswrapper -r dnetrtwlanu kon / etc / ndiswrapper / dnetrtwlanu niet verwijderen: geen bestand of map

@ Jeremy- Herstart na het verwijderen van ndiswrapper driver, loste het probleem niet op. Ik heb het script uitgevoerd en de gegenereerde info opgehaald. geüpload bij onderstaande link. Vriendelijk beoordelen en voorstellen. https://gist.github.com/hmsvigle/9e3d711375595152bc2cda2bf3ae6593


0
2018-05-01 14:36


oorsprong


Bewerk uw vraag om het resultaat toe te voegen van: modinfo 8192eu | grep 3319 en ook: sudo ndiswrapper-l maar alleen als de laatste nu anders is dan wat je hierboven hebt gepost na de installatie van 16.04. - chili555
Bewerk om resultaten voor te nemen lspci -nnk |grep -iA3 net omdat het misschien makkelijker is om de interne Intel wifi op gang te krijgen - Jeremy31
@ Chili555 - himansu @ himansu-Inspiron-5537: ~ $ modinfo 8192eu | grep 3319 himansu @ himansu-Inspiron-5537: ~ $ himansu @ himansu-Inspiron-5537: ~ $ sudo ndiswrapper -l [sudo] wachtwoord voor himansu: dnetrtwlanu: invalid driver! - Himansu
@ Jeremy31 - Mijn interne wifi-hardware werkt niet correct. Waarvoor ik een externe wifi-adapter heb gebruikt. geen o / p voor A3. himansu @ himansu-Inspiron-5537: ~ $ lspci -nnk | grep -i A3 himansu @ himansu-Inspiron-5537: ~ $ - Himansu
@ Jeremy31 wilde zeggen: lspci -nnk | grep 0280 -A2 Hoe zit het met uw interne draadloze netwerk werkt niet zoals verwacht? - chili555


antwoorden:


Ik geloof niet dat de opdracht ndiswrapper precies correct was. Probeer het alsjeblieft:

sudo ndiswrapper -e dnetrtwlanu 

Plaats alstublieft fouten of waarschuwingen en we zullen proberen ze te herstellen.

Vervolgens geloof ik niet dat het rtl8192eu-dkms-pakket je exacte apparaat bedekt; laten we het verwijderen:

sudo apt-get purge rtl8192eu-dkms

Ten slotte geloof ik het Mange-pakket van github is correct. Om voor de zekerheid te zorgen, laten we een nieuwe kloon nemen:

rm -r rtl8192eu-linux-driver
git clone https://github.com/Mange/rtl8192eu-linux-driver.git
cd rtl8192eu-linux-driver
make
sudo make install
sudo modprobe 8192eu

Start opnieuw op en vertel ons of de draadloze verbinding werkt. Zoals eerder, post eventuele fouten en we zullen proberen ze op te lossen. Een paar waarschuwingen zijn waarschijnlijk onschadelijk.


1
2018-05-08 20:01



Nu werkte het prima. nadat ik het pakket had verwijderd - rtl8192eu-dkms en het vers gedownloade exemplaar opnieuw gecompileerd. Heel erg bedankt voor alle hulp. Ik waardeer het echt. :) - Himansu