Vraag Help Ubuntu 17.10 geluid daalt


Ik sloot de klep van mijn laptop, toen ik hem opendeed, is er geen geluid uit de luidsprekers of de koptelefoon.

Het gebeurt ook als ik Windows start en opnieuw opstart om Ubuntu op te starten. Als ik de computer uitschakel en aanzet, start dan op met Ubuntu en het geluid werkt goed.

Ik heb de instructies gevolgd die ik kon vinden op askubuntu en de procedure voor het oplossen van problemen met geluid maar niets werkt. Help alstublieft. enter image description here enter image description here

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC295 Analog [ALC295 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

$ sudo echo "options snd-hda-intel model=auto" > /etc/modprobe.d/snd-hda-intel.conf
bash: /etc/modprobe.d/snd-hda-intel.conf: Permission denied

$ sudo lspci -v
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
    Subsystem: Hewlett-Packard Company Sunrise Point-H HD Audio
    Flags: bus master, fast devsel, latency 32, IRQ 134
    Memory at a4428000 (64-bit, non-prefetchable) [size=16K]
    Memory at a4410000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: [50] Power Management version 3
    Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel

0
2018-03-22 23:07


oorsprong




antwoorden:


Laat me weten of het werkt. De onderstaande opdracht laadt je snd-hda-intel module door deze aan / etc / modules toe te voegen, je moet misschien een log uit / inloggen doen.      echo "snd-hda-intel" | sudo tee -a /etc/modules


1
2018-03-23 00:11



Bedankt, @root. Dat "soort van werken". Dat maakt de koptelefoons werken, maar niet de luidspreker voor zowel muziek op mijn computer als online (youtube, spotify ...) - Viet
U bent vergeten uw systeemspecificaties te plaatsen, maar hoe dan ook, dit document kan nuttig zijn. Volg de instructies om een ​​diagnose van het probleem te stellen en voeg vervolgens de options snd-hda-intel model=YOUR_MODEL naar het bestand /etc/modprobe.d/alsa-base.conf. docs.slackware.com/howtos:hardware:audio_and_snd-hda-intel - root
Ik heb de bovenstaande specificaties bijgewerkt. Ik heb geprobeerd met model = ALC295 Analog maar toestemming geweigerd. - Viet
Je hebt root-toegang nodig sudo vim /etc/modprobe.d/alsa-base.confen voeg vervolgens de optieregel toe. - root
Het werkte, maar toen heb ik mijn computer opnieuw opgestart en opnieuw is er geen luidsprekergeluid. - Viet