Vraag Inkscape kan niet worden gestart in Ubuntu 18.04


Hoe kan ik deze libgtkmm-2.4.so.1 voor Inkscape downloaden in Ubuntu 18.04?

inkscape: error while loading shared libraries: libgtkmm-2.4.so.1:   
  cannot open shared object file: No such file or directory

0
2017-07-14 13:56


oorsprong


Hoe heb je Inkscape geïnstalleerd? Probeer te installeren gemiste libgtkmm-2.4.so.1 bibliotheek met sudo apt install libgtkmm-2.4-1v5. - N0rbert
Hallo HExa, welkom bij askubuntu! U moet uw inkscape verwijderen en opnieuw installeren. Het lijkt erop dat je een gebroken afhankelijkheid hebt! Hoe heb je Inkscape geïnstalleerd? Als u nog meer problemen ondervindt, probeert u inkscape als snap-in te installeren snap install inkscape - abu_bua
@ HExa Geef aan hoe u Inkscape hebt geïnstalleerd en uitvoer hebt toegevoegd which inkscape naar de vraag. Er is geen specifieke reden om het te installeren als Snap, beide DEB en breuk zal 0,92 zijn. - N0rbert
Ik installeerde inkscape door sudo apt-get install inkscape. Ok bedankt, ik zal deze 2 oplossingen. - HExa
Sluiten kiezers: Crafting answer - Elder Geek


antwoorden:


Er is iets mis met je inkscape-installatie zoals aangegeven door N0rbert in deze opmerking.. Het ontbrekende bibliotheekpakket wordt weergegeven als een afhankelijkheid van inkscape en moet zijn geïnstalleerd bij het installeren van inkscape.

Een alternatief zou zijn om precies hetzelfde te doen als in de opmerking wordt gesuggereerd en de opdracht te geven sudo apt install libgtkmm-2.4-1v5 die dit probleem hoogstwaarschijnlijk oplost maar richt de oorzaak mogelijk niet.

Persoonlijk zou ik de volgende opdrachten geven:

sudo apt update om de pakketdatabase vanaf de server bij te werken.

sudo apt install --reinstall inkscape om het te herinstalleren inkscape-pakket.

Dit resulteert in een lopend exemplaar van inkscape onder Ubuntu 18.04. Als u het vanaf een terminal start in plaats van de GUI, ziet u mogelijk een waarschuwing als "Kan de canberra-gtk-module niet laden". U kunt ervoor kiezen om de waarschuwing te negeren (inkscape wordt nog steeds gestart) of om het op te lossen met sudo apt install libcanberra-gtk-module

Opmerking: beide van de bovengenoemde pakketten vereisen dat u schakel de universe-opslagplaats in voordat u probeert te installeren.


1
2017-07-17 16:18